Page 1 of 2 12 LastLast
Results 1 to 10 of 20

Thread: Screen Tearing Finally SOLVED! 4 Easy Steps and reduce Choppiness! and add VSync Too!

  1. #1
    Join Date
    Jul 2008
    Location
    Vancouver
    Beans
    338
    Distro
    Ubuntu 18.04 Bionic Beaver

    Screen Tearing Finally SOLVED! 4 Easy Steps and reduce Choppiness! and add VSync Too!

    *** Updated below for Ubuntu 18.04 Bionic Beaver - a even Better Solution, with some tips to minimize Window Dragging Choppiness!

    NOTE: Read Post 7 for a better updated way which is not Nvidia Driver specific
    add this line

    options nvidia-drm modeset=1
    note no driver # needed anymore and to be sure I just upgraded from 390 to 397 and still VSyncing and no tearing WooHoo.

    Good News, Ubuntu 17.10 Beta

    Screen Tearing has plagued linux/Ubuntu with Nvidia Proprietary Drivers, as we ALL know.

    And it is TOTALLY FIXED (for at least this reboot)

    All give the long and short of it.

    Short,
    Upgrade to Ubuntu 17.10, ...
    and Log into Ubuntu Session ... NOT Gnome Session (and YES they BOTH use GDM3, and NOT LightDM anymore)
    - this cut out 70% of the tearing when moving around Chrome's screen etc. etc.
    - then, PRIME Synchronization on Optimus, All Tearing GONE, ALL of it!
    WooHOO FINALLY!

    the Longer Answer
    Why does Ubuntu's Session work better than Gnome's, and yes they both look EXACTLY the same ... a full Gnome3 Awesome DE. But it may have something to do with a better xwayland integration (X on top of Wayland) ... Wayland is the future but not quite ready and not ready for Optimus at all YET.

    for PRIME Synchronization on Optimus (the lack of synchronization has has plagued optimus Laptops Using Nvidia for 3-4 years)
    15/10/17
    https://ubuntuforums.org/showthread.php?t=2365449 .... For Full Instructions
    My Notes
    Code:
    sudo nano /etc/modprobe.d/zz-nvidia-modeset.conf
    ∘ add: options nvidia_384_drm modeset=1
    Code:
    sudo update-initramfs -u
    ∘ reboot
    ‣ Note: one could also just edit /etc/modprobe.d/nvidia-graphics-drivers.conf on the last line instead on creating a new file. Same affect, the new file method may be slightly more persistent, i.e., an update to nvidia that doesn't up the version #..

    • To check -
    Code:
    sudo cat /sys/module/nvidia_drm/parameters/modeset
    ‣ Should say "y" for modeset=1

    and can
    Code:
     xrandr --verbose
    ‣ 1st. section, (the laptop display), should show PRIME Synchronization: 1

    Great New - SOLVED I hope.

    Trying to share the Good News!, Mark
    Last edited by markackerman8@gmail.com; August 7th, 2018 at 07:42 PM. Reason: Updated below for Ubuntu 18.04 Bionic Beaver - a even Better Solution, with some tips to minimize Window Dragging Choppiness!

  2. #2
    Join Date
    Jul 2008
    Location
    Vancouver
    Beans
    338
    Distro
    Ubuntu 18.04 Bionic Beaver

    Re: Screen Tearing Finally SOLVED! 4 Simple Steps

    Easy Peasy - WOW

    But here is an update with a simple clean answer, just confirmed it is working after i updated my driver and screen tearing came back, but i remembered I needed to add the specific driver number to the line .... IMPORTANT

    Code:
    sudo nano /etc/modprobe.d/zz-nvidia-modeset.conf
    add this line to the bottom:
    options nvidia_387_drm modeset=1
    Simply make sure the number matches your proprietary driver #, in my case ...
    NVIDIA Driver Version: 387.12 ... therefore you need the
    nvidia_387_drm
    in the line.

    Code:
    sudo update-initramfs -u
    Reboot

    Please say thanks if I helped - Wow So Simple 3 years Later - WHY!!

    Anyway Good Luck, Mark
    Last edited by markackerman8@gmail.com; October 25th, 2017 at 12:30 AM.

  3. #3
    Join Date
    Nov 2012
    Location
    Halloween Town
    Beans
    Hidden!
    Distro
    Xubuntu Development Release

    Re: Screen Tearing Finally SOLVED! 4 Easy Steps

    Thread moved to General Help since is 17.10 is already released

  4. #4
    Join Date
    Jun 2007
    Beans
    16,982

    Re: Screen Tearing Finally SOLVED! 4 Simple Steps

    Quote Originally Posted by markackerman8@gmail.com View Post
    OK So no views - WOW
    The "Views" deal in this forum is currently useless, probably better if it didn't exist..
    Atm views = replies + 1

    Also note this works fine in 16.04.3 image or 16.04.x with the hwe xserver..

  5. #5
    Join Date
    Jul 2005
    Beans
    37
    Distro
    Ubuntu Gnome 16.10 Yakkety Yak

    Re: Screen Tearing Finally SOLVED! 4 Easy Steps

    Found this thread in Google and I made the change now my system is not booting. I get A start job is running for Hold until boot process finished up.

  6. #6
    Join Date
    Apr 2018
    Beans
    1

    Re: Screen Tearing Finally SOLVED! 4 Easy Steps

    Works for me! Thanks!! I am searching for this, since that I bought my notebook, 2 years ago. Very Thanks!
    Last edited by danbroken; April 25th, 2018 at 01:24 PM.

  7. #7
    Join Date
    Jul 2008
    Location
    Vancouver
    Beans
    338
    Distro
    Ubuntu 18.04 Bionic Beaver

    Red face Re: Screen Tearing Finally SOLVED! 4 Easy Steps

    Update: Here's a Better Solution and with a Non Specific Driver Functionality ... i.e.) no need to modify every time you update your Nvidia Driver!

    Get PRIME Synchronization on Optimus


    ∘ Create a new file in /etc/modprobe.d/nvidia-drm-nomodeset.conf
    Code:
    sudo gedit /etc/modprobe.d/nvidia-drm-nomodeset.conf
    And make sure the following line is present;
    PHP Code:
    options nvidia-drm modeset=
    After Update Intramfs,

    Code:
    sudo update-initramfs -u
    and Reboot

    ∘ To check if it (Synchronization) is NOW set or not set use this command:

    Code:
    sudo cat /sys/module/nvidia_drm/parameters/modeset
    It should say "y" for modeset=1, which means it is synchronized at 60 fps (I believe) for your Monitor. ... and All Screen Tearing should be gone
    for ex. HDMI-1-1, or eDP-1-1
    Solution (now for none specific Nvidia Drivers - AWESOME!)
    DONE!
    ################################################## ####

    And to Finally get Nvidia Window Dragging almost as SMOOTH as with the nouveaux driver
    Here is what I just did in My recent 18.04 re-install, and it was indeed choppy!

    The obvious was set Nvidia to FULL Quality in Nvidia Settings / OpenGL Settings, and ...
    in PowerMizer Tab, select "Prefer Maximum Performance", ...

    but still not great and I remembered I had not adjusted my swap tendancy to a MUCH lower Value (If you have MORE than enough RAM)

    Swappiness (to Check and it is always defaulted at 60)

    Code:
    cat /proc/sys/vm/swappiness
    ‣ if 60

    Code:
    sudo gedit /etc/sysctl.conf
    And add these two lines at the bottom and reboot
    PHP Code:
    # sharply reduce Swappiness inclination
    vm.swappiness=10 
    , and some people set it to 5,1, or even 0!

    Reboot, and reset your Nvidia Settings as per above, and Window Dragging is ...

    MUCH SMOOTHER!!!!!

    Always trying to Help, Mark

  8. #8
    Join Date
    Dec 2007
    Location
    Brazil
    Beans
    128
    Distro
    Ubuntu 16.04 Xenial Xerus

    Re: Screen Tearing Finally SOLVED! 4 Easy Steps

    Quote Originally Posted by markackerman8@gmail.com View Post
    Update: Here's a Better Solution and with a Non Specific Driver Functionality ... i.e.) no need to modify every time you update your Nvidia Driver!

    Get PRIME Synchronization on Optimus


    ∘ Create a new file in /etc/modprobe.d/nvidia-drm-nomodeset.conf
    Code:
    sudo gedit /etc/modprobe.d/nvidia-drm-nomodeset.conf
    And make sure the following line is present;
    PHP Code:
    options nvidia-drm modeset=
    After Update Intramfs,

    Code:
    sudo update-initramfs -u
    and Reboot

    ∘ To check if it (Synchronization) is NOW set or not set use this command:

    Code:
    sudo cat /sys/module/nvidia_drm/parameters/modeset
    It should say "y" for modeset=1, which means it is synchronized at 60 fps (I believe) for your Monitor. ... and All Screen Tearing should be gone
    for ex. HDMI-1-1, or eDP-1-1
    Solution (now for none specific Nvidia Drivers - AWESOME!)
    DONE!
    ################################################## ####

    And to Finally get Nvidia Window Dragging almost as SMOOTH as with the nouveaux driver
    Here is what I just did in My recent 18.04 re-install, and it was indeed choppy!

    The obvious was set Nvidia to FULL Quality in Nvidia Settings / OpenGL Settings, and ...
    in PowerMizer Tab, select "Prefer Maximum Performance", ...

    but still not great and I remembered I had not adjusted my swap tendancy to a MUCH lower Value (If you have MORE than enough RAM)

    Swappiness (to Check and it is always defaulted at 60)

    Code:
    cat /proc/sys/vm/swappiness
    ‣ if 60

    Code:
    sudo gedit /etc/sysctl.conf
    And add these two lines at the bottom and reboot
    PHP Code:
    # sharply reduce Swappiness inclination
    vm.swappiness=10 
    , and some people set it to 5,1, or even 0!

    Reboot, and reset your Nvidia Settings as per above, and Window Dragging is ...

    MUCH SMOOTHER!!!!!

    Always trying to Help, Mark
    That worked flawlessly on my Dell notebook with NVidia GT-730M (Optimus) with Kubuntu 18.04. It fixed also all the icon animations after install nvidia-driver-390 and nvidia-prime packages (after installation they were performing animations too much faster than normal, like there was switched on a turbo button).

    Thank you very much!
    "Linux has half of my heart"
    http://www.adamiworks.com

  9. #9
    Join Date
    Jul 2008
    Location
    Vancouver
    Beans
    338
    Distro
    Ubuntu 18.04 Bionic Beaver

    Re: Screen Tearing Finally SOLVED! 4 Easy Steps and reduce Choppiness Too!

    You are VERY Welcome mate!

  10. #10
    Join Date
    Nov 2006
    Beans
    Hidden!

    Re: Screen Tearing Finally SOLVED! 4 Easy Steps and reduce Choppiness Too!

    Quote Originally Posted by markackerman8@gmail.com View Post
    Code:
    options nvidia_384_drm modeset=1
    You sir, are a hero. And I registered this forum just to make sure you knew it.

    It might be worth mentioning that it initially didn't work for me, so I tried with different versions:

    Code:
    options nvidia_396_drm modeset=1
    options nvidia-396-drm modeset=1
    options nvidia_drm modeset=1
    options nvidia-drm modeset=1
    And now at least one of them worked - so it won't be too hard for me to find out which one by eliminating them one by one.

    A million of kisses all over your special cheeks.

Page 1 of 2 12 LastLast

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •