Results 1 to 2 of 2

Thread: Unable to install Ubuntu Server 14.04.1

  1. #1
    Join Date
    Nov 2014

    Unable to install Ubuntu Server 14.04.1

    I've been trying to install Ubuntu Server to a Dell Notebook, since it has no CD Drive, I'm forced to use an SD card (more on that later), I can boot from the SD card, but when it comes to detect the CD, it finds no CD:

    There was a problem reading data from the CD-ROM. Please make sure it is in the drive. If retrying does not work, you should check the integrity of your CD-ROM.

    Failed to copy file from CD-ROM. Retry?

    I've tried multiple solution I've found here, and but none of them have worked.

    Here's a recollection of the things I've tried:

    1. When you get the error, Alt-F2 to a second console.
    2. Find out which device your USB stick is (tail -n 100 /var/log/syslog)
    3. Then mount it to /cdrom (mount -t vfat /dev/sd[abcd] /cdrom
    4. Alt-F1 to get back to the install console, and try detecting again

    This gives me the error:

    mounting /dev/sdb on /cdrom failed: No such file or directory

    I'm sure the SD card is /dev/sdb, so I'm not sure what's causing this problem.

    I had the similar problem with ubuntu 10.04 and I managed to solve it using documentation from ubuntu site. There is an issue described
    "If you get "Incorrect CD-ROM detected" error on detection stage, reboot, press F6 and then ESC to go to manual boot line editing, and add the option 'cdrom-detect/try-usb=true'." so I did similar thing but at the start of installation. On the main screen I pressed TAB button and added the line from the citation and instalation worked just fine. I hope that someone will find this useful.
    This gives me the error:

    Could not find kernel image: cdrom-detect/try-usb=true

    There is a script that fixes truncated names in the USB.
    Essentially, what this script does is to rename the files that were longer than 64 characters, and were then truncated by the CD-ROM's name size limit. (Two, UDEB files that were .UDE files)

    This was suggested on another thread (renaming the .UDE files to .UDEB) which I can't find as of now.

    Also, for some reason my computer is giving an error when I try to use USB drives:

    An operating system wasn't found. Try disconnecting any drives that don't containg an operating system.
    Press Ctrl + Alt + Delete

    I've tried them on all my USB ports, but I keep getting the same error..

    I really need some help. Thanks!

    PS: I used UnetBootin to make the USBs/SD bootable.
    Last edited by marcelo14; November 24th, 2014 at 06:56 AM.

  2. #2
    Join Date
    May 2015

    Re: Unable to install Ubuntu Server 14.04.1

    The problem was that the ISO image isn't designed to be used with unnetbootin or the USB creator tools. Instead, a direct dd to the USB device is all you need.

    dd if=ubuntu-14.04.2-server-amd64.iso of=/dev/sdb bs=16M

    (obviously, replace /dev/sdb with your USB key, but don't use any partitions (i.e. don't use /dev/sdb1, /dev/sdb2, etc -- just the whole device)


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts