Page 1 of 2 12 LastLast
Results 1 to 10 of 13

Thread: Grub menu missing Linux Kernel entries

  1. #1
    Join Date
    Jun 2007
    Location
    High Desert, So. Calif.
    Beans
    183
    Distro
    Ubuntu 14.04 Trusty Tahr

    Grub menu missing Linux Kernel entries

    From a previous thread, I repaired my grub2 menu, but had multiple entries for my Windows 7, memory test 86+ and Linux Kernels. I installed Grub Customizer to see if I could eliminate the extra entries and keep only one set. I screwed up royally. When I restarted my computer, the Grub Menu only had one each of the Windows 7 loader, memory test 86+ and a memory test 86+ (serial console 115200) My Linux Kernel entries were missing. Now, I can't boot into Ubuntu. Short of re-installing Ubuntu, where can I start to fix this? sigh
    Asus P5N-D, E8500, PC-6400 8 GB
    2ea WD 320GB HD's,9600 GeForce GSO 764MB,
    Windows 7-64Bit/Ubuntu 14.04 64 Bit

  2. #2
    Join Date
    Jan 2007
    Beans
    Hidden!
    Distro
    Ubuntu Development Release

    Re: Grub menu missing Linux Kernel entries

    Welcome back gilloz.

    Assuming (from your previous thread) that the kernels are still there but Grub Customizer isn't letting you see them, try booting from the Grub menu. I'll assume your Ubuntu installation is on sda5 (hd0,5). If it is somewhere else, taylor the commands...

    At the Grub menu (hold down SHIFT during boot if you don't see it):

    Code:
    set prefix=(hd0,5)/boot/grub
    set root=(hd0,5)
    insmod linux
    linux /vmlinuz root=/dev/sda5 ro
    initrd /initrd.img
    boot
    If you can't load the kernel shortcut above, try the longer version. Since I don't know which kernel you are using, you will have to fill in the correct information. If you have a 'grub' prompt, you should be able to type part of the kernel and initrd.img names and use TAB to complete the name (generic or generic-pae may or may not be part of your kernel name):
    Code:
    set prefix=(hd0,5)/boot/grub
    set root=(hd0,5)
    insmod linux
    linux /boot/vmlinuz-X.X.X-X-generic root=/dev/sda5 ro
    initrd /initrd.img-X.X.X-X-generic
    boot
    If it boots, I suggest purging grub, removing all bits of Grub Customizer again (see the GC link for how to do this), then reinstalling GRUB and we can then work on reducing your menu entries.
    Back to Xorg...

    Retired.

  3. #3
    Join Date
    Nov 2004
    Location
    Maine
    Beans
    2,420
    Distro
    Kubuntu

    Re: Grub menu missing Linux Kernel entries

    Quote Originally Posted by gilloz View Post
    From a previous thread, I repaired my grub2 menu, but had multiple entries for my Windows 7, memory test 86+ and Linux Kernels. I installed Grub Customizer to see if I could eliminate the extra entries and keep only one set. I screwed up royally. When I restarted my computer, the Grub Menu only had one each of the Windows 7 loader, memory test 86+ and a memory test 86+ (serial console 115200) My Linux Kernel entries were missing. Now, I can't boot into Ubuntu. Short of re-installing Ubuntu, where can I start to fix this? sigh
    Hi you may want to try boot-repair also I'd try it first if it works you'll save yourself some time you can get it here
    Wireless script
    Dave
    Registered Linux User #462608
    Morse Code an early Digital Mode.

  4. #4
    Join Date
    Jun 2007
    Location
    High Desert, So. Calif.
    Beans
    183
    Distro
    Ubuntu 14.04 Trusty Tahr

    Re: Grub menu missing Linux Kernel entries

    Thanks guys for your quick responses. OK, here is where I stand. My bootloader is on sda1 next to my Windows 7 installation which is on sda2. When I get my Grub menu at startup, I only have 3 choices. Windows 7 (loader) (on/dev/sd2), Memory Test(memtest86+) and Memory Test(memtest86+, serial console 115200). Ubuntu kernels are missing from the listing. I cannot start and boot into Ubuntu, so I have no access to the Terminal. When I am in the Grub menu at startup, I can get a Command Line which gives me a cursor labeled grub>. I tried entering Linux and it comes back Kernel not specified. I tried entering my present kernel, which is Ubuntu,with Linux 3.2.0-27-generic and it comes back with either unknown or not known, I forgot. In any case, I cannot get Ubuntu started. kc1di, where is this boot-repair located? I did try a procedure for restoring Grub2 after installation of Windows, and that did nothing for me. I somehow have to undo what Grub Customizer did. Thanks
    Asus P5N-D, E8500, PC-6400 8 GB
    2ea WD 320GB HD's,9600 GeForce GSO 764MB,
    Windows 7-64Bit/Ubuntu 14.04 64 Bit

  5. #5
    Join Date
    Jan 2007
    Beans
    Hidden!
    Distro
    Ubuntu Development Release

    Re: Grub menu missing Linux Kernel entries

    Click the Boot Repair link in my signature line. You can install and run it from the LiveCD. In addition to the 'Recommended Repair' option, you may need to purge grub from the Advanced option and get rid of any Grub Customizer files as well.

    I'm assuming from your post you tried running the commands above from the Grub prompt and were unsuccessful. Since your Ubuntu is on sda1, the commands would use (hd0,1).
    Back to Xorg...

    Retired.

  6. #6
    Join Date
    Jun 2007
    Location
    High Desert, So. Calif.
    Beans
    183
    Distro
    Ubuntu 14.04 Trusty Tahr

    Re: Grub menu missing Linux Kernel entries

    OK. Here is an update. I located a Boot Repair for Grub2 at a site called How to Geeks. I ran through that procedure and I finally got my regular menu back. I can now access Ubuntu. This time I do not have many duplicates, but there are a few. What is the best way to eliminate the duplicate entries? Don't want to mess with Grub Customizer again. Drs305, can I just do the sudo apt-get purge grub-customizer to get rid of it and it's files without going through the whole purge procedure? Kc1di, if that was the boot repair you mentioned, then thanks.

    Added: Drs305, your Boot Repair link was the same program that I found in How to Geeks. I somehow missed your last statement on that. Thank you also for that. Now to get rid of those multiple entries.
    Last edited by gilloz; July 27th, 2012 at 02:28 PM.
    Asus P5N-D, E8500, PC-6400 8 GB
    2ea WD 320GB HD's,9600 GeForce GSO 764MB,
    Windows 7-64Bit/Ubuntu 14.04 64 Bit

  7. #7
    Join Date
    Jan 2007
    Beans
    Hidden!
    Distro
    Ubuntu Development Release

    Re: Grub menu missing Linux Kernel entries

    By default you should just have one kernel and recovery mode, a submenu "Previous Linux versions", memtest86+ and your Windows entries.

    If you open /etc/default/grub as root, you can remove the recovery mode if you wish by uncommenting (removing the # symbol) from
    #GRUB_DISABLE_RECOVERY="true"
    Save the file.

    To remove the memtest entries, run:
    Code:
    sudo chmod -x /etc/grub.d/memtest86+
    Run update-grub after making all the changes.

    I'm about off to work. If you still have entries you don't want please post your grub.cfg file so we can see what menu items you have and where they are located.
    Back to Xorg...

    Retired.

  8. #8
    Join Date
    Jun 2009
    Location
    SW Forida
    Beans
    Hidden!
    Distro
    Kubuntu

    Re: Grub menu missing Linux Kernel entries

    In addition to drs305's suggestions.

    What files are in /etc/grub.d ?
    Some of the procedures on reordering boot menu are copying the scripts like 30_os-prober to some other number earlier in the order like 07_ . But then a reinstall of grub may create duplicate os-prober scripts which creates duplicate entries.

    Default scripts:
    fred@fred-Precise:/etc/grub.d$ ls
    00_header 10_linux 20_memtest86+ 40_custom 41_custom
    05_debian_theme 20_linux_xen 30_os-prober 40_custom~ README
    UEFI boot install & repair info - Regularly Updated :
    https://ubuntuforums.org/showthread.php?t=2147295
    Please use Thread Tools above first post to change to [Solved] when/if answered completely.

  9. #9
    Join Date
    Jun 2007
    Location
    High Desert, So. Calif.
    Beans
    183
    Distro
    Ubuntu 14.04 Trusty Tahr

    Re: Grub menu missing Linux Kernel entries

    There are only two items that need removing from the grub.cfg file. It is, Windows 7 (loader) (on/dev/sd2) and "Previous Kernels" that is it. Two entries of windows 7 are shown in the .cfg file. Previous kernels has no other listing below it.
    Asus P5N-D, E8500, PC-6400 8 GB
    2ea WD 320GB HD's,9600 GeForce GSO 764MB,
    Windows 7-64Bit/Ubuntu 14.04 64 Bit

  10. #10
    Join Date
    Jun 2009
    Location
    SW Forida
    Beans
    Hidden!
    Distro
    Kubuntu

    Re: Grub menu missing Linux Kernel entries

    You often get two Windows entries as a second one is the recovery partition. You can also houseclean out old kernels to remove from list, but most of us suggest keeping two just in case something happens to the one you are using.

    Check current kernel I also keep one older just in case:
    uname -a
    lsb_release -a
    Go to Synaptic Package Manager and search for linux-image.
    More info in post #8
    http://ubuntuforums.org/showthread.php?t=1283521
    UEFI boot install & repair info - Regularly Updated :
    https://ubuntuforums.org/showthread.php?t=2147295
    Please use Thread Tools above first post to change to [Solved] when/if answered completely.

Page 1 of 2 12 LastLast

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •