Page 1 of 3 123 LastLast
Results 1 to 10 of 29

Thread: Keyboard layout reverting to US on (every) reboot

  1. #1
    Join Date
    Oct 2009
    Location
    Chesterfield, UK
    Beans
    319
    Distro
    Ubuntu 11.10 Oneiric Ocelot

    Keyboard layout reverting to US on (every) reboot

    I live in the UK, and have the default UK keyboard, with the layout as US on ubuntu, so I changed it to UK, deleted the US one, applied System-wide. which was fine until it rebooted, then it went right back to US...why is that?...and how can i fix it?

  2. #2
    Join Date
    Feb 2010
    Location
    Nouvelle-Aquitaine
    Beans
    173
    Distro
    Kubuntu 18.04 Bionic Beaver

    Re: Keyboard layout reverting to US on (every) reboot

    What I did is:
    System > Preferences > Keyboard preference > Layouts tab
    Select keyboard model
    Select layout United Kingdom
    Apply system-wide
    £ above 3 works for me
    If that's what you're trying to achieve
    Hope that helps

    Addendum [Friday, 26 February 2010 10:29 AM]
    There's an option for selecting the keyboard at the bottom of the login screen.
    Last edited by boxcorner; February 26th, 2010 at 10:30 AM.

  3. #3
    Join Date
    Mar 2010
    Location
    England
    Beans
    180
    Distro
    Xubuntu 12.04 Precise Pangolin

    Re: Keyboard layout reverting to US on (every) reboot

    I have exactly the same problem with my new install. I've done the 'preferences' bit and removed the USA option but it reverts at every boot.
    I have automatic log-in so I don't see the log-in screen.

    Any known way of removing the USA keyboard permanently?

    Susan

  4. #4
    Join Date
    Jan 2007
    Location
    Israel
    Beans
    145

    Re: Keyboard layout reverting to US on (every) reboot

    Similar problem.
    Set layouts to
    -USA Internations(AltGr dead keys)
    -Israel

    And it resets every boot to USA.

    I should add that clicking on "Reset to Defaults" applies my chosen layouts. but again reverts to USA after reboot.

    What configuration file does ubuntu "ask" to find out which layouts to set at boot?

    I am using Karmic 64.

  5. #5
    Join Date
    Mar 2010
    Location
    England
    Beans
    180
    Distro
    Xubuntu 12.04 Precise Pangolin

    Re: Keyboard layout reverting to US on (every) reboot

    Strangely, mine has worked OK since I complained about it!

    Susan
    Pentium 4, 2.4 GHz 1.5GB RAM
    Xubuntu 12.04
    Computers are my mid-life crisis - it could have been worse!

  6. #6
    Join Date
    Feb 2007
    Beans
    70

    Re: Keyboard layout reverting to US on (every) reboot

    similar problem

    my default is bosnian layout, with german as additional one

    every time I reboot, it switches to some strange layout which doesn't give me letters but some strange symbols. So I always have to remove that stupid layout called ba, de

    Any solution?

  7. #7
    Join Date
    Aug 2006
    Beans
    Hidden!

    Re: Keyboard layout reverting to US on (every) reboot

    I have similar problems on two computers running 9.10.

    I would like to have just UK and Latin American layouts installed but I keep being attacked by zombie keyboard layouts.

    On my desktop (shere the system language is Spanish) every time I login the Spanish (ES) layout has been added and is selected even though I remove it every time.

    On my netbook (system language English) every week or so a ghost layout appears as '??' in the system tray icon and produces a seemingly arbitrary group of symbols.

    Does anyone know what parts of the OS have the capacity to install new layouts and how to determine which one is responsible?

    Any help appreciated!

  8. #8
    Join Date
    Mar 2010
    Beans
    1

    Re: Keyboard layout reverting to US on (every) reboot

    I found the same problem, but only on my wife's account. I'd set her keyboard layout to UK through Gnome preferences and every time the US layout would reappear and be selected frustratingly.

    It turned out that on the gdm login screen her choice of keyboard layout in the discreet option bar at the bottom of the screen was set to US. That was then overriding the Gnome layout preference.

    Solution: Selecting the appropriate keyboard layout on the next login solved the problem and GDM remembered the preference for next time.

    This isn't what the user would expect to happen. Is there a way to unify / synchronise the GDM and Gnome keyboard layout preferences ?

  9. #9
    Join Date
    Feb 2007
    Beans
    70

    Re: Keyboard layout reverting to US on (every) reboot

    well, I don't have any login screen

  10. #10
    Join Date
    Dec 2009
    Location
    Russia, Saint-Petersburg
    Beans
    23
    Distro
    Ubuntu Development Release

    Re: Keyboard layout reverting to US on (every) reboot

    Quote Originally Posted by vratnica View Post
    well, I don't have any login screen
    Go System → Administration → Login Screen and choose «Show the screen for choosing who will log in».

Page 1 of 3 123 LastLast

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •