Page 1 of 2 12 LastLast
Results 1 to 10 of 13

Thread: Disable gdm at start-up (Karmic Koala 9.10)

  1. #1
    Join Date
    Feb 2008
    Beans
    4

    Disable gdm at start-up (Karmic Koala 9.10)

    Is it possible to disable gdm at start-up in Karmic (login in a shell after boot)? I know there are some changes from previous versions of Ubuntu.

    It was already proposed to do

    sudo update-rc.d -f gdm remove

    But thats not right anymore

    TIA

    Christian

  2. #2
    Join Date
    Nov 2009
    Beans
    1

    Re: Disable gdm at start-up (Karmic Koala 9.10)

    Hi Christian,

    Don't know if you've already found the solution, but here's what I came up with.
    the issue is that GDM is run from Upstart instead of the old way...

    I couldn't find the "official" way to do it, but, here goes:

    1) edit the /etc/init/gdm.conf
    2) comment out the "start on" line, so that it looks like this
    Code:
    #start on (filesystem
    #          and started hal
    #          and tty-device-added KERNEL=tty7
    #          and (graphics-device-added or stopped udevtrigger))
    This essentially prevents the service from starting up automatically.

    Now, you should be able to start gdm by calling
    Code:
    $ sudo start gdm
    If you just want to start X without starting GDM,
    Code:
    $ startx
    Hope this helps!
    Marc

  3. #3
    Join Date
    Jun 2006
    Location
    Canada
    Beans
    517

    Lightbulb [SOLVED] Disable gdm at start-up (Karmic Koala 9.10)

    I had a hard time because I was following guides that were not tested on 9.10. In fact you don't need to mess with GDM's configuration as GRUB2 is the easiest way to get this done. Here are the steps:

    1 - Edit the GRUB2 configuration defaults

    Code:
    $ sudo gedit /etc/default/grub
    2 - Change the line GRUB_CMDLINE_LINUX_DEFAULT="quiet splash" to

    Code:
    GRUB_CMDLINE_LINUX_DEFAULT="quiet splash text"
    3 - Save and close the grub file

    4 - Update grub so that the changes are propagated to grub's configuration file (to all current and future kernels)

    Code:
    $ sudo update-grub
    That it! Simple right?

    If you ever need to log into gnome, use the startx command. If you want GDM to start use the sudo gdm start command.

    Hope this helps people from wasting hours of trying to disable GDM on 9.10 using older guides that suggest editing gdm.conf, moving gdm.conf, using update-rc.d, rcconf or sysv-rc-conf - none of those worked for me. This was the cleanest/best way I found of doing this.

    Cheers!

    My Top Bugs - Launchpad Profile - Wiki Page

    Appreciate what the severe effort of many converging wills has produced.

  4. #4
    Join Date
    Apr 2005
    Location
    Sydney, Australia
    Beans
    61
    Distro
    Ubuntu

    Smile Re: Disable gdm at start-up (Karmic Koala 9.10)

    A better method.

    Check your current runlevel:

    % runlevel
    N 2


    Edit /etc/init/gdm.conf, and change:

    stop on runlevel [016]

    to:

    stop on runlevel [0216]


    Better to manipulate the runlevels correctly, as in the long-term other services will probably start to use Upstart


    http://soniahamilton.wordpress.com/

  5. #5
    Join Date
    Jul 2009
    Location
    in front of the computer
    Beans
    139
    Distro
    Ubuntu 9.10 Karmic Koala

    Re: Disable gdm at start-up (Karmic Koala 9.10)

    I did that , but now i haven't sound.
    linux user: #498107

  6. #6
    Join Date
    Jul 2009
    Location
    in front of the computer
    Beans
    139
    Distro
    Ubuntu 9.10 Karmic Koala

    Re: Disable gdm at start-up (Karmic Koala 9.10)

    For people that the sound doesn't work:
    -Put start-pulseaudio-x11 in the .xinitrc.

    That's all!!
    linux user: #498107

  7. #7
    Join Date
    Nov 2009
    Location
    Beijing,China
    Beans
    51
    Distro
    Ubuntu 10.04 Lucid Lynx

    Re: [SOLVED] Disable gdm at start-up (Karmic Koala 9.10)

    Quote Originally Posted by komputes View Post
    I had a hard time because I was following guides that were not tested on 9.10. In fact you don't need to mess with GDM's configuration as GRUB2 is the easiest way to get this done. Here are the steps:

    1 - Edit the GRUB2 configuration defaults

    Code:
    $ sudo gedit /etc/default/grub
    2 - Change the line GRUB_CMDLINE_LINUX_DEFAULT="quiet splash" to

    Code:
    GRUB_CMDLINE_LINUX_DEFAULT="quiet splash text"
    3 - Save and close the grub file

    4 - Update grub so that the changes are propagated to grub's configuration file (to all current and future kernels)

    Code:
    $ sudo update-grub
    That it! Simple right?

    If you ever need to log into gnome, use the startx command. If you want GDM to start use the sudo gdm start command.

    Hope this helps people from wasting hours of trying to disable GDM on 9.10 using older guides that suggest editing gdm.conf, moving gdm.conf, using update-rc.d, rcconf or sysv-rc-conf - none of those worked for me. This was the cleanest/best way I found of doing this.

    Cheers!


    I'd appreciate it.But I've still got a problem now in Karmic.I installed both kdm and gdm,after typing "startx" in the command line,I've only to login into Gnome,how could I login kde?Thx!

  8. #8
    Join Date
    Jul 2008
    Location
    Woodstock Cape Town RSA
    Beans
    990
    Distro
    Ubuntu 11.10 Oneiric Ocelot

    Re: [SOLVED] Disable gdm at start-up (Karmic Koala 9.10)

    I can't seem to get GDM to reinstall properly. I somehow borked it, and the only manager that is working is KDM. The new Grub2 setup is very confusing, how does one go about installing GDM?

  9. #9
    Join Date
    Jun 2006
    Location
    Victoria, BC Canada
    Beans
    93
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: Disable gdm at start-up (Karmic Koala 9.10)

    I am also looking for a way to boot my old desktop (now being used as a server) into a lower runlevel. If I use this method:

    Code:
    Check your current runlevel:
    
    % runlevel
    N 2
    
    Edit /etc/init/gdm.conf, and change:
    
    stop on runlevel [016]
    
    to:
    
    stop on runlevel [0216]

    With the lower runlevel I assume I will be able to use ssh and my NFS will still mount but how will I start up X and Gnome should I need to?

  10. #10
    Join Date
    Jul 2007
    Location
    Burlington, NC
    Beans
    1,995
    Distro
    Ubuntu 14.04 Trusty Tahr

    Re: Disable gdm at start-up (Karmic Koala 9.10)

    Quote Originally Posted by mfdc1969 View Post
    With the lower runlevel I assume I will be able to use ssh and my NFS will still mount but how will I start up X and Gnome should I need to?
    to get into Gnome as the current console user:
    Code:
    startx
    to start the gdm service manually to get a GUI login screen:
    Code:
    sudo start gdm

Page 1 of 2 12 LastLast

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •