Results 1 to 2 of 2

Thread: Getting "E297: Write error in swap file" error!

  1. #1
    Join Date
    Aug 2009

    Getting "E297: Write error in swap file" error!

    Dear All,

    I am new to Linux, I have installed Ubuntu in my laptop wich has windows Vista OS.

    When I try to create new file in my home directory, I am getting the error - E297 and E303.
    I guess no space left in my home directory to create or write any files in my home directory.

    While installing the Ubuntu, I have exported the Windows Documents, so I believe it has occupied the whole space in this partition(18.5 GB).

    Help me how to unmount the windows documents and make use of the memory allocated for Ubuntu.

    When I run the df command in my terminal it gives-

    File system 1k-blocks Used Available Use% Mounted On
    /dev/sda7 18239964 17379588 0 100% /

    Thank You,

  2. #2
    Join Date
    Jan 2007
    Melbourne, Australia

    Re: Getting "E297: Write error in swap file" error!

    Hi, if you have free space on the partition that windows is, you can boot a Ubuntu live cd and use gparted (System>Admin>Partition Editor) and shrink down you windows partition and increase the size of the Ubuntu partition, using the resize function.
    Remember to backup your important stuff before working on partitions.
    Ubuntu Newbie Help: irc: #beginners-help on network
    Help others, mark your threads solved.

Tags for this Thread


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts