Page 4 of 5 FirstFirst ... 2345 LastLast
Results 31 to 40 of 45

Thread: One or more of the mounts listed in /etc/fstab/ cannot yet be mounted (Karmic)

  1. #31
    Join Date
    Jul 2009
    Hamilton, New Zealand
    Ubuntu 12.04 Precise Pangolin

    Re: One or more of the mounts listed in /etc/fstab/ cannot yet be mounted (Karmic)

    Not all people in this thread are in the same situation. Some (like the OP) have a functional ubuntu with a warning message about unmounted partitions at boot. In most such cases it is the swap partition that is not being mounted. Others have a more serious problem because their root partition is not mounting.

    I leave it to others to deal with the more serious case. If your buntu is functional however and simply can't find the swap partition it is likely because the UUID of your swap partition changed during the upgrade. This happened to me. There are many ways to fix this. Here is one.

    • Run System-Adminstration-GParted to browse your partitions.
    • Find the swap partition ( in my case /dev/sdb5 ). You might need to select a different disk if you have more than one (button in top right).
    • Right click on the swap partition and select information.
    • Copy the UUID (in my case b993412e-7d08-49c2-98c5-46f2bec39391 )
    • Edit /etc/fstab and look for the line containing the word `swap'.
    • If the UUID in that line doesn't match the actual UUID of your swap partition then you've found the problem.
    • Copy in the correct value. Save.
    • sudo swapon -a (to activate the swap partition) or reboot.

    The fix for inability to mount other partitions is often similar. However if ubuntu isn't running and your root partition isn't mounted then that makes it a lot harder to edit fstab.
    Life's a pitch. And then you sing!

  2. #32
    Join Date
    Jan 2009
    Devon, UK
    Ubuntu 9.10 Karmic Koala

    Re: One or more of the mounts listed in /etc/fstab/ cannot yet be mounted (Karmic)

    Quote Originally Posted by oblivia View Post

    I ran "sudo blkid" to find out the UUID for each partition.
    Then I ran "sudo gedit /etc/fstab" and changed the UUID to the correct one for the swap partition, saved the fstab file, rebooted and I no longer get the error.
    This solution worked for me. However, I HAD NOT moved my swap partition, the error was generated immediately upon upgrading to 9.10. Weird, but there you go.
    9.10 on work desktop (32bit, 2GBRAM, T6320)

    9.10 on Laptop (64bit, 4GBRAM, T6400 Acer Aspire 5735)

  3. #33
    Join Date
    Jul 2005

    Re: One or more of the mounts listed in /etc/fstab/ cannot yet be mounted (Karmic)

    This worked for me and my system just hung after boot up with the same message. I hit "ESC" and followed the instrunctions below and then rebooted:

  4. #34
    Join Date
    Apr 2009
    Ubuntu 9.10 Karmic Koala

    Re: One or more of the mounts listed in /etc/fstab/ cannot yet be mounted (Karmic)

    My problem was that the swap partition was not being mounted at start up. I got the folowing error message at boot:

    swap: waiting for UUID=xxxxxxxx-xxxx-xxxx-xxxx-xxxxxxxxxxxx

    I tried what hawthornso23 suggests above and it has been working fine since then. I tried this as I wasn't comfortable disabling fsck as was suggested elsewhere.

  5. #35
    Join Date
    Sep 2008
    Ubuntu 9.10 Karmic Koala

    Re: One or more of the mounts listed in /etc/fstab/ cannot yet be mounted (Karmic)

    I've the "One or more of the mounts listed in /etc/fstab cannot yet be mounted" problem in a peculiar way.

    I've made a fresh Karmic install in a dual-boot with Windows XP SP3 (but exactly the same problem occured previosly when I upgraded from Jaunty to Karmic).

    This is the uncommented extract from my /etc/fstab file:
    proc            /proc           proc    defaults        0       0
    /dev/sda7 /               ext4    errors=remount-ro 0       1
    /dev/sda5  /datos          vfat    utf8,umask=007,gid=46 0       1
    /dev/sda1  /windows        vfat    utf8,umask=007,gid=46 0       1
    /dev/sda6       none            swap    sw              0       0
    /dev/scd0       /media/cdrom0   udf,iso9660 user,noauto,exec,utf8 0       0
    At the beginning there where the UUIDs in there, but I've replaced them with the /dev/sdaX as they said in lots of threads.

    When I turn on the computer, I select Ubuntu on GRUB menu, and the bootsplash cames. After some seconds, the mentioned error shows up, offering a recovery shell by pressing ESC. If I ignore it, some seconds after (30? 60?) the message disappears, and the bootsplash goes on. Again, after a while, the same error message comes back, and, again, if I wait a while, it disappears, and the boot goes on, but with no problems this time. Then I can do login and use the computer with no troubles.

    It ALWAYS shows the error message EXACTLY 2 times.

    Apart from the UUID change, I also tried the "grub-update" + "dpkg -a" solution, with no results.

    Another curious point is that the error message names every partition by its "/dev/sdaX", except from / ("/dev/sda7"), which is named by its UUID, even when I changed this in /etc/fstab.

    I really don't know what to do now. I can use the computer, and everything is OK - except it takes a LOOOOOONG time to boot.

    Any help?

  6. #36
    Join Date
    Apr 2009

    Re: One or more of the mounts listed in /etc/fstab/ cannot yet be mounted (Karmic)

    I am using the latest Linux Mint 8 and also having exactly the same problem as the above poster.

  7. #37
    Join Date
    Feb 2010

    Talking Re: One or more of the mounts listed in /etc/fstab/ cannot yet be mounted (Karmic)

    I just had a case with the same symptoms, on a Xen domU hosted at RimuHosting. I tried a few of the suggestions here and none of them worked for me. I asked them for help and they had a good suggestion, which was to make sure my /etc/fstab was right, and if necessary create a new VPS with Karmic and inspect that to see what I was doing wrong.

    It turned out to be an /etc/fstab problem after all.

    Here's the WRONG /etc/fstab that I had, which worked for 9.04 and never booted (even after every other trick mentioned here) under 9.10:
    none       /dev/pts devpts mode=0620                 0 0
    none       /proc    proc   defaults                  0 0
    /dev/xvda1 /        ext3   defaults,noatime,relatime 1 0
    /dev/xvda9 swap     swap   defaults,noatime          0 0
    none       /sys     sysfs  noauto                    0 0
    In the recovery shell I could see that /dev/xvda1 and /dev/xvda9 were not present, and in fact only about 8 or 9 files total were in /dev.

    I was able to use mknod to create the missing /dev/xvda1 and /dev/xvda9 using major and minor numbers from the first 2 columns of /proc/diskstats so that I could mount the filesystems, but those manually created entries disappeared upon reboot.

    Also, and probably most importantly, I could see that /sys was *not mounted* and so "ls -l /sys" showed an empty directory. From what I read about udev, it looks in /sys and uses what it finds there to automatically generate a ton of devices (682 files total on this server now that it's working properly). So the fact that there were only about 8 files in /dev was a huge red flag.

    This is the /etc/fstab that works, which is what the RimuHosting new VPS install script made:
    proc           /proc   proc     defaults                  0 0
    /dev/xvda1     /       ext3     defaults,noatime,relatime 1 0
    /dev/xvda9     swap    swap     defaults                  0 0
    I believe that what was happening was that udev was not seeing anything under /sys, and therefore not generating the entries under /dev for the things it found under /sys.

    I think that the cause of that problem was that my /etc/fstab had /sys last, when it should have had it first. Apparently having it not be there at all works also, and might actually be more correct. My /sys definitely has stuff under it and udev created a ton of entries once I rebooted with the new /etc/fstab above.

    So if you're stuck, consider installing Karmic to an empty partition and borrowing a fresh /etc/fstab from that for your busted Karmic installation that won't boot. You could do that on a VPS provider or on a VM on another machine or on an old HD you aren't using or something. It sure helped me to have a clean reference installation of Karmic to examine. If you can do that on the same hardware that isn't booting (fresh install to spare old HD) that's probably best.

    Hope this helps!
    Last edited by Jamie Flournoy; February 7th, 2010 at 07:35 PM.

  8. #38
    Join Date
    Jan 2010

    Re: One or more of the mounts listed in /etc/fstab/ cannot yet be mounted (Karmic)

    I had the same problem (New Installation, Ubuntu Karmic 64bit).
    I configured Eclipse and suddendly this crap got frozen and my system rebootet by itself!
    After that, this error came while booting. mount -n -o remount,rw / (or any other device) did not help.

    I got it working again as I startet Ubuntu with the installation CD (chose try ubuntu), and when the desktop finished loading I just mounted and unmounted the affected partitions and rebooted.

  9. #39
    Join Date
    Sep 2008
    Ubuntu 9.10 Karmic Koala

    Re: One or more of the mounts listed in /etc/fstab/ cannot yet be mounted (Karmic)

    well... some updates here...

    last week i re-installed my windows xp... windows xp instaler first formats the selected partition, then copies the instalation files to that partition, then reboots and boots from that partition, and just there it starts the real instalation...

    well, i formated my windows partition and copied the instalation files... when the system had its reboot, it told me that the partition table was damaged, or could not be recognized, or something like that (don't remember )

    after an hour fighting with a karmic live cd and my partitions and grub, it resulted that my partitions' path changed... what used to be '/dev/sda5' now is '/dev/sda3', and things like that...

    but, the first time i could regenerate grub, my /etc/fstab file still had '/dev/sda5' (and the same with my windows partition - /dev/sda5 was a fat32 data partition, and my windows partition was fat32 too), so the system didn't mount them... just / and swap...

    and, until i changed my /etc/fstab to make the system boot those fat32 partitions, it DIDN'T show the 'One or more of the mounts ... cannot yet be mounted' error...

    after i changed /etc/fstab in order to mount those fat32 partitions, the error came back, and still's here...

    so there's something about those fat32 partitions, i think...

    in my ~ i have some symlinks to folders in my data partition (the fat32 one at /dev/sda3)... and my fstab first has the / entry, then /datos ('data', /dev/sda3) and then /windows (the other fat32 one)...

    i'll try what Jamie Flournoy said... maybe first mounting /datos, so when i mount / it can resolve those symlinks... but i don't think i can mount /datos if i didn't mounted / first...

    but we'll see...

  10. #40
    Join Date
    Dec 2009

    Re: One or more of the mounts listed in /etc/fstab/ cannot yet be mounted (Karmic)

    I am having this problem, as well (9.10). I have no idea what to do

    It started this evening after Firefox crashed while I was trying to watch a YouTube video (another poster here mentioned something similar). I can't boot normally; right now I'm on the live CD to seek help.

    I went to System > Administration > GParted to find the swap partition UUID (760878d8-6c0f-4841-9b96-3c80672605e1). I thought maybe that was the problem - the swap partition not mounting at boot up. I tried "sudo nano -Bw /etc/fstab" in terminal. Here is what I ended up with:

    # /etc/fstab: static file system information
    # Use 'blkid -o value -s UUID' to print the universally unique identifier
    # for a device; this may be used with UUID= as a more robust way to name
    # devices that works even if disks are added and removed. See fstab(5).
    # <file system> <mount point> <type> <options> <dump> <pass>
    proc /proc proc defaults 0 0
    # / was on /dev/sdb1 during installation
    UUID=bea739ac-dc3a-4af4-ba1b-9430e11d5158 / ext3 errors=remount=ro 0 1
    # /home was on /dev/sda1 during installation
    UUID=a31097ec-c78d-4760-9cf0-2cfcd5aff759 /home ext3 defaults 0 2
    # swap was on /dev/sdb5 during installation
    UUID=760878d8-6c0f-4841-9b96-3c80672605e1 none swap sw 0 0
    /dev/scd0 media/cdrom0 udf , iso9660 user,noauto,exec,utf8 0 0
    /dev/fd0 media/floppy0 auto rw,user,noauto,exec,utf8 0 0
    I am only a beginner here... but I'm wondering if, from the info above, this means that one drive isn't being "seen" on boot up? It says "remount" - is this something I have to do; unmount the drive and then remount? If so... how? The UUID for the swap partition is correct, and I haven't changed any settings at all today, so I've no idea how this came about!

    Also, when trying to reboot from recovery shell, here is the information on the screen (it wouldn't progress any further than this):

    init: mountall-shell main process (763) killed by TERM signal
    root@robine-desktop: ~# mountall start/starting
    General error mounting filesystems.
    A maintenance shell will now be started.
    CONTROL-D will terminate this shell and re-try.
    root@robine-desktop: ~# swapon: /dev/disk/by-uuid/760878d8-6c0f-4841-9b96-3c80672605e1: swapon failed: Device or resource busy
    mountall: swapon /dev/disk/by-uuid/760878d8-6c0f-4841-9b96-3c80672605e1 [1158] terminated with status 255
    mountall: Problem activating swap: /dev/disk/by-uuid/760878d8-6c0f-4841-9b96-3c80672605e1
    One or more of the mounts listed in etc/fstab cannot yet be mounted: (ESC for recovery shell)
    /home: waiting for UUID=a31097ec-c78d-47b0-9cf0-2cfcd5aff759
    mountall: Cancelled
    Any help is very appreciated, as I am very lost right now!!

Page 4 of 5 FirstFirst ... 2345 LastLast


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts