Page 2 of 6 FirstFirst 1234 ... LastLast
Results 11 to 20 of 52

Thread: [SOLVED] Skype green video

  1. #11
    Join Date
    Dec 2008
    Beans
    1

    Re: Skype green video

    Hi all. FWIW justin212k's suggestion
    Code:
    LD_PRELOAD=/usr/lib/libv4l/v4l1compat.so skype
    worked for my logitech quickcam problems. I did not have to install any packages as v4lcompat was already there. Didn't wanna go the gstfakevideo route cause it kills the internal mic.

    Registered to just thank the post.

  2. #12
    Join Date
    Apr 2008
    Location
    Europe
    Beans
    Hidden!
    Distro
    Ubuntu 12.04 Precise Pangolin

    To make it perfect...

    Thanks for the awesome workaround - but i found it a bit annoying to have a terminal open to run skype.

    I made two executable scripts in ~/bin/skype.

    ScreenSkype.sh

    Code:
    #!/bin/sh
    screen -d -m ~/bin/skype/SkypeLauncher.sh
    SkypeLauncher.sh

    Code:
    #!/bin/sh
    LD_PRELOAD=/usr/lib/libv4l/v4l1compat.so skype
    exit 0
    Then i changed the Skype Lancher in the Main Menu to point to ScreenSkype.sh.

    Now I can run Skype with working web cam and without having to have a terminal open.

  3. #13
    Join Date
    Aug 2007
    Location
    Bangkok, TH
    Beans
    410

    Re: Skype green video

    My Video is working now! With the command
    Code:
    LD_PRELOAD=/usr/lib/libv4l/v4l1compat.so skype
    Don't know why it wasn't before, but now it does!

    My webcam is MDTech..
    Code:
    ID 0ac8:303b Z-Star Microelectronics Corp. ZC0303 WebCam
    Edit:
    aaaaalex, was the extra script necessary? You might have your reasons, but I prefer this method:
    Rename (move) /usr/bin/skype to /usr/bin/skype.real
    Then create a script at:
    /usr/bin/skype
    Code:
    #!/bin/sh
    LD_PRELOAD=/usr/lib/libv4l/v4l1compat.so skype.real
    Then give /usr/bin/skype executable permission. My links to skype aren't broken, and there's no need to keep a terminal open just for skype.
    Best of all, my video works! (at least, the video test does.)

    ***Reminder: Be sure to call "skype.real" (NOT skype) to the command in the script. Calling skype in the script will cause your system to run out of memory (due to recursive calls). I made this mistake the first time. I did Ctrl+Alt+Backspace just in time. Thank goodness for the 4GB. There was a long blank screen, and then I had to manually start X again.
    Last edited by lian1238; December 14th, 2008 at 06:30 PM.

  4. #14
    Join Date
    Dec 2008
    Beans
    16

    Re: Skype green video

    Hello everyone,
    i just changed from osx to ubuntu and everything looks nice but i have the same issue with skype. I just get a green static screen.
    In Cheese everything works fine. I tryied all your workaround suggestions
    but nothing seems to work for me.
    When i start skype in a terminal i get the following error message

    nightingale@xxy:~$ skype
    ALSA lib pcm_bluetooth.c:1619:(bluetooth_init) BT_GETCAPABILITIES failed : Input/output error(5)
    ALSA lib pcm_bluetooth.c:1619:(bluetooth_init) BT_GETCAPABILITIES failed : Input/output error(5)
    ALSA lib pcm_bluetooth.c:1619:(bluetooth_init) BT_GETCAPABILITIES failed : Input/output error(5)
    ALSA lib pcm_bluetooth.c:1619:(bluetooth_init) BT_GETCAPABILITIES failed : Input/output error(5)
    ALSA lib pcm_bluetooth.c:1619:(bluetooth_init) BT_GETCAPABILITIES failed : Input/output error(5)
    ALSA lib pcm_bluetooth.c:1619:(bluetooth_init) BT_GETCAPABILITIES failed : Input/output error(5)
    libv4l2: error setting pixformat: Invalid argument
    Starting the process...


    When i start the Cam i see the following error message


    Skype Xv: Xv ports available: 17
    Skype XShm: XShm support enabled
    Skype Xv: Using Xv port 79
    libv4l2: error dequeuing buf: Invalid argument
    I dont know what i did wrong and iam not experienced enough to understand what that means.
    Does anybody have an idea, what could help ?

    Thanks a lot

  5. #15
    Join Date
    Jun 2008
    Beans
    18

    Re: Skype green video

    I'm using similar method (made a skype file in /usr/local/bin etc...)
    Now my webcam works but i can't see other's webcam, it's some random stuff there. Are these things related?

  6. #16
    Join Date
    Dec 2008
    Beans
    16

    Re: [SOLVED] Skype green video

    The Video is working now.

    I removed the Skype Version that i installed via apt (the medibuntu Version)
    and i installed a newer Version from the skype Homepage.

    http://www.skype.com/go/getskype-linux-ubuntu

    Afterwards things worked fine without any Patch or Workaround.

  7. #17
    Join Date
    Nov 2007
    Beans
    78

    Re: [SOLVED] Skype green video

    Hi there,

    I've been following the post, since I have the same problem with my logitech cam in skype. I tried the command in both versions
    Code:
    LD_PRELOAD=/usr/lib/libv4l/v4l1compat.so skype
    and
    Code:
    LD_PRELOAD=/usr/lib/lib32/libv4l/v4l1compat.so skype
    but always get the same error
    Code:
    LD_PRELOAD=/usr/lib/libv4l/v4l1compat.so skype
    ERROR: ld.so: object '/usr/lib/lib32/libv4l/v4l1compat.so' from LD_PRELOAD cannot be preloaded: ignored.
    What am I doing wrong?
    FYI I'm using 64bits...

  8. #18
    Join Date
    Mar 2009
    Beans
    1

    Angry Re: [SOLVED] Skype green video

    can't seem to get aaaalex or lian1238 to work for me but I can get my webcam to work in a terminal with that command line

  9. #19
    Join Date
    Aug 2007
    Location
    Bangkok, TH
    Beans
    410

    Re: [SOLVED] Skype green video

    Quote Originally Posted by Arrgoss View Post
    Hi there,

    I've been following the post, since I have the same problem with my logitech cam in skype. I tried the command in both versions
    Code:
    LD_PRELOAD=/usr/lib/libv4l/v4l1compat.so skype
    and
    Code:
    LD_PRELOAD=/usr/lib/lib32/libv4l/v4l1compat.so skype
    but always get the same error
    Code:
    LD_PRELOAD=/usr/lib/libv4l/v4l1compat.so skype
    ERROR: ld.so: object '/usr/lib/lib32/libv4l/v4l1compat.so' from LD_PRELOAD cannot be preloaded: ignored.
    What am I doing wrong?
    FYI I'm using 64bits...
    Not sure about 64bits. Could you try replacing lib32 with lib64 in the command?

  10. #20
    Join Date
    Jul 2008
    Beans
    2

    Re: [SOLVED] Skype green video

    You need to make sure you install the 32 bit(lib32v4l) version as well. Then this will work.

    Code:
    LD_PRELOAD=/usr/lib32/libv4l/v4l1compat.so skype

Page 2 of 6 FirstFirst 1234 ... LastLast

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •