Page 2 of 2 FirstFirst 12
Results 11 to 16 of 16

Thread: Slow performance when connecting to Vista using rdesktop

  1. #11
    Join Date
    Apr 2005
    Beans
    432
    Distro
    Ubuntu

    Re: Slow performance when connecting to Vista using rdesktop

    The fix of changing the Windows cursor scheme to "None" worked great for Vista, but not so much for Windows 7. The laggy cursor can be fixed by changing to "None", but the cursor turns black instead of white and cannot be seen against a black background.

    Also, all other cursor schemes aside from the default "Aero" theme have nasty artifacts, rendering them useless also.

  2. #12
    Join Date
    Nov 2008
    Beans
    5

    Re: Slow performance when connecting to Vista using rdesktop

    Thanks for letting us know!
    I haven't tried with Windows 7 yet. Let's hope that a new version of Rdesktop is released that deals with these problems.
    I think I might wait upgrading my Vista machine to 7 until I know that the RDP from my Ubuntu machine is working flawlessly.

  3. #13
    Join Date
    Apr 2005
    Beans
    432
    Distro
    Ubuntu

    Re: Slow performance when connecting to Vista using rdesktop

    Ok, so I found a fix that allows you to use the standard "Aero" cursor theme with good performance: use the -z option for rdesktop. This option turns on compression. I wouldn't expect compression to have an effect on the mouse cursor on a 100Mbit LAN, but it does. So here's a working rdesktop command line:

    Code:
    rdesktop -z 192.168.0.5
    To take this a step further and enable rendering of Cleartype fonts, look at this blog post. So if I'm on a LAN, let's combine compression with the "LAN default" RDP experience switch:

    Code:
    rdesktop -z -x 0x80 192.168.0.5
    Optionally, take this further again and install what is, in my opinion, the best VNC/RDP client available for GNOME, GRDC. Version 0.6 works quite well, and has a GUI option for compression. The -x switch can be added as well in the advanced options.


  4. #14
    Join Date
    Jan 2007
    Beans
    2

    Re: Slow performance when connecting to Vista using rdesktop

    Better fix for black background over RDC to see mouse pointer is to change desktop color, go to "Windows color and appearance" and change black color with any other from color palette.

  5. #15
    Join Date
    May 2011
    Beans
    1

    Re: Slow performance when connecting to Vista using rdesktop

    I found that remmina works well for Windows 7 and Vista on Ubuntu. It's a workaround, but still!

  6. #16
    Join Date
    Sep 2009
    Beans
    4

    Re: Slow performance when connecting to Vista using rdesktop

    one more thought from me if you want.
    The network speed from / to ubuntu box may also affecting rdp speed.
    I tried solution from here and my rdp works little faster.

    http://ubuntumanual.org/posts/10/how...peed-in-ubuntu

    add below to /etc/sysctl.conf and
    sudo sysctl -p

    ## increase TCP max buffer size setable using setsockopt()
    net.core.rmem_max = 16777216
    net.core.wmem_max = 16777216
    ## increase Linux autotuning TCP buffer limits
    ## min, default, and max number of bytes to use
    ## set max to at least 4MB, or higher if you use very high BDP paths
    net.ipv4.tcp_rmem = 4096 87380 16777216
    net.ipv4.tcp_wmem = 4096 65536 16777216
    ## don't cache ssthresh from previous connection
    net.ipv4.tcp_no_metrics_save = 1
    net.ipv4.tcp_moderate_rcvbuf = 1
    ## recommended to increase this for 1000 BT or higher
    net.core.netdev_max_backlog = 2500
    ## for 10 GigE, use this, uncomment below
    ## net.core.netdev_max_backlog = 30000
    ## Turn off timestamps if you're on a gigabit or very busy network
    ## Having it off is one less thing the IP stack needs to work on
    ## net.ipv4.tcp_timestamps = 0
    ## disable tcp selective acknowledgements.
    net.ipv4.tcp_sack = 0
    ##enable window scaling
    net.ipv4.tcp_window_scaling = 1
    ##disable ipv6
    net.ipv6.conf.all.disable_ipv6 = 1
    net.ipv6.conf.default.disable_ipv6 = 1
    net.ipv6.conf.lo.disable_ipv6 = 1

Page 2 of 2 FirstFirst 12

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •