Page 1 of 2 12 LastLast
Results 1 to 10 of 11

Thread: How to run 'nvidia-xconfig' as root

  1. #1
    Join Date
    Feb 2007
    Location
    Victoria, Canada
    Beans
    72
    Distro
    Ubuntu 12.04 Precise Pangolin

    How to run 'nvidia-xconfig' as root

    I've just installed Ubuntu 8.10. I have a Nvidia 6600GT video card. I tried to change to a Nvidia driver to make use the higher resolutions of my monitor. When I go into System -> Administration -> Nvidia X server settings, I get the following message:

    "You do not appear to using the NVIDIA X driver. Please edit your X configuration file (just run 'nvidia-xconfig' as root), and restart the X server."

    What do I type to run this and is there a specific directory where I do this? Also, how do I restart the X server?

  2. #2
    Join Date
    Oct 2007
    Beans
    Hidden!
    Distro
    Ubuntu 8.04 Hardy Heron

    Re: How to run 'nvidia-xconfig' as root

    I'm not to familar with installing Graphics cards but I can tell you how to get sudo control... in your terminal:
    sudo -i
    Then type in your password (which wont appear) and press enter.

  3. #3
    Join Date
    Feb 2007
    Location
    Romania
    Beans
    Hidden!

    Re: How to run 'nvidia-xconfig' as root

    open a terminal and type:
    Code:
    sudo nvidia-xconfig
    to restart the X server press Ctrl+Alt+BackSpace.

  4. #4
    Join Date
    Feb 2007
    Location
    Victoria, Canada
    Beans
    72
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: How to run 'nvidia-xconfig' as root

    I used the first command to move into "root@raj-desktop:~#".

    However, when I try to run the command, "sudo nvidia-xconfig", I get the message:

    sudo: nvidia-xconfig: command not found

    Am I in wrong directory?

  5. #5
    Join Date
    Feb 2007
    Location
    Romania
    Beans
    Hidden!

    Re: How to run 'nvidia-xconfig' as root

    How did you install the nvidia driver?

    Please post the output of:
    Code:
    cat /etc/X11/xorg.conf
    and
    Code:
    aptitude search nvidia

  6. #6
    Join Date
    Feb 2007
    Location
    Victoria, Canada
    Beans
    72
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: How to run 'nvidia-xconfig' as root

    I went into System -> Adminstration -> Hardware Drivers

    Output for "cat /etc/x11/xorg.conf" is:

    # xorg.conf (X.Org X Window System server configuration file)
    #
    # This file was generated by dexconf, the Debian X Configuration tool, using
    # values from the debconf database.
    #
    # Edit this file with caution, and see the xorg.conf manual page.
    # (Type "man xorg.conf" at the shell prompt.)
    #
    # This file is automatically updated on xserver-xorg package upgrades *only*
    # if it has not been modified since the last upgrade of the xserver-xorg
    # package.
    #
    # Note that some configuration settings that could be done previously
    # in this file, now are automatically configured by the server and settings
    # here are ignored.
    #
    # If you have edited this file but would like it to be automatically updated
    # again, run the following command:
    # sudo dpkg-reconfigure -phigh xserver-xorg

    Section "Device"
    Identifier "Configured Video Device"
    EndSection

    Section "Monitor"
    Identifier "Configured Monitor"
    EndSection

    Section "Screen"
    Identifier "Default Screen"
    Monitor "Configured Monitor"
    Device "Configured Video Device"
    EndSection


    The output for "aptitude search nvidia" is:

    E: Could not get lock /var/lib/dpkg/lock - open (11 Resource temporarily unavailable)
    E: Unable to lock the administration directory (/var/lib/dpkg/), is another process using it?
    p nvidia-173-kernel-source - NVIDIA binary kernel module source
    i nvidia-173-modaliases - Modaliases for the NVIDIA binary X.Org dri
    p nvidia-177-kernel-source - NVIDIA binary kernel module source
    i nvidia-177-modaliases - Modaliases for the NVIDIA binary X.Org dri
    p nvidia-71-kernel-source - NVIDIA binary kernel module source
    i nvidia-71-modaliases - Modaliases for the NVIDIA binary X.Org dri
    p nvidia-96-kernel-source - NVIDIA binary kernel module source
    i nvidia-96-modaliases - Modaliases for the NVIDIA binary X.Org dri
    p nvidia-cg-toolkit - NVIDIA Cg Toolkit Installer
    i nvidia-common - Find obsolete NVIDIA drivers
    v nvidia-glx -
    c nvidia-glx-173 - NVIDIA binary Xorg driver
    p nvidia-glx-173-dev - NVIDIA binary Xorg driver development file
    c nvidia-glx-177 - NVIDIA binary Xorg driver
    p nvidia-glx-177-dev - NVIDIA binary Xorg driver development file
    p nvidia-glx-71 - NVIDIA binary Xorg driver
    p nvidia-glx-71-dev - NVIDIA binary Xorg driver development file
    p nvidia-glx-96 - NVIDIA binary Xorg driver
    p nvidia-glx-96-dev - NVIDIA binary Xorg driver development file
    v nvidia-glx-dev -
    p nvidia-kernel-common - NVIDIA binary kernel module common files
    v nvidia-kernel-source -
    idA nvidia-settings - Tool of configuring the NVIDIA graphics dr
    p nvidia-xconfig - The NVIDIA X Configuration Tool

  7. #7
    Join Date
    May 2008
    Location
    Ontario, Canada
    Beans
    Hidden!
    Distro
    Ubuntu

    Re: How to run 'nvidia-xconfig' as root

    does envy not work for the nvidia 6600?

    sudo apt-get install ennyng-core envyng-qt

    excellent program to install video drivers.

  8. #8
    Join Date
    Feb 2007
    Location
    Romania
    Beans
    Hidden!

    Re: How to run 'nvidia-xconfig' as root

    The nvidia driver is not installed.

    You can try envy as suggested by cc7gir or reinstall the driver from the terminal:
    Code:
    sudo aptitude purge nvidia-glx-177 nvidia-glx-173
    Code:
    sudo aptitude install linux-headers-`uname -r`
    Code:
    sudo aptitude install nvidia-glx-177 nvidia-settings
    And edit the xorg.conf file if needed:
    Code:
    gksu gedit /etc/X11/xorg.conf
    # xorg.conf (X.Org X Window System server configuration file)
    #
    # This file was generated by dexconf, the Debian X Configuration tool, using
    # values from the debconf database.
    #
    # Edit this file with caution, and see the xorg.conf manual page.
    # (Type "man xorg.conf" at the shell prompt.)
    #
    # This file is automatically updated on xserver-xorg package upgrades *only*
    # if it has not been modified since the last upgrade of the xserver-xorg
    # package.
    #
    # Note that some configuration settings that could be done previously
    # in this file, now are automatically configured by the server and settings
    # here are ignored.
    #
    # If you have edited this file but would like it to be automatically updated
    # again, run the following command:
    # sudo dpkg-reconfigure -phigh xserver-xorg

    Section "Device"
    Identifier "Configured Video Device"
    Driver "nvidia"
    EndSection

    Section "Monitor"
    Identifier "Configured Monitor"
    EndSection

    Section "Screen"
    Identifier "Default Screen"
    Monitor "Configured Monitor"
    Device "Configured Video Device"
    EndSection

  9. #9
    Join Date
    Feb 2007
    Location
    Victoria, Canada
    Beans
    72
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: How to run 'nvidia-xconfig' as root

    I've tried to install using the commands suggested by Sisco311. I then went back and entered the command: sudo nvidia-xconfig

    But I've gotten the following message:

    raj@raj-desktop:~$ sudo -i
    [sudo] password for raj:
    root@raj-desktop:~# sudo nvidia-xconfig

    Using X configuration file: "/etc/X11/xorg.conf".

    VALIDATION ERROR: Data incomplete in file /etc/X11/xorg.conf.
    Device section "Configured Video Device" must have a Driver
    line.

    Backed up file '/etc/X11/xorg.conf' as '/etc/X11/xorg.conf.backup'
    New X configuration file written to '/etc/X11/xorg.conf'

    root@raj-desktop:~#

    Have I missed something?

  10. #10
    Join Date
    Feb 2009
    Beans
    1

    Re: How to run 'nvidia-xconfig' as root

    I was getting the same message after restarting my system after getting the "Display server shut down about 6 times in the last 90 seconds" message. I was able to fix the problem by uninstalling and reinstalling nvidia-glx-177.

Page 1 of 2 12 LastLast

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •