Page 3 of 12 FirstFirst 12345 ... LastLast
Results 21 to 30 of 111

Thread: Webcam works with Cheese, but not with Skype

  1. #21
    Join Date
    Jan 2010
    Beans
    4

    Re: Webcam works with Cheese, but not with Skype

    Quote Originally Posted by onetwothreecool View Post
    ERROR: ld.so: object '/usr/lib/libv4l/v4l1compat.so' from LD_PRELOAD cannot be preloaded: ignored.
    [1] 6239

    i get this error?
    I get this exact same msg. too after it is typed in a terminal window. Anyone, anyone, Bueller, Bueller......?

  2. #22
    Join Date
    Jan 2010
    Beans
    5

    Re: Webcam works with Cheese, but not with Skype

    Quote Originally Posted by swamytk View Post
    To create a shortcut for skype with this fix:

    1. Create a simple script shown below with the name launchskype in your home folder

    2. Set it as executable file. In file browser, right click the file and select "Make Link" option. It will create a link. Cut and paste this link to your desktop.
    3. Double click this shortcut to launch skype. If it is prompted to "display or execute", select execute (or make select as default action in nautilus preferences)
    Thank you very much, I am using Sony VAIO VGN-FT50B & Skype 2.1.0.47,
    the LD_PRELOAD=/usr/lib/libv4l/v4l1compat.so works prefect for me.
    But I am facing the problem to create a shortcut to open the skype without typing this script in terminal each time.
    Although I followed swamytk said every step, but I have no luck still cannot open with the link I created, can anyone give me some hints?

  3. #23
    Join Date
    Mar 2008
    Beans
    9
    Distro
    Ubuntu 9.10 Karmic Koala

    Re: Webcam works with Cheese, but not with Skype

    If you don't want to make a desktop shortcut you can edit the System->Preferences->MainMenu properties for Skype. Just change the Command: field from 'skype' to '/path/to/your/script/skype.sh'

  4. #24
    Join Date
    Jan 2010
    Beans
    5

    Re: Webcam works with Cheese, but not with Skype

    I think I know where I've done wrong, but since I am a rookie of Linux, so I don't know how to solve it.
    To create a shortcut for skype with this fix:

    1. Create a simple script shown below with the name launchskype in your home folder
    I created the launchskype by gedit Text Editor and just save like that, did I make mistake at this part?

    2. Set it as executable file. In file browser, right click the file and select "Make Link" option. It will create a link. Cut and paste this link to your desktop.
    I surfed some website and have the idea how to make it executable file, but I couldn't copy the file to my home folder

    3. Double click this shortcut to launch skype. If it is prompted to "display or execute", select execute (or make select as default action in nautilus preferences)
    Since I couldn't finished the first 2 steps, I didn't get to the 3 step.

    And Thank you for the tips Kyle138, but I didn't see any skype.sh, what is the file of skype.sh?
    I am sorry that may be I asked some stupid question because I don't know Linux at all, but I really want to join this community, since I found Ubuntu is really great and COOL!
    I really willing to learn more about Linux. I hope I can get some help in this forum.

  5. #25
    Join Date
    Mar 2008
    Beans
    9
    Distro
    Ubuntu 9.10 Karmic Koala

    Re: Webcam works with Cheese, but not with Skype

    Gedit is fine for editing a scipt file. Think of it as a .bat file in windows, just a text file containing a list of commands to run.

    There are a couple of ways to make a file executable. From the GUI (nautilus) you just right-click the file, select properties, select the Permissions tab, and check the box []Allow executing file as program. From the command line you would type chmod +x filename

    In my example before the file skype.sh is the one that you created. You named yours launchskype

  6. #26
    Join Date
    Oct 2008
    Location
    Philippines
    Beans
    1,195
    Distro
    Ubuntu 14.04 Trusty Tahr

    Smile Re: Webcam works with Cheese, but not with Skype

    It worked perfectly. Thanks!
    advocating Free and Open Source Software, supporting the Open Web
    fight for your right to party and get your free cloud storage now

  7. #27
    Join Date
    Apr 2008
    Beans
    2
    Distro
    Ubuntu 8.04 Hardy Heron

    Re: Webcam works with Cheese, but not with Skype

    Quote Originally Posted by Chauncellor View Post
    There's something wrong with GStreamer or something. There's a bug report here:

    https://bugs.launchpad.net/ubuntu/+s...4l/+bug/260918

    I haven't checked this out recently as I don't really use Skype all that much, but there's a workaround mentioned in there.

    Run this in a terminal.

    Code:
    LD_PRELOAD=/usr/lib/libv4l/v4l1compat.so skype
    That should fix your problem. I just have my launcher to start up with that code in a terminal, and all is well at the moment. Glancing over the status, it seems that a fix may have been released.

    Good luck
    Thank you so much !!! I was having this problem for month and your solution solved it in a flash !

  8. #28
    Join Date
    Sep 2008
    Beans
    120

    Re: Webcam works with Cheese, but not with Skype

    Thank you so much, solved.....
    - In a world without walls and fences who needs windows and gates?
    - I am Running Linux.. Finally, my PC is valid & Reliable Hereafter.

  9. #29
    Join Date
    Feb 2010
    Beans
    9

    Unhappy Re: Webcam works with Cheese, but not with Skype

    Hello

    I am struggling to get my webcam to work with Skype 2.1.0.81 , it works with Cheese.
    I am running karmic 64-bit.

    desktop:~$ lsusb
    Bus 003 Device 002: ID 046d:08d7 Logitech, Inc. QuickCam Communicate STX
    I have test the "sudo gstreamer-properties" select Video & it only works with "v4l2"

    When I try to run "LD_PRELOAD=/usr/lib/libv4l/v4l1compat.so /usr/bin/skype" I get the following error
    "ERROR: ld.so: object '/usr/lib/libv4l/v4l1compat.so' from LD_PRELOAD cannot be preloaded: ignored."

    Then if I try to run "LD_PRELOAD=/usr/lib32/libv4l/v4l1compat.so /usr/bin/skype" Skype will load without errors, however when I go to test (button) the video, the program crashes with a segmentation fault.

    Would appreciate some help
    Cheers

  10. #30
    Join Date
    Apr 2006
    Beans
    12

    Re: Webcam works with Cheese, but not with Skype

    I tried to open skype with the command you suggest and get this

    Code:
    lotv@lotv-laptop:~$ LD_PRELOAD=/usr/lib/libv4l/v4l1compat.so skype
    X Error, request 42, minor 0, error code 8 BadMatch (invalid parameter attributes) 
    X Error, request 42, minor 0, error code 8 BadMatch (invalid parameter attributes) 
    X Error, request 42, minor 0, error code 8 BadMatch (invalid parameter attributes)
    Any suggestions? Skype seems to be using the correct device but all I see is a plain black screen instead of my beautiful face, It works exactly the same with or without the launcher you use.

Page 3 of 12 FirstFirst 12345 ... LastLast

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •