Page 2 of 2 FirstFirst 12
Results 11 to 19 of 19

Thread: [SOLVED] No Backlight after Suspend - Intrepid

  1. #11
    Join Date
    Jul 2005
    Location
    Sydney, Australia
    Beans
    234
    Distro
    Ubuntu 10.04 Lucid Lynx

    Re: No Backlight after Suspend - Intrepid

    Actually, all I need to do is to change
    Code:
    HAL_PROP_POWER_MANAGEMENT_QUIRK_DPMS_SUSPEND=false
    to
    Code:
    HAL_PROP_POWER_MANAGEMENT_QUIRK_DPMS_SUSPEND=true
    (line 46 of /usr/lib/hal/scripts/linux/hal-system-power-suspend-linux).

    ++kudos to owend

  2. #12
    Join Date
    Jul 2005
    Location
    Sydney, Australia
    Beans
    234
    Distro
    Ubuntu 10.04 Lucid Lynx

    Re: No Backlight after Suspend - Intrepid

    Nope, actually all three must be needed, because after a reboot suspend didn't work with only the DPMS_SUSPEND quirk turned on.

    (I read somewhere that some of these switches are 'sticky', that can sometimes fool you when debugging because you think that you aren't using a particular command, but it's still in effect.)

  3. #13
    Join Date
    Mar 2006
    Beans
    55
    Distro
    Ubuntu 10.04 Lucid Lynx

    Re: [SOLVED] No Backlight after Suspend - Intrepid

    Hey - thanks

    Adding the three lines

    Code:
    HAL_PROP_POWER_MANAGEMENT_QUIRK_S3_BIOS=true
    HAL_PROP_POWER_MANAGEMENT_QUIRK_S3_MODE=true
    HAL_PROP_POWER_MANAGEMENT_QUIRK_DPMS_SUSPEND=true
    after the following (found at line 49)

    Code:
    elif ! env | grep -q HAL_PROP_POWER_MANAGEMENT_QUIRK; then
    worked for me too.

    I'm using a Sony VGN-B3VP laptop with Intrepid.

  4. #14
    Join Date
    Jul 2005
    Location
    Sydney, Australia
    Beans
    234
    Distro
    Ubuntu 10.04 Lucid Lynx

    Re: [SOLVED] No Backlight after Suspend - Intrepid

    I've reported this as a bug in launchpad, with the hope that it may get fixed in a later release. You may like to subscribe or help out there as well:

    https://bugs.launchpad.net/ubuntu/+s...ls/+bug/307126

  5. #15
    Join Date
    Mar 2006
    Beans
    55
    Distro
    Ubuntu 10.04 Lucid Lynx

    Re: [SOLVED] No Backlight after Suspend - Intrepid

    This problem has started up again on my laptop. I think that it may have been installation of some updates, which reintroduced the problem.

    Has anyone else got the same problem?

  6. #16
    Join Date
    Mar 2009
    Beans
    1

    Re: [SOLVED] No Backlight after Suspend - Intrepid

    ARGH. Yes, it is happening to me again now, too. I originally had the problem after upgrade to Intrepid, fixed as per this post. Just installed some updates last night that have broken it again. My first thought was that this file had been overwritten, but I just checked, and it still has the changes in it. >_< Anyone got any other bright ideas?

    *Edited to add: I'm on a VAIO VGN-T140P.

    *Edited again, a bit later: I found Synaptic->File->History and got the list of stuff I updated last night. Looks like the most likely culprit was hal-info. I will keep digging and update here as I figure stuff out.

    last update: hal-info (20081124-0ubuntu1~intrepid) to 20090128-0ubuntu1~intrepid2

    last update before that (working) was: hal-info (20081001-0ubuntu1~hardy1) to 20081124-0ubuntu1~hardy

    *Edit: Yep, okay, I downgraded the package in Synaptic and, voila, I get my LCD back after suspend again.

    For those who don't know how to do it, go into Synaptic and search for the hal-info package. Go to Package->Force Version and select the version prior to the one that's currently installed. Apply to downgrade it. Then to keep Synaptic from wanting to automatically upgrade it again, Package->Lock Version.

    If anyone comes up with the REAL solution to this (e.g. where you still get to upgrade hal-info), I'd definitely be interested in hearing it. Meanwhile, hope this helps someone else.

    *Final edit of the evening, I promise: Just reported the bug here: https://bugs.launchpad.net/ubuntu/+s...fo/+bug/336521
    Last edited by wirehead2501; March 5th, 2009 at 06:12 AM.

  7. #17
    Join Date
    Mar 2007
    Beans
    676
    Distro
    Ubuntu Development Release

    Re: [SOLVED] No Backlight after Suspend - Intrepid

    I've been chasing similar problems on a different machine, and found the same solution (editing the .../hal-system-power-suspend-linux file). Then the update happened and I lost the fix, like you did.

    So I snooped around a bit and found that the HAL information is now used directly out of the HAL database, not from the file we edited. I've restored correct functioning on my machine by using the hal-set-property command - see "man hal-set-property" - to address specific power-management.quirks. For the dpms-suspend quirk it would go like this:

    sudo hal-set-property --udi '/org/freedesktop/Hal/devices/computer' --key "power_management.quirk.dpms_suspend" --bool "true"

    to set it to true, and correspondingly --bool "false" to set it to false.

    I really don't know why the developers are making these changes, without any notification that I can see. The business of setting the correct quirks is getting more and more arcane and complicated, and users are apparently not supposed to trouble with it - leave it to HAL. Well, HAL doesn't know what my machine needs, apparently - or yours. In my case I set all quirks to false, and it works fine!
    Last edited by scradock; April 15th, 2009 at 05:34 AM. Reason: typos
    Sony vaio vgn-fw235j; Synaptics touchpad; triple boot: mint 12 64-bit; Precise 64-bit & Saucy 64-bit. 2TB external USB drive with more...

  8. #18
    Join Date
    Feb 2009
    Beans
    215
    Distro
    Kubuntu 9.04 Jaunty Jackalope

    Re: [SOLVED] No Backlight after Suspend - Intrepid

    I disliked using vbetool to turn off my laptop's backlight. I noticed that I started to have the problem when xrandr automatically initiated after kubuntu detected my tv signal through a connected svideo cable. Disabling xrandr from the post below solved the problem. Now dpms and powerdevil both work.

    http://ubuntuforums.org/showthread.php?t=1137576

  9. #19
    Join Date
    May 2005
    Beans
    65

    Re: [SOLVED] No Backlight after Suspend - Intrepid

    My laptop is an NEC VersaPro VY15F, with an Intel 82852/855GM graphics device. Hibernate worked, but not suspend.

    Before Karmic (9.10), my solution was to edit /usr/lib/hal/scripts/linux/hal-system-power-suspend-linux and change the quirks line to:
    QUIRKS="--quirk-s3-bios --quirk-s3-mode --quirk-dpms-on --quirk-vbe-post --quirk-vbestate-restore"
    (This needed to be redone after each update, since the file got overwritten.)

    Now that file has no effect. Instead, I must add two boot parameters and delete references to the quirks in a file that removes them instead of letting them take effect.

    The first time I suspend, resume works for a moment and then goes into hibernation. After coming out of hibernation, resume works from the second time on. This may be peculiar to my machine.

    Make backups of all files you change. All changes must be made as root.

    My new method:

    1. In /boot/grub/menu.lst
    add i915.modeset=0 nomodeset to the defoptions line. This disables the new kernel mode-setting (KMS):
    ## additional options to use with the default boot option, but not with the
    ## alternatives
    ## e.g. defoptions=vga=791 resume=/dev/hda5
    # defoptions=quiet splash i915.modeset=0 nomodeset

    If menu.lst doesn't exist, your installation uses a new GRUB method.
    If so, edit /etc/defaults/grub
    and add i915.modeset=0 nomodeset:
    GRUB_CMDLINE_LINUX_DEFAULT="quiet splash i915.modeset=0 nomodeset"

    1b) Save and run the command update-grub.

    2. In /usr/lib/pm-utils/sleep.d/98smart-kernel-video
    delete all references to the quirks you need.
    In my case, two quirks are in the section remove_all_video_quirks:
    --quirk-s3-bios --quirk-s3-mode
    and three are in the section have_smart_intel:
    --quirk-dpms-on --quirk-vbe-post --quirk-vbestate-restore

    3) Save and reboot.

    To find the quirks you need, look at the manpage for pm-suspend, and run pm-suspend followed by quirk options. Try combining everything that looks likely, then removing some. Be thorough and patient. Make notes, because you may be rebooting a lot until something works.

    If no combination works, try installing uswsusp and running s2ram, or try TuxOnIce, though I had no luck with either.

    ##########

    Update for Lucid:

    Under Lucid, the instructions above do not work -- with those kernel parameters, I boot into a black screen.
    i915.modeset needs to be on in order to boot.

    1. In /boot/grub/menu.lst
    add i915.modeset=1 to the defoptions line. This enables the new kernel mode-setting (KMS):
    ## additional options to use with the default boot option, but not with the
    ## alternatives
    ## e.g. defoptions=vga=791 resume=/dev/hda5
    # defoptions=quiet splash i915.modeset=0

    If menu.lst doesn't exist, your installation uses a new GRUB method.
    If so, edit /etc/defaults/grub
    and add i915.modeset=0 nomodeset:
    GRUB_CMDLINE_LINUX_DEFAULT="quiet splash i915.modeset=1"

    2) Save and run the command update-grub.

    3) Save and reboot.

    Formerly, after suspending the machine for the first time after each boot, it would recover for a moment and then go into hibernation. After booting out of hibernation, suspend worked find. Now, after suspending for the first time, the machine recovers for a moment and then suspends. After resuming, subsequent suspends work fine.

    I had video trouble with Lucid (apps hanging, system failure on viewing video), which I have solved by installing the newest Ubunu kernel (details are in a different thread).
    Last edited by James Keating; May 24th, 2010 at 04:01 PM. Reason: new method for Lucid

Page 2 of 2 FirstFirst 12

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •