Results 1 to 3 of 3

Thread: Nvidia driver update failed

  1. #1
    Join Date
    Oct 2007

    Nvidia driver update failed

    Hi, i need help regarding the installation of nvidia GTX 550 card driver.
    My pc updated this morning and since cant get the nvidia driver working, I tried purging the nvidia-current and then installing it as someone in this thread suggests:
    But to no avail.
    I got the following output from apt:
    absol@Freiya:~$ sudo apt-get install nvidia-current
    Reading package lists... Done
    Building dependency tree       
    Reading state information... Done
    The following extra packages will be installed:
    The following NEW packages will be installed:
      dkms nvidia-current
    0 upgraded, 2 newly installed, 0 to remove and 0 not upgraded.
    Need to get 33.5 MB of archives.
    After this operation, 98.7 MB of additional disk space will be used.
    Do you want to continue [Y/n]? y
    Get:1 precise/main dkms all [73.1 kB]
    Get:2 precise-updates/restricted nvidia-current i386 295.40-0ubuntu1.1 [33.4 MB]
    Fetched 33.5 MB in 5min 41s (98.2 kB/s)                                                                                                      
    Selecting previously unselected package dkms.
    (Reading database ... 423728 files and directories currently installed.)
    Unpacking dkms (from .../dkms_2.2.0.3-1ubuntu3_all.deb) ...
    Selecting previously unselected package nvidia-current.
    Unpacking nvidia-current (from .../nvidia-current_295.40-0ubuntu1.1_i386.deb) ...
    Processing triggers for man-db ...
    Setting up dkms ( ...
    Setting up nvidia-current (295.40-0ubuntu1.1) ...
    update-alternatives: using /usr/lib/nvidia-current/ to provide /etc/ (i386-linux-gnu_gl_conf) in auto mode.
    update-alternatives: warning: skip creation of /usr/lib32/ because associated file /usr/lib32/nvidia-current/ (of link group i386-linux-gnu_gl_conf) doesn't exist.
    update-alternatives: warning: skip creation of /usr/lib32/vdpau/ because associated file /usr/lib32/nvidia-current/vdpau/ (of link group i386-linux-gnu_gl_conf) doesn't exist.
    update-alternatives: warning: skip creation of /usr/lib32/ because associated file /usr/lib32/nvidia-current/vdpau/ (of link group i386-linux-gnu_gl_conf) doesn't exist.
    update-alternatives: using /usr/lib/nvidia-current/ to provide /etc/ (x86_64-linux-gnu_gl_conf) in auto mode.
    update-initramfs: deferring update (trigger activated)
    update-initramfs: Generating /boot/initrd.img-3.2.0-27-generic-pae
    INFO:Enable nvidia-current
    DEBUG:Parsing /usr/share/nvidia-common/quirks/dell_latitude
    DEBUG:Parsing /usr/share/nvidia-common/quirks/lenovo_thinkpad
    DEBUG:Parsing /usr/share/nvidia-common/quirks/put_your_quirks_here
    DEBUG:Processing quirk Latitude E6530
    INFO:Applying quirk Latitude E6530
    DEBUG:{'Files': {}, 'Vendor': {}, 'Monitor': {}, 'Screen': {0: ['\tIdentifier "My Screen"\n', '\tOption "RegistryDwords" "EnableBrightnessControl=1"\n']}, 'Module': {}, 'SubSection': {}, 'DRI': {}, 'InputDevice': {}, 'Extensions': {}, 'InputClass': {}, 'ServerLayout': {}, 'Device': {0: ['\tIdentifier "My Card"\n', '\tDriver "nvidia"\n', '\tOption "NoLogo" "True"\n']}, 'VideoAdaptor': {}, 'Comments': {}, 'ServerFlags': {}, 'Modes': {}}
    DEBUG:Creating /usr/share/X11/xorg.conf.d/10-nvidia-current-latitude-e6530.conf
    DEBUG:Processing quirk ThinkPad T420s
    INFO:Applying quirk ThinkPad T420s
    DEBUG:{'Files': {}, 'Vendor': {}, 'Monitor': {}, 'Screen': {0: ['\tIdentifier "My Screen"\n', '\tOption "RegistryDwords" "EnableBrightnessControl=1"\n']}, 'Module': {}, 'SubSection': {}, 'DRI': {}, 'InputDevice': {}, 'Extensions': {}, 'InputClass': {}, 'ServerLayout': {}, 'Device': {0: ['\tIdentifier "My Card"\n', '\tDriver "nvidia"\n', '\tOption "NoLogo" "True"\n']}, 'VideoAdaptor': {}, 'Comments': {}, 'ServerFlags': {}, 'Modes': {}}
    DEBUG:Creating /usr/share/X11/xorg.conf.d/10-nvidia-current-thinkpad-t420s.conf
    Loading new nvidia-current-295.40 DKMS files...
    First Installation: checking all kernels...
    Building only for 3.2.0-27-generic-pae
    Building for architecture i686
    Building initial module for 3.2.0-27-generic-pae
    Running module version sanity check.
     - Original module
       - No original module exists within this kernel
     - Installation
       - Installing to /lib/modules/3.2.0-27-generic-pae/updates/dkms/
    depmod....(bad exit status: 139)
    -------- Uninstall Beginning --------
    Module:  nvidia-current
    Version: 295.40
    Kernel:  3.2.0-27-generic-pae (i686)
    Status: Before uninstall, this module version was ACTIVE on this kernel.
     - Uninstallation
       - Deleting from: /lib/modules/3.2.0-27-generic-pae/updates/dkms/
     - Original module
       - No original module was found for this module on this kernel.
       - Use the dkms install command to reinstall any previous module version.
    depmod....(bad exit status: 139)
    DKMS: uninstall completed.
    Error! Problems with depmod detected.  Automatically uninstalling this module.
    DKMS: Install Failed (depmod problems).  Module rolled back to built state.
    dpkg: error processing nvidia-current (--configure):
     subprocess installed post-installation script returned error exit status 6
    Processing triggers for bamfdaemon ...
    Rebuilding /usr/share/applications/bamf.index...
    Processing triggers for initramfs-tools ...
    update-initramfs: Generating /boot/initrd.img-3.2.0-27-generic-pae
    Errors were encountered while processing:
    E: Sub-process /usr/bin/dpkg returned an error code (1)
    Previously tried installing the driver version from the nvidia page (295) which was released this month and fixes the security issue, but i seem to have forgotten the way of installing the driver, as multiple errors presented... I'll try google that next.

    Any more suggestions?

  2. #2
    Join Date
    Oct 2009
    Elgin, IL USA
    Ubuntu 16.10 Yakkety Yak

    Re: Nvidia driver update failed

    I have not had any problems with GTX 550 Ti in 12.04, other than having to use nomodeset during install (no parameters needed after install). nvidia-current 2.95.40 should have been automatically been installed during Ubuntu installation.

    But now your problem may be due to running the script from nvidia website which does not automatically update with kernels and may interfere with automatic updates. So you may have to run that script from nvidia every time you have a kernel update. Not sure how you would purge that to use regular Ubuntu packages that would update automatically.

    I have never used a pae kernel, I use 64-bit whether I need it (8 GB) or not (2 GB tablet PC).
    i5 650 3.2 GHz upgraded to i7 870, 16 GB 1333 RAM, nvidia GTX 1060, 32" 1080p & assorted older computers

  3. #3
    Join Date
    Oct 2007

    Unhappy Re: Nvidia driver update failed

    Hi, thanks for answering, I reached the same conclusion but couldn't find a way to remove the manually installed nvidia driver so I ended installing ubuntu again.

    After installation, the fresh Ubuntu 12.04 installation did not started the graphics but afterwards I booted in fail safe mode and then just chose "resume normal boot" which somehow started successfully the graphical environment, installed successfully the restricted drivers and everything seems to work fine now.

    I did not allowed the updates though, but might try this weekend.

Tags for this Thread


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts