Page 1 of 3 123 LastLast
Results 1 to 10 of 24

Thread: The VPN connection 'xxxxx' failed because there were no valid VPN secrets.

  1. #1
    Join Date
    Feb 2008
    Beans
    21

    The VPN connection 'xxxxx' failed because there were no valid VPN secrets.

    Brand new install of Ubuntu 8.10 (Intrepid Ibex). I installed network-manager-pptp through Synaptic and did a full restart.

    I'm trying to get a VPN connection setup. This is a standard windows VPN host

    The VPN connection 'xxxxx' failed because there were no valid VPN secrets.

    I've googled this error, and tried several suggestions of switching authentication options, but nothing is working.

    How do I get the detailed logs regarding this error?

    Thanks!
    Last edited by giesen2; November 23rd, 2008 at 07:11 PM. Reason: mentioned installing network-manager-pptp

  2. #2
    Join Date
    Jan 2006
    Location
    Not heaven... Iowa
    Beans
    Hidden!
    Distro
    Ubuntu

    Re: The VPN connection 'xxxxx' failed because there were no valid VPN secrets.

    HAve you seen this VPN Client Help page?
    Linux User #415691 Ubuntu User #8629
    Iowa Team (LoCo): [Wiki] [Launchpad]
    IRC channel: #ubuntu-us-ia on irc.freenode.net

  3. #3
    Join Date
    May 2006
    Location
    Colorado, USA
    Beans
    83
    Distro
    Ubuntu 7.10 Gutsy Gibbon

    Re: The VPN connection 'xxxxx' failed because there were no valid VPN secrets.

    I was having the same problem and I used this method:


    Solution Source

    Hi -
    Here's how to get it working in Ubuntu Intrepid for a Windows home network. Before trying this, be sure your router allows PPTP service.
    Open Network Configuration (Start, System, Preferences).
    Highlight your VPN connection, hit Edit.
    At IPv4 Settings Tab: choose method Automatic (VPN).
    At VPN Tab:
    1 - input the IP address of the target computer.
    2 - input your user name. Leave all else blank.
    3 - hit Advanced button.
    At Authentication:
    1 - UNcheck PAP (because PAP means to allow unsecured passage - this is the source of "no shared shared secrets")
    2 - Check CHAP, MSCHAP and MSCHAPv2.
    At Security and Compression:
    1 - Check Use Point-to-point encryption (MPPE)
    2 - Select 128-bit (most secure).
    3 - Check Allow stateful encryption.
    At Echo: check Allow PPP echo packets.
    Leave all else blank. Hit OK, OK to save and get out.
    Note: Your password is requested on VPN startup. I did not try to add it to the keyring.


    This worked for me but no until I removed my password from the actual connection. I am on my VPN right now. I hope this helps.

  4. #4
    Join Date
    Jun 2008
    Beans
    6

    Re: The VPN connection 'xxxxx' failed because there were no valid VPN secrets.

    I think I solved the problem.

    The source of the problem is - the application nm-pptp-auth-dialog wants to access the keyring to search for the password.

    The problem: there is no such record in the keyring table. so it returns an error. Due to a bug, the application do not append the record in the first place!

    solution:

    make a new VPN connection. Connect to it. Click Deny when prompted: "Allow application to access keyring?"

    then enter the password manually, and check "Save password in keyring"

    then click Allow Always

    and Wallah, you have just created the required entry in the keyring! You'll no longer have "no secerts" problem!

    (goto applications > accessories > keyring manager > passwords to see it!)

    Hope this helps. Please let me know if it doesn't.

  5. #5
    Join Date
    Nov 2008
    Beans
    1

    Re: The VPN connection 'xxxxx' failed because there were no valid VPN secrets.

    Thanks Serpent,
    this worked for me too.

    Has this been lodged as a bug?

  6. #6
    Join Date
    Jun 2008
    Beans
    6

    Re: The VPN connection 'xxxxx' failed because there were no valid VPN secrets.

    my pleasure!

    I don't know. should I report it as a bug?

  7. #7
    Join Date
    Jun 2009
    Beans
    1

    Wink Re: The VPN connection 'xxxxx' failed because there were no valid VPN secrets.

    AHHH this is such an annoying error. Unfortunately, none of the info I could find online really fixes it. You can connect if you do not store your password in the key ring, but if you get disconnected, you have to do it all over again every time.

    However, I found a real solution. Uninstall the Gnome Network Manager applet and install the KDE one instead. The bug in in the Gnome applet. The KDE applet also works with Gnome, so you don't need to run KDE. If you need PPTP install Kvpnc as well. I am successfully running both with Gnome, configured them to use PPTP and it worked on the first try, no more errors. It uses the KDE keyring and remembers your password as well.

    This is a serious bug that needs to be fixed, fortunately KDE can save you here.
    Last edited by mothman7; June 24th, 2009 at 06:38 PM.

  8. #8
    Join Date
    Aug 2009
    Location
    hisingen, sweden
    Beans
    235
    Distro
    Ubuntu

    Re: The VPN connection 'xxxxx' failed because there were no valid VPN secrets.

    Any news? Is this bug fixed? Can only find KVpnc KDE and i cant handle it...

  9. #9
    Join Date
    Sep 2009
    Beans
    1

    Re: The VPN connection 'xxxxx' failed because there were no valid VPN secrets.

    Quote Originally Posted by slacker9876 View Post
    I was having the same problem and I used this method:


    Solution Source

    Hi -
    Here's how to get it working in Ubuntu Intrepid for a Windows home network. Before trying this, be sure your router allows PPTP service.
    Open Network Configuration (Start, System, Preferences).
    Highlight your VPN connection, hit Edit.
    At IPv4 Settings Tab: choose method Automatic (VPN).
    At VPN Tab:
    1 - input the IP address of the target computer.
    2 - input your user name. Leave all else blank.
    3 - hit Advanced button.
    At Authentication:
    1 - UNcheck PAP (because PAP means to allow unsecured passage - this is the source of "no shared shared secrets")
    2 - Check CHAP, MSCHAP and MSCHAPv2.
    At Security and Compression:
    1 - Check Use Point-to-point encryption (MPPE)
    2 - Select 128-bit (most secure).
    3 - Check Allow stateful encryption.
    At Echo: check Allow PPP echo packets.
    Leave all else blank. Hit OK, OK to save and get out.
    Note: Your password is requested on VPN startup. I did not try to add it to the keyring.


    This worked for me but no until I removed my password from the actual connection. I am on my VPN right now. I hope this helps.
    Hi, I have similar problem, how do I find out if my router allows PPTP service?

  10. #10
    Join Date
    Apr 2008
    Beans
    135

    Re: The VPN connection 'xxxxx' failed because there were no valid VPN secrets.

    Quote Originally Posted by Black Serpent View Post
    I think I solved the problem.

    The source of the problem is - the application nm-pptp-auth-dialog wants to access the keyring to search for the password.

    The problem: there is no such record in the keyring table. so it returns an error. Due to a bug, the application do not append the record in the first place!

    solution:

    make a new VPN connection. Connect to it. Click Deny when prompted: "Allow application to access keyring?"

    then enter the password manually, and check "Save password in keyring"

    then click Allow Always

    and Wallah, you have just created the required entry in the keyring! You'll no longer have "no secerts" problem!

    (goto applications > accessories > keyring manager > passwords to see it!)

    Hope this helps. Please let me know if it doesn't.
    Verifying that this method works; I can connect to my vpn server now. Running Jaunty x64.

Page 1 of 3 123 LastLast

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •