Results 1 to 8 of 8

Thread: [SOLVED] Surf filesystems through root

  1. #1
    Join Date
    Nov 2008
    Beans
    16

    [SOLVED] Surf filesystems through root

    I triple boot windows ubuntu and SUSE. In SUSE I can surf my files through root, I just have to enter in my root password and I can change anything I want. I am sure you can do that in ubuntu, but how? Thanks in advance

  2. #2
    Join Date
    Sep 2008
    Location
    Korea
    Beans
    938
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: Surf filesystems through root


  3. #3
    Join Date
    Nov 2008
    Beans
    16

    Re: Surf filesystems through root

    I know the advantages and disadvantages of using su. I used SUSE linux for over a year and am just trying ubuntu. I dont want to change folders around and all that stuff through terminal. I read through I'd like it to be in a window like you see normally, except your root. I hate seeing 'error: permission denied.'

  4. #4
    Join Date
    Sep 2008
    Location
    Korea
    Beans
    938
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: Surf filesystems through root

    Then start your GUI applications with gksudo, like
    Code:
    gksudo gedit
    or
    Code:
    gksudo nautilus

  5. #5
    Join Date
    Nov 2008
    Beans
    16

    Re: Surf filesystems through root

    With root:
    Code:
    root@laptop:/home/lxuser# gksudo gedit
    GConf Error: Failed to contact configuration server; some possible causes are that you need to enable TCP/IP networking for ORBit, or you have stale NFS locks due to a system crash. See http://www.gnome.org/projects/gconf/ for information. (Details -  1: Failed to get connection to session: Did not receive a reply. Possible causes include: the remote application did not send a reply, the message bus security policy blocked the reply, the reply timeout expired, or the network connection was broken.)
    GConf Error: Failed to contact configuration server; some possible causes are that you need to enable TCP/IP networking for ORBit, or you have stale NFS locks due to a system crash. See http://www.gnome.org/projects/gconf/ for information. (Details -  1: Failed to get connection to session: Did not receive a reply. Possible causes include: the remote application did not send a reply, the message bus security policy blocked the reply, the reply timeout expired, or the network connection was broken.)
    GConf Error: Failed to contact configuration server; some possible causes are that you need to enable TCP/IP networking for ORBit, or you have stale NFS locks due to a system crash. See http://www.gnome.org/projects/gconf/ for information. (Details -  1: Failed to get connection to session: Did not receive a reply. Possible causes include: the remote application did not send a reply, the message bus security policy blocked the reply, the reply timeout expired, or the network connection was broken.)
    GConf Error: Failed to contact configuration server; some possible causes are that you need to enable TCP/IP networking for ORBit, or you have stale NFS locks due to a system crash. See http://www.gnome.org/projects/gconf/ for information. (Details -  1: Failed to get connection to session: Did not receive a reply. Possible causes include: the remote application did not send a reply, the message bus security policy blocked the reply, the reply timeout expired, or the network connection was broken.)
    
    (gksudo:9984): GConf-CRITICAL **: gconf_value_free: assertion `value != NULL' failed
    
    (gedit:9985): EggSMClient-WARNING **: Failed to connect to the session manager: None of the authentication protocols specified are supported
    
    root@laptop:/home/lxuser#
    Code:
    root@laptop:/home/lxuser# gksudo nautilus
    GConf Error: Failed to contact configuration server; some possible causes are that you need to enable TCP/IP networking for ORBit, or you have stale NFS locks due to a system crash. See http://www.gnome.org/projects/gconf/ for information. (Details -  1: Failed to get connection to session: Did not receive a reply. Possible causes include: the remote application did not send a reply, the message bus security policy blocked the reply, the reply timeout expired, or the network connection was broken.)
    GConf Error: Failed to contact configuration server; some possible causes are that you need to enable TCP/IP networking for ORBit, or you have stale NFS locks due to a system crash. See http://www.gnome.org/projects/gconf/ for information. (Details -  1: Failed to get connection to session: Did not receive a reply. Possible causes include: the remote application did not send a reply, the message bus security policy blocked the reply, the reply timeout expired, or the network connection was broken.)
    GConf Error: Failed to contact configuration server; some possible causes are that you need to enable TCP/IP networking for ORBit, or you have stale NFS locks due to a system crash. See http://www.gnome.org/projects/gconf/ for information. (Details -  1: Failed to get connection to session: Did not receive a reply. Possible causes include: the remote application did not send a reply, the message bus security policy blocked the reply, the reply timeout expired, or the network connection was broken.)
    GConf Error: Failed to contact configuration server; some possible causes are that you need to enable TCP/IP networking for ORBit, or you have stale NFS locks due to a system crash. See http://www.gnome.org/projects/gconf/ for information. (Details -  1: Failed to get connection to session: Did not receive a reply. Possible causes include: the remote application did not send a reply, the message bus security policy blocked the reply, the reply timeout expired, or the network connection was broken.)
    
    (gksudo:10236): GConf-CRITICAL **: gconf_value_free: assertion `value != NULL' failed
    
    (nautilus:10237): libgnomevfs-WARNING **: Unable to create ~/.gnome2 directory: No such file or directory
    Could not create per-user gnome configuration directory `/root/.gnome2/': No such file or directory
    root@laptop:/home/lxuser#

    Not in root:
    Code:
    lxuser@laptop:~$ gksudo nautilus
    (nautilus:10372): libgnomevfs-WARNING **: Unable to create ~/.gnome2 directory: No such file or directory
    Could not create per-user gnome configuration directory `/root/.gnome2/': No such file or directory
    Code:
    lxuser@laptop:~$ gksudo gedit
    GConf Error: Failed to contact configuration server; some possible causes are that you need to enable TCP/IP networking for ORBit, or you have stale NFS locks due to a system crash. See http://www.gnome.org/projects/gconf/ for information. (Details -  1: Failed to get connection to session: Failed to connect to socket /tmp/dbus-qrVrVGdHTx: Connection refused)
    GConf Error: Failed to contact configuration server; some possible causes are that you need to enable TCP/IP networking for ORBit, or you have stale NFS locks due to a system crash. See http://www.gnome.org/projects/gconf/ for information. (Details -  1: Failed to get connection to session: Failed to connect to socket /tmp/dbus-M7vefScBmH: Connection refused)
    GConf Error: Failed to contact configuration server; some possible causes are that you need to enable TCP/IP networking for ORBit, or you have stale NFS locks due to a system crash. See http://www.gnome.org/projects/gconf/ for information. (Details -  1: Failed to get connection to session: Failed to connect to socket /tmp/dbus-4h6qXTF07Z: Connection refused)
    GConf Error: Failed to contact configuration server; some possible causes are that you need to enable TCP/IP networking for ORBit, or you have stale NFS locks due to a system crash. See http://www.gnome.org/projects/gconf/ for information. (Details -  1: Failed to get connection to session: Failed to connect to socket /tmp/dbus-pnAASkvcAM: Connection refused)
    GConf Error: Failed to contact configuration server; some possible causes are that you need to enable TCP/IP networking for ORBit, or you have stale NFS locks due to a system crash. See http://www.gnome.org/projects/gconf/ for information. (Details -  1: Failed to get connection to session: Failed to connect to socket /tmp/dbus-YK5p6YafJj: Connection refused)

  6. #6
    Join Date
    Oct 2007
    Location
    Chennai, India
    Beans
    3,804
    Distro
    Ubuntu Development Release

    Re: Surf filesystems through root

    Quote Originally Posted by L1GTN1NG View Post
    I dont want to change folders around and all that stuff through terminal.
    I hate seeing 'error: permission denied.'
    Not recommended, but:

    Press Alt+F2, then give the command
    Code:
    gksudo nautilus
    or the file manager of your choice.

    root logins are discouraged in Ubuntu, to the extent that it is against forum policy on how to enable root logins.

    If you are logged in as root, do not use gksudo. If you are a regular user, use gksudo to get root-like abilities.
    Last edited by prshah; November 22nd, 2008 at 07:44 PM.
    Cheers,PRShah
    Make your own: Ubuntu, Kubuntu, Xubuntu, Mythbuntu All-in-One Live DVD
    "I never make mistakes; I thought I did, once.. but I was wrong."

  7. #7
    Join Date
    Nov 2008
    Beans
    16

    Re: Surf filesystems through root

    Quote Originally Posted by prshah View Post
    Not recommended, but:

    Press Alt+F2, then give the command
    Code:
    gksudo nautilus
    or the file manager of your choice.

    root logins are discouraged in Ubuntu, to the extent that it is against forum policy on how to enable root logins.

    If you are logged in as root, do not use gksudo. If you are a regular user, use gksudo to get root-like abilities.
    Alt-F2 did the trick. Thanks to both of you!!

  8. #8
    Join Date
    Oct 2007
    Location
    Chennai, India
    Beans
    3,804
    Distro
    Ubuntu Development Release

    Re: Surf filesystems through root

    Quote Originally Posted by L1GTN1NG View Post
    Alt-F2 did the trick. Thanks to both of you!!
    Can you mark the thread solved? Click "Thread Tools" near the upper right hand side of the page, and select "Mark Thread as Solved".
    Cheers,PRShah
    Make your own: Ubuntu, Kubuntu, Xubuntu, Mythbuntu All-in-One Live DVD
    "I never make mistakes; I thought I did, once.. but I was wrong."

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •