Page 1 of 2 12 LastLast
Results 1 to 10 of 18

Thread: weird internet connection issues

  1. #1
    Join Date
    Nov 2008
    Beans
    11

    weird internet connection issues

    In the past week that I have used my Ubuntu laptop my eathernet connection is

    not working at all. well when I looked at the setting for eth0 they were all

    wrong. so I set my DNS and MAC address and assumed the problem would go away. I

    was wrong.

    first the network manager refused to use the auto eth0 and instead created auto

    Ethernet. this had the orgianal bad settings. now I'm stuck on my windows box

    because that is the only this that WILL connect to the internet.

    BTW I checked the help center provided with ubuntu, and preformed the ifdown

    then ifup. sudo ifdown eth0 said the interface wasn't configured. and sudo ifup

    eth0 came up with some odd error.

    If anybody can help please do. I do know quite a bit about the cmd line.

  2. #2
    Join Date
    Nov 2008
    Beans
    11

    Re: weird internet connection issues

    Is this that rare that nobody will help?

  3. #3
    Join Date
    Jan 2007
    Beans
    5,549

    Re: weird internet connection issues

    post output of ifconfig from your terminal

  4. #4
    Join Date
    Dec 2005
    Location
    Sweden, Stockholm
    Beans
    41
    Distro
    Xubuntu 9.10 Karmic Koala

    Re: weird internet connection issues

    could you post the output of (type in a terminal)
    Code:
    cat /etc/resolv.conf
    ------------------------------------------------------------------------------
    AMD Athlon 64 +3800 / ASUS A8N-SLI Premium
    2048 MB DDR / GeForce 7600GS 512 MB / Dell 2407WFP

  5. #5
    Join Date
    Nov 2008
    Beans
    11

    Re: weird internet connection issues

    eth0
    Link encap:Ethernet HWaddr 00:03:0d:12:70:bf
    inet6 addr: fe80::203:dff:fe12:70bf/64 Scope:Link
    UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
    RX packets:22512 errors:0 dropped:0 overruns:0 frame:0
    TX packets:121 errors:0 dropped:0 overruns:0 carrier:0
    collisions:0 txqueuelen:1000
    RX bytes:1369664 (1.3 MB) TX bytes:24965 (24.9 KB)
    Interrupt:19 Base address:0xe800

    lo
    Link encap:Local Loopback
    inet addr:127.0.0.1 Mask:255.0.0.0
    inet6 addr: ::1/128 Scope:Host
    UP LOOPBACK RUNNING MTU:16436 Metric:1
    RX packets:216 errors:0 dropped:0 overruns:0 frame:0
    TX packets:216 errors:0 dropped:0 overruns:0 carrier:0
    collisions:0 txqueuelen:0
    RX bytes:13536 (13.5 KB) TX bytes:13536 (13.5 KB)

    wlan0
    Link encap:Ethernet HWaddr 00:0c:76:c9:f7:a1
    UP BROADCAST MULTICAST MTU:1500 Metric:1
    RX packets:0 errors:0 dropped:0 overruns:0 frame:0
    TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
    collisions:0 txqueuelen:1000
    RX bytes:0 (0.0 B) TX bytes:0 (0.0 B)

    wlan0:
    avahi Link encap:Ethernet HWaddr 00:0c:76:c9:f7:a1
    inet addr:169.254.10.85 Bcast:169.254.255.255 Mask:255.255.0.0
    UP BROADCAST MULTICAST MTU:1500 Metric:1

    wmaster0
    Link encap:UNSPEC HWaddr 00-0C-76-C9-F7-A1-00-00-00-00-00-00-00-00-00-00
    UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
    RX packets:0 errors:0 dropped:0 overruns:0 frame:0
    TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
    collisions:0 txqueuelen:1000
    RX bytes:0 (0.0 B) TX bytes:0 (0.0 B)

  6. #6
    Join Date
    Jan 2007
    Beans
    5,549

    Re: weird internet connection issues

    well i would suggest that you try to use a static ip.. presuming that your router ip address is 192.168.1.1 .. try this http://prash-babu.blogspot.com/2008/...-in-linux.html

  7. #7
    Join Date
    Apr 2008
    Beans
    2

    Re: weird internet connection issues

    I have the same problem. I have tried to make what you suggest using a static IP address (as described in your link). But this does not work! Unfortunately!

  8. #8
    Join Date
    Nov 2008
    Beans
    11

    Re: weird internet connection issues

    I tried the procedeure above. but the result was faliure. I'm going to post my terminal output as well. I might mention that that when I preformed Ipconfig /all to get the gateway and ip off my windows box it told me that the ip was leased out today and and would expire tomorrow. this confirms that I have a dynamic Ip Not a static one.

    the last thing is that when I made the edit to the network interfaces the congiuration file was nearly compleatly barren. I'll post that to.

    Code:
     
    
    heres the cinfig file
    
    auto lo
    iface lo inet loopback
    
    and here is the terminal output
    
    patrick@patrick-laptop:~$ sudo gedit /etc/network/interfaces
    [sudo] password for patrick: 
    patrick@patrick-laptop:~$ sudo /etc/init.d/networking restart
     * Reconfiguring network interfaces...                                   [ OK ] 
    patrick@patrick-laptop:~$ sudo ifdown eth0
    ifdown: interface eth0 not configured
    patrick@patrick-laptop:~$ sudo ifup eth0
    SIOCSIFNETMASK: Invalid argument
    Failed to bring up eth0

  9. #9
    Join Date
    Jan 2007
    Beans
    5,549

    Re: weird internet connection issues

    what is your router's ip address?? post your /etc/network/interfaces file here.. also post output of ifconfig

  10. #10
    Join Date
    Nov 2008
    Beans
    11

    Re: weird internet connection issues

    ifconfig
    Code:
    eth0
    Link encap:Ethernet HWaddr 00:03:0d:12:70:bf
    inet6 addr: fe80::203:dff:fe12:70bf/64 Scope:Link
    UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
    RX packets:22512 errors:0 dropped:0 overruns:0 frame:0
    TX packets:121 errors:0 dropped:0 overruns:0 carrier:0
    collisions:0 txqueuelen:1000
    RX bytes:1369664 (1.3 MB) TX bytes:24965 (24.9 KB)
    Interrupt:19 Base address:0xe800
    
    lo
    Link encap:Local Loopback
    inet addr:127.0.0.1 Mask:255.0.0.0
    inet6 addr: ::1/128 Scope:Host
    UP LOOPBACK RUNNING MTU:16436 Metric:1
    RX packets:216 errors:0 dropped:0 overruns:0 frame:0
    TX packets:216 errors:0 dropped:0 overruns:0 carrier:0
    collisions:0 txqueuelen:0
    RX bytes:13536 (13.5 KB) TX bytes:13536 (13.5 KB)
    
    wlan0
    Link encap:Ethernet HWaddr 00:0c:76:c9:f7:a1
    UP BROADCAST MULTICAST MTU:1500 Metric:1
    RX packets:0 errors:0 dropped:0 overruns:0 frame:0
    TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
    collisions:0 txqueuelen:1000
    RX bytes:0 (0.0 B) TX bytes:0 (0.0 B)
    
    wlan0:
    avahi Link encap:Ethernet HWaddr 00:0c:76:c9:f7:a1
    inet addr:169.254.10.85 Bcast:169.254.255.255 Mask:255.255.0.0
    UP BROADCAST MULTICAST MTU:1500 Metric:1
    
    wmaster0
    Link encap:UNSPEC HWaddr 00-0C-76-C9-F7-A1-00-00-00-00-00-00-00-00-00-00
    UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
    RX packets:0 errors:0 dropped:0 overruns:0 frame:0
    TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
    collisions:0 txqueuelen:1000
    RX bytes:0 (0.0 B) TX bytes:0 (0.0 B)
    network interfaces
    Code:
    auto lo
    iface lo inet loopback
    my windows box has static DNS servers, but dynamic IP address.

Page 1 of 2 12 LastLast

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •