Page 1 of 3 123 LastLast
Results 1 to 10 of 24

Thread: [SOLVED] dialog boxes dont work with desktop effects

  1. #1
    Join Date
    Oct 2008
    Location
    Tulsa,Ok
    Beans
    Hidden!
    Distro
    Ubuntu Development Release

    [SOLVED] dialog boxes dont work with desktop effects

    whenever I enable desktop effects save as dialog boxes dont work. I enable system>preferences>appearance>visual effects>normal. With the effects enabled I choose save as in any program and i am unable to select a folder or move around the hard drive folders. This seems to be the case with any dialog box that comes up. For example I tried to upload an Avatar. I hit the browse button to select a picture on my hard drive and the computer is stuck at the folder that was selected when the dialog box opened. I cant navigate the hard drive at all. However the Cancel button works so the box is not completelty dead.

    some info on my setup
    HP G60-120us
    2.6.27-7-generic
    Ubuntu 8.10
    Nvidia driver 177
    compiz 1:0.7.8-0ubuntu4.1

  2. #2
    Join Date
    Oct 2008
    Location
    Tulsa,Ok
    Beans
    Hidden!
    Distro
    Ubuntu Development Release

    Re: dialog boxes dont work with desktop effects

    I hope this helps find an awnswer. When using Firefox and Rythmnbox none of the dialog boxes like save as/import file work. While using Amarok, which is a KDE app, everything works fine.
    Last edited by duanedesign; November 17th, 2008 at 04:07 AM.

  3. #3
    Join Date
    Oct 2008
    Location
    Tulsa,Ok
    Beans
    Hidden!
    Distro
    Ubuntu Development Release

    Re: dialog boxes dont work with desktop effects

    bump

  4. #4
    Join Date
    Nov 2008
    Location
    Newburgh, Indiana
    Beans
    102
    Distro
    Ubuntu 8.04 Hardy Heron

    Re: dialog boxes dont work with desktop effects

    OK, let's start with the basics. I have attached a script that i need you to download and run. it is called compiz-check and it checks if you have all the requirements to run compiz.

    I think all tests will run positive (cuz compiz is technically running), but if they don't it could help point us toward the problem.

    download the file anywhere (remove the ".xcf" extension as i only added it so i could upload)

    to run type this in terminal:

    Code:
    bash /PATH/TO/compiz-check
    post any errors

    Also just for convenience i have attached a file (compiz-switch) that allows simple turning on/off of compiz.(do NOT remove ".deb" extension)

    After downloading just click on the file and install

    After installation there will be an icon in the applications>accessories menu called compiz-switch.

    If you want you can drag that icon to the panel for easy access.
    Attached Files Attached Files

  5. #5
    Join Date
    Oct 2008
    Location
    Tulsa,Ok
    Beans
    Hidden!
    Distro
    Ubuntu Development Release

    Re: dialog boxes dont work with desktop effects

    Thank you for the reply.

    Kernel


    Linux duanedesign-laptop 2.6.27-8-generic

    computer info

    cpu family : 17
    model : 3
    model name : AMD Turion Dual-Core Turion RM-70 2000 MHz
    L2Cache - 2 x 512 KB
    Graphics Card GeForce 8200M G/PCI/SSE2/3DNOW!
    prop. driver NVIDIA 177.80

    compiz check results:

    Distribution: Ubuntu 8.10 i386
    Desktop environment: GNOME
    Graphics chip: nVidia Corporation Device 0845 (rev a2)
    Driver in use: nvidia
    Rendering method: Nvidia

    Checking if it's possible to run Compiz on your system...

    Checking for texture_from_pixmap... [ OK ]
    Checking for non power of two support... [ OK ]
    Checking for composite extension... [ OK ]
    Checking for FBConfig... [ OK ]
    Checking for hardware/setup problems... [ OK ]

    xorg.conf

    Section "ServerLayout"
    Identifier "Default Layout"
    Screen "Default Screen" 0 0
    InputDevice "Keyboard0" "CoreKeyboard"
    InputDevice "Mouse0" "CorePointer"
    EndSection

    Section "Module"
    Load "dbe"
    Load "dri"
    Load "glx"
    EndSection

    Section "InputDevice"
    # generated from default
    Identifier "Keyboard0"
    Driver "keyboard"
    EndSection

    Section "InputDevice"
    # generated from default
    Identifier "Mouse0"
    Driver "mouse"
    Option "Protocol" "auto"
    Option "Device" "/dev/psaux"
    Option "Emulate3Buttons" "no"
    Option "ZAxisMapping" "4 5"
    EndSection

    Section "Monitor"
    Identifier "Configured Monitor"
    EndSection

    Section "Device"
    Identifier "Configured Video Device"
    Driver "nvidia"
    Option "XAANoOffscreenPixmaps"
    Option "AddARGBGLXVisuals" "True"
    EndSection

    Section "Screen"
    Identifier "Default Screen"
    Device "Configured Video Device"
    Monitor "Configured Monitor"
    DefaultDepth 24
    Option "NoLogo" "True"
    Option "AddARGBGLXVisuals" "True"
    SubSection "Display"
    Depth 24
    Modes "nvidia-auto-select"
    EndSubSection
    EndSection

    Section "DRI"
    Mode 0666
    EndSection

    Section "Extensions"
    Option "Composite" "Enable"
    EndSection


    Also I am including a list of installed packages.
    Attached Files Attached Files
    Last edited by duanedesign; November 21st, 2008 at 08:46 AM.

  6. #6
    Join Date
    Nov 2008
    Location
    Newburgh, Indiana
    Beans
    102
    Distro
    Ubuntu 8.04 Hardy Heron

    Re: dialog boxes dont work with desktop effects

    Wow, your on top of it, i was gonna ask you for xorg.conf but you got it posted ahead of time. thanks

  7. #7
    Join Date
    Nov 2008
    Location
    Newburgh, Indiana
    Beans
    102
    Distro
    Ubuntu 8.04 Hardy Heron

    Re: dialog boxes dont work with desktop effects

    Perhaps it's your driver. Sometimes different drivers work better on different systems.

    Perhaps you could try nvidia-glx-173. Or maybe nvidia-glx since it's in ubuntu the repository

    I have heard of some issues (including nvidia cards) being fixed by the changing of the driver.

    Also get nvidia-sttings (to change graphics settings) this may help alot via:

    Code:
    sudo apt-get install nvidia-settings
    to run it just type nvidia-settings i terminal if you dont have a menu icon

    Plus if you are using compizconfig-settings-manager there may be a certain setting thats causing the problem.
    Last edited by Marcus Derekus; November 21st, 2008 at 06:56 PM.

  8. #8
    Join Date
    Nov 2008
    Location
    USA
    Beans
    149
    Distro
    Ubuntu 11.04 Natty Narwhal

    Re: dialog boxes dont work with desktop effects

    If there is anyone else with the same card (and ubuntu 8.10) and has desktop effects working, then your help would be taken and aprecciated.
    "Do not underestimate the power of Ubuntu"
    ___
    | || |
    / o o \
    / \ /\ / \

  9. #9
    Join Date
    Nov 2008
    Location
    Newburgh, Indiana
    Beans
    102
    Distro
    Ubuntu 8.04 Hardy Heron

    Re: dialog boxes dont work with desktop effects

    BTW:I don't think it'll help, but perhaps you should add your cards BusID to xorg.conf.

    DO NOT CHANGE ANY THING BESIDES ADDING THE CODE IN RED. BUT READ THIS POST ALL THE WAY THROUGH BEFORE PROCEEDING.

    Ok open up xorg.conf in super-user mode

    Code:
    sudo /etc/X11/xorg.conf
    Edit your file so it matches the one below.
    we will only be changing the code in red.

    Code:
    Other parts in this file may not look like yours. This is because I got mine from a machine using an intel graphics card
    
    # xorg.conf (X.Org X Window System server configuration file)
    #
    # This file was generated by dexconf, the Debian X Configuration tool, using
    # values from the debconf database.
    #
    # Edit this file with caution, and see the xorg.conf manual page.
    # (Type "man xorg.conf" at the shell prompt.)
    #
    # This file is automatically updated on xserver-xorg package upgrades *only*
    # if it has not been modified since the last upgrade of the xserver-xorg
    # package.
    #
    # Note that some configuration settings that could be done previously
    # in this file, now are automatically configured by the server and settings
    # here are ignored.
    #
    # If you have edited this file but would like it to be automatically updated
    # again, run the following command:
    # sudo dpkg-reconfigure -phigh xserver-xorg
    
    Section "Device"
            Identifier "Configured Video Device"  
            Driver     "nvidia"
            BusId      "PCI:01:05:0
    EndSection
    
    Section "Monitor"
            Identifier "Configured Monitor"
    EndSection
    
    Section "Screen"
            Identifier "Default Screen"
            Monitor "Configured Monitor"
            Device "Configured Video Device"
    EndSection

    On the BusID "PCI:01:05:0", yours needs to be a little different.

    To find out your BusID open terminal and type:

    Code:
    lspci | grep VGA
    You will get an output kinda like

    Code:
    01:05.0 VGA compatible controller: ATI Technologies Inc RS690M [Radeon X1200 Series]
    Type your version of the number in red in the BusID SubSection (CAPS sensitive)

    but a little changed so that if you got the number:

    01:05.0

    it would look like

    "PCI:01:05:0"(and of course the quotes)


    note the adding of PCI: and that the . after 05 is replaced with :


    BTW: sorry if this posts format sounded a little wierd. I just copied it off of another post of mine (different thread) and edited it a little to be more relevant.
    Last edited by Marcus Derekus; November 21st, 2008 at 07:26 PM.

  10. #10
    Join Date
    Oct 2008
    Location
    Tulsa,Ok
    Beans
    Hidden!
    Distro
    Ubuntu Development Release

    Re: dialog boxes dont work with desktop effects

    I thought switching to 173 instead of 177 might work. Under Administration>Hardware Drivers it gives me both options. However it says the 177 is recommended. Are there any cons to using 173 over 177.

    I am going to try your suggestions, I will give an update in a bit.

    [update]

    added busID [-]
    openedcompizconfig turned off all settings [-]
    opened nvidia settings manager resaved xorg.conf [-]

    installed nvidia glx-173 instead of 177. I cant get Compiz to start at all now. here is what I get in Terminal.

    duanedesign@duanedesign-laptop:~$ compiz --replace
    Checking for Xgl: not present.
    Detected PCI ID for VGA:
    Checking for texture_from_pixmap: Segmentation fault
    not present.
    Trying again with indirect rendering:
    Checking for texture_from_pixmap: Segmentation fault
    not present.
    aborting and using fallback: /usr/bin/metacity

    when I run: glxinfo

    duanedesign@duanedesign-laptop:~$ glxinfo | grep -i direct
    Xlib: extension "GLX" missing on display ":0.0".
    Error: couldn't find RGB GLX visual or fbconfig

    [update]
    too many issues with 173 went back to 177 were I only have one issue to solve.
    Last edited by duanedesign; November 22nd, 2008 at 03:51 AM.

Page 1 of 3 123 LastLast

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •