Page 1 of 7 123 ... LastLast
Results 1 to 10 of 64

Thread: Gateway M275 with Ubuntu Hardy Heron (8.04.1)

  1. #1
    Join Date
    Oct 2006
    Ubuntu 9.10 Karmic Koala

    Gateway M275 Tablet laptop with Ubuntu Hardy Heron (8.04.1)

    I was recently given a Gateway M275 Tablet PC laptop in a non-functioning state. This laptop ships with Windows XP Tablet, but a clean format and the Recovery CD failed to bring it back to a working state. I thought "If I'm going to have to fight with laptop drivers, I might as well fight with Linux drivers".

    (I may summarize my Windows results later, but that is basically outside the scope of this forum apart from what it may tell me about my hardware specifically)

    So, this is a report on the things I've learned, and perhaps more importantly, the issues I am still trying to resolve.

    If you read this and find it helpful, please drop a comment saying so.
    Or, if you read this and it doesn't address some problem (either something else that you have solved, or something that hasn't even yet been solved) a response would be helpful there too.

    Any pointers and or help about outstanding issues would be greatly appreciated.

    As a disclaimer: I am certainly not a Linux expert, but I like to think I am a quick leaner. If I've made mistakes, please help me make corrections for the entire community's benefit.

    bonus tags: Gateway, M275, tablet, linux, ubuntu, hardy, 8.04, gnome, wacom, drivers, graphics
    Last edited by ScottHW; November 21st, 2008 at 06:30 PM.

  2. #2
    Join Date
    Oct 2006
    Ubuntu 9.10 Karmic Koala

    Checking for errors, Installing Ubuntu; Issues remain

    I thought it might be possible that this laptop had graphics hardware issues. During the Windows XP reinstall, the Safe Mode always hangs while/after loading "AGPCPQ.SYS". A number of other forums across the interweb report similar problems. Even after a fresh format and new install, the problem persisted. The computer was able to take an Install from a different Windows XP Pro install CD, and make it all the way to the desktop, graphics and all, so I had some hope.

    I started with a new LiveCD, to see if any of the laptop's functions would work. To my satisfacton, the LiveCD booted, and I was able to cruise around GNOME successfully.

    So, let's check the HDD to see if there are any problems there (bad sectors, etc)

    Hard drive info:
    Hitachi Travelstar
    MODEL: HTS548060M9AT00
    60GB 5400 RPM

    >badblocks -n -v -s -c 10240
    Testing with random pattern: done
    Pass completed. 0 bad blocks found.
    Described in more detail here:
    Checking disks for errors using the badblocks command
    credit: specialj

    Well, the HDD appears to be alright. How about the memory? I used MEMTEST86 v3.4. All test Passed, everything was just fine. Again, very encouraging.

    Alright, let's get our Linux on. Using the Install/LiveCD, I went right ahead. Partitions were created as follows (shown as "Code" simply for clarity)
    /dev/sda1   /       ext3     4096 MB
    /dev/sda2  swap              2048 MB
    /dev/sda3  /home    ext3    16348 MB
    Now things are on the right track. Wireless works no problem, FF runs and browses, once I installed the plugins I could watch YouTube vids easily. Sound works fine. Things are looking good.

    But, several symptoms showed up, related to graphics:

    1. Switching screen modes i.e. virtual terminals leads to hangs/crashes
    2. None of the LCD bezel buttons work, so no screen rotation, and no On-Screen Keyboard
    3. Manual screen rotation (System>Preferences>Screen Resolution) fails/hangs/crashes
    4. Displaying a simple .wmv video clip with Totem causes hangs/crashes
    5. ON-Screen Display (OSD) for laptop "Brightness", "Sound", "Status" etc. are garbled or no-show (minor importance, but indicative of problems)
    Last edited by ScottHW; November 17th, 2008 at 07:25 AM.

  3. #3
    Join Date
    Oct 2006
    Ubuntu 9.10 Karmic Koala

    Hardware, RAM Upgrade

    The Gateway M275 Tablet has some nice specs:

    Hardware specs

    Low cost Tablet PC convertible with big screen
    (by Conrad H. Blickenstorfer)

    Here's a good description of the tablet

    The factory RAM that was in the laptop was marked as follows:
    hynix china 53
    PC2700S-25330 0507
    256MB DDR 333MHz CL2.5
    HYMD232M646D6-J AA

    (200 Pin SoDIMM)

    BUT, I figured with only 2x256MB RAM stock, and a max of 2GB, I could do a little upgrading.
    I found a good deal, and got down in it twice

    Crucial 1GB PC2700 333Mhz 200-pin DDR SODIMM Laptop Memory $5 AR + s/h

    Seems to be running great, and Ubuntu recognizes the memory no problem. I've only got one of them installed so far, made much simpler with the instructions linked from the link above
    (credit: Bryan A)
    Last edited by ScottHW; November 18th, 2008 at 03:33 PM. Reason: Added Review link; Added RAM details

  4. #4
    Join Date
    Oct 2006
    Ubuntu 9.10 Karmic Koala

    Dual-booting with WinXP

    In an attempt to further diagnose the laptop, I figured it might not be a bad idea to see how it responds to WinXP Pro. If there genuinely are hardware issues, then WinXP would show problems as well, and I would know it's not just Linux driver issues.

    Along the way, I made several mistakes. First, I tried to just boot from WinXP Install CD. But when I got into the Setup, and tried to Partition/Format for installation, I received the following:
    Setup cannot create a new partition in the space you selected because
    the maximum number of partitions already exists on the disk.
    Alright; a very fast internet search will remind everyone that a HDD can only accept 4 partitions. With 3 reserved for root, swap, and /home, that only leaves one left. But WinXP only needs one. Hmmm....

    I assumed perhaps the Gateway Recovery Partition as still hiding somewhere, even though sudo fdisk -l in hadn't shown anything else, and neither did gparted.

    My solution; I used sudo gparted to create a new partition in the remaining 36GB of space, formatted as FAT32 (since Linux doesn't yet natively support NTFS writing). At this point, I figured it wouldn't hurt to have a back-up copy of the MBR, just in case.
    dd if=/dev/hda bs=512 count=1
    source: sidebar of
    CLI Magic: Salvage lost partitions with gpart
    By Mayank Sharma on October 23, 2006 (8:00:00 AM)

    I have used gpart in the past, and has success with it. I tried to read the partitions on the drive, and it appeared to have gone correctly, so I wrote the new partition table. That was a mistake; now the laptop wouldn't boot

    Great, I totally fscked that up. Alright, I went back to the Ubuntu LiveCD, and it still worked fine. One thing I noticed; now fdisk -l gives the warning similar to "partition does not start at end of cylinder". OK, so gpart didn't quite work in this case. Good thing I had the backup MBR; just turn around the above diskdump (dd) command to restore from

    Things still weren't quite right, warnings about "no media" during booting. So I just went ahead and burned a new copy of the Super Grub Disc v0.9766.
    The default options set me back on the right track.

    When I ran the WinXP Install CD again, at the Partition screen, I was given the choice to Delete/Reformat the 36GB partition. Windows XP Pro went in just fine. Possibly the Gateway Recovery CD containing WinXP Tablet has errors, or there may truly be something wrong with the graphics hardware.

    I made a quick modification to /etc/boot/grub/menu.lst to add the WindowsXP boot option, sticking this bit after the Ubuntu-installed MEMTEST86+
    title		Windows XP
    root		(hd0,3)
    chainloader	+1
    The HDD now has 4 partitions. I'd have liked to have a FAT32 that I could have used as a "shared" partition that both WinXP and Linux could write, but that's a different issue.
    Last edited by ScottHW; November 17th, 2008 at 07:25 AM.

  5. #5
    Join Date
    Oct 2006
    Ubuntu 9.10 Karmic Koala

    Graphics Driver for Intel integrated 855GM

    From the symptoms listed above, I've thought that I may have graphics driver and/or hardware problems.

    A good Specifications page about the M275 will list:
    Video: Integrated Intel® Extreme Graphics 2

    And more specifically:
    Intel integrated Graphics 855GM

    This can be confirmed using the command to list PCI hardware connections (use switches for more details)
    lspci -vvnn
    I've attached the results of both from my machine for reference.

    Alternatively, a lot can be learned using the package gnome-device-manager, currently v0.2.1
    credit: davidmaxwaterman

    Also, the package sysinfo (0.7-0ubuntu3) can tell quite a few things about your hardware.

    Either of these will report something similar to
    82852/855GM Integrated Graphics Device
    Integrated graphics are fine, but it doesn't leave many options if the hardware itself is actually damaged.

    "Intel", they've been around a while, maybe you've heard of them. So, drivers should be pretty well developed and easy to come by. Well, sort of.

    Recently, 915resolution would have been a necessity for rotating a tablet
    915Resolution: Intel Video BIOS Hack
    Steve Tomljenovic [stomljen at yahoo dot com]
    Last modified April 26, 2007

    Here's the homepage for Intel Linux graphics

    laptop hangs when switching video mode

    [855GM] system hang during suspend/resume

    System freeze after pressing ctrl-alt-bs.

    xserver crashes when rotating display and compiz enabled
    I tried the Option "ForceEnablePipeA" "true"

    Bugs with screen mode change (startup/shutdown, hibernate, suspend, screensaver, power save, or tty switch)

    Installed xresprobe, in order to provide ddcprobe output

    Thread asking for specific help

    Some other forums about the M275 refer to upgrading the BIOS. I currently have the most recent version 48.04.01
    Attached Files Attached Files
    Last edited by ScottHW; November 21st, 2008 at 11:41 AM.

  6. #6
    Join Date
    Oct 2006
    Ubuntu 9.10 Karmic Koala

    Screen and Wacom Tablet rotation

    Don't be misled, some sites/forums incorrectly report that the M275 uses a FinePoint digitizer. That's incorrect; some tablets do, but the M275 is NOT one of them. The M285 does use FinePoint, find more info here

    If you happen to be unable to get a Gateway Recovery CD, the Wacom drivers (for Windows) are inconvienently NOT on the Gateway site. Find them here

    A very useful thread:
    Wacom tablets in Ubuntu guide/howto - Loïc2
    Last edited by ScottHW; November 18th, 2008 at 03:01 AM.

  7. #7
    Join Date
    Oct 2006
    Ubuntu 9.10 Karmic Koala

    Hangs/Crashes with tty Virtual Terminals, Suspend...

    The most major problem I'm still having, after sorting out how to do rotations.

    While I suppose I can just use Terminal for most of the simple Linux commands I might like to be issuing, it's quite bothersome that fundamental aspects of Linux aren't working on my system.

    Launchpad Bug #127101: laptop hangs when switching video mode

    Bugzilla – Bug 10809 System freeze after pressing ctrl-alt-bs.


    As stated above, this is basically worked out.
    Only thing, occasionally I still get "Failed to Suspend" upon waking, accompanied with three or four loud beeps.
    How do I go about diagnosing that?
    I know there's a pretty significant recording in dmesg when I do a suspend, although I can't quite understand it all yet...

    Occurs about 1/3 of the time when I turn the computer back on from Standby, accompanied by 5-6 obnoxious beeps.
    Sleep Problem
    Your computer failed to Suspend...

    System beeps on return from suspend
    The suggestions here are mostly just how to stop the SOUND, not diagnose the problem...

    Acer Aspire 5100 Suspend Problem on Ubuntu 8.04
    Some useful info (and some webcam nonsense, too)..

    Sleep Problem

    Suspend/Hibernate in Hardy solved (for me)
    Not actually Solved, but he does suggest how to find the gnome-power-manager...

    Troubleshooting Sleep Problem Message
    Same problem, no suggestions...

    Question M1530: After successful hibernation, get "your computer failed to hibernate" message
    Gees, this problem is ALL OVER the forums, widely reported, mostly unanswered...

    [SOLVED] suspend and hibernate questions
    OK, here we go; Post #14 at least tells how to log the problems...

    As I try to follow this problem across the forums, I realize that the vB implementation won't let you search for "some string". So, one work-around is a google site: serach, (pretty common trick, suggested here:

    Another question:
    Suspending and Hibernation in hardy -- failed
    This one linked to the Launchpad bug

    Here is the bug on Launchpad (links to similar bug 195095, too)
    {Hardy} Message: "Suspend Problem. Your computer failed to suspend"
    TONS of reported incidences, with no answer or even suggestions. They do tell you how to disable the sound...

    Get rid of the beeping by unchecking the box
    System->Preferences->Power Management->General
    [_] Use sound to notify in event of error

    A number of users report that the failure occurs when Suspending for a long time, and not for short Suspend periods...

    The very last post says that it stopped happening for one user when she upgraded to Intrepid
    Last edited by ScottHW; December 5th, 2008 at 08:41 PM.

  8. #8
    Join Date
    Oct 2006
    Ubuntu 9.10 Karmic Koala

    LCD Bezel buttons

    From some hints on other forums, I've tried to use
    But I don't get any response from any of the four keys with either of those.

    A couple of times, when I had the tablet rotated over 180 deg, the Brightness button actually functioned....
    Last edited by ScottHW; November 25th, 2008 at 08:22 PM.

  9. #9
    Join Date
    Oct 2006
    Ubuntu 9.10 Karmic Koala

    OnScreen Display (OSD) system information doesn't work

    Status, Brightness, Volume

    During booting, the OSD works fine, but starts to not work right at "Loading hardware drivers..." (I have disabled quiet in GRUB)

    I don't quite understand it yet, but apparently after coming back from Suspend, the OSD behaves much better, mostly working
    Last edited by ScottHW; November 18th, 2008 at 02:57 AM.

  10. #10
    Join Date
    Oct 2006
    Ubuntu 9.10 Karmic Koala

    Tablet Software

    on-screen keyboard

    built in to Ubuntu, works pretty well.
    System>Preferences>Universal Access
    Maintains "focus" better than XVkbd
    (may need to be turned on in System>Preferences>Main Menu>)
    haven't yet figured out how to auto-tile windows when on-screen kbd is called up..., or even do it manually

    OR how to use on-screen kbd when prompted for Admin password...

    Note-taking, doodling

    Wacom tablets in Ubuntu guide/howto

    ... which links to
    Linux on the Lenovo ThinkPad X60 Tablet
    Last updated: 2008.09.26
    Created to be X60-specific, but still has tons of good tips about screen rotation....

    Cell Writer
    So, it looks like it works, but could be improved. For one thing, I would like the recognition to just take place over any window. Or at least have window docking make other windows get out of the way. And there are obvious recognition issues/problems with expected things like t and +, c and <, etc.

    I guess what I really want is something like No-Cell Writer
    Last edited by ScottHW; November 27th, 2008 at 05:39 PM.

Page 1 of 7 123 ... LastLast

Tags for this Thread


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts