Results 1 to 7 of 7

Thread: 8.04 > 8.10 server upgrade 2.6.27-7 kernel refuses to mount LVM root

  1. #1
    Join Date
    Aug 2006
    Location
    home
    Beans
    Hidden!
    Distro
    Ubuntu Studio 9.10 Karmic Koala

    8.04 > 8.10 server upgrade 2.6.27-7 kernel refuses to mount LVM root

    the 2.6.27-7-server kernel refuses to mount my LVM root after upgrade
    > booting previous 2.6.24-21-server just works fine ......

    booting the new kernel just gives me following after initramfs initialization ... >
    Code:
    reading al physical volumes. This may take a while
    Begin: waiting for root file sytem
    
    reading al physical volumes. This may take a while
    Begin: waiting for root file sytem
    
    reading al physical volumes. This may take a while
    Begin: waiting for root file sytem
    
    etc...
    seems he's unable to find the root ...

    anyone ?
    democracy : 2 wolves and a sheep voting on "what's for dinner"
    i am self-employed, and my views reflect the electrical charges held between many simultaneously firing synapses... or is that synapsi?
    http://3d.uk.to

  2. #2
    Join Date
    Jan 2008
    Location
    Sittingbourne, UK
    Beans
    196
    Distro
    Ubuntu 10.10 Maverick Meerkat

    Re: 8.04 > 8.10 server upgrade 2.6.27-7 kernel refuses to mount LVM root

    You should be able to boot the old 8.04 kernels and check the grub config. If these won't boot then you'll probably need to boot from a disk/live CD.

  3. #3
    Join Date
    Aug 2006
    Location
    home
    Beans
    Hidden!
    Distro
    Ubuntu Studio 9.10 Karmic Koala

    Re: 8.04 > 8.10 server upgrade 2.6.27-7 kernel refuses to mount LVM root

    yeah thx,

    but as I said I can boot from 2.6.24-21-server kernel ( 8.04.1 )..

    my grub settings are the same for all kernels ... just to rule that out
    LVM uses device-mapper ( so no UUIDS )...
    my guess there's something wrong with that ( the device mapper )...
    I imaged the partition to a vmware machine, .. still same problem ..
    ( so without all the raid arrays > production server I won't take it offline )

    tried depmodding + a new initramfs too nada .. I'm currently checking, & rebuilding a kernel to see if device-mapper was accidentally removed as a kernel module .. so far that seems ok ...

    anyone pretty please ?
    democracy : 2 wolves and a sheep voting on "what's for dinner"
    i am self-employed, and my views reflect the electrical charges held between many simultaneously firing synapses... or is that synapsi?
    http://3d.uk.to

  4. #4
    Join Date
    Mar 2008
    Beans
    99

    Re: 8.04 > 8.10 server upgrade 2.6.27-7 kernel refuses to mount LVM root

    I've had this on 3 machines I upgraded and the solution appears to be to modify /boot/grub/menu.lst
    and add for the current kernel stanza (the line starting kernel)
    rootdelay=90

    This has worked for me but booting is a bit slow so I guess you can reduce the 90 until it stops working, and go back.

  5. #5
    Join Date
    Aug 2006
    Location
    home
    Beans
    Hidden!
    Distro
    Ubuntu Studio 9.10 Karmic Koala

    Re: 8.04 > 8.10 server upgrade 2.6.27-7 kernel refuses to mount LVM root

    mmm sorry

    nope that didn't work, tried even higher settings ( rootdelay=180 )

    I'm kind of sure it has something to do with the device-mapper, I did notice ( the rig has a whole bunch of hd's, mostly sata's ) that the 2 PATA's on a PCI card previously as /dev/hd[cd] are now labeled as /dev/sd[cd].. but these aren't the boot disks ... I still need to investigate whether there's another shift in names ... unfortunately booting ( the new kernel ) isn't getting very far ......



    democracy : 2 wolves and a sheep voting on "what's for dinner"
    i am self-employed, and my views reflect the electrical charges held between many simultaneously firing synapses... or is that synapsi?
    http://3d.uk.to

  6. #6
    Join Date
    Jan 2008
    Location
    Sittingbourne, UK
    Beans
    196
    Distro
    Ubuntu 10.10 Maverick Meerkat

    Re: 8.04 > 8.10 server upgrade 2.6.27-7 kernel refuses to mount LVM root

    Quote Originally Posted by djamu View Post
    yeah thx,

    but as I said I can boot from 2.6.24-21-server kernel ( 8.04.1 )..
    Sorry, obviously didn't read your initial post very well.

  7. #7
    Join Date
    Aug 2006
    Location
    home
    Beans
    Hidden!
    Distro
    Ubuntu Studio 9.10 Karmic Koala

    Re: 8.04 > 8.10 server upgrade 2.6.27-7 kernel refuses to mount LVM root

    Quote Originally Posted by Philio View Post
    Sorry, obviously didn't read your initial post very well.
    NP. I'll dig some more, currently rolling a custom 2.6.27 kernel with newly compiled device-mapper...
    democracy : 2 wolves and a sheep voting on "what's for dinner"
    i am self-employed, and my views reflect the electrical charges held between many simultaneously firing synapses... or is that synapsi?
    http://3d.uk.to

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •