Results 1 to 2 of 2

Thread: Resizing terminals with wmctrl

  1. #1
    Join Date
    Jun 2007
    Beans
    43

    Resizing terminals with wmctrl

    I have made two resize scripts executed using xbindkeys-config via CTRL+ALT+4 and CTRL+ALT+6 (ala winsplit revolution). They are move_e:
    Code:
    wmctrl -r :ACTIVE: -b remove,maximized_vert,maximized_horz
    wmctrl -r :ACTIVE: -e 1,960,0,960,1080
    and move_w
    Code:
    wmctrl -r :ACTIVE: -b remove,maximized_vert,maximized_horz
    wmctrl -r :ACTIVE: -e 1,0,0,940,1080
    The problem is that terminal windows refuse to comply (they just seem to get the height and width right), although everything else does. Anyone have any idea why? I have tried experimenting with the "gravity", but that doesn't appear to do anything. Screen size is 1920x1080 btw.

    Thanks also to spiregrain for showing me how to do this, on this thread:
    http://ubuntu-virginia.ubuntuforums....d.php?t=601186

  2. #2
    Join Date
    Nov 2008
    Beans
    92

    Re: Resizing terminals with wmctrl

    Hi
    I seem to have the same Problem. I wrote a tiling script for Metacity and all the windows but the terminal do what they should do. This problem occurs in Hardy. Intrepid is working properly. If you are using Hardy then this could be a bug .I thought i may have changed some settings. But it looks like this is normal.

    greeting z


    It's been a long time since I wrote in English, so if you find any heavy mistakes you could tell me.

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •