Page 1 of 3 123 LastLast
Results 1 to 10 of 22

Thread: tsclient / rdesktop - caps lock inop

  1. #1
    Join Date
    Aug 2007
    Beans
    10

    tsclient / rdesktop - caps lock inop

    The caps lock key doesn't work or 'flow thru' to the terminal session.
    (If the user holds the shift key caps will type thru to the terminal session.)

    Within tsclient on the 'local resources' tab I selected the keyboard language
    to "en-us" and I've tried enabling the "window manager's key bindings"
    option under the tsclient performance tab without any noticeable benefit.

    Is there a setting within tsclient, rdesktop or Gnome that will enable the
    caps lock functionality?

  2. #2
    Join Date
    Dec 2006
    Location
    Oregon, US
    Beans
    1,541
    Distro
    Ubuntu Development Release

    Re: tsclient / rdesktop - caps lock inop

    Try the gnome-rdp client instead. It's so much faster than the one that comes with Ubuntu...and your capslock might work too.

    sudo apt-get install gnome-rdp

  3. #3
    Join Date
    Aug 2007
    Beans
    10

    Re: tsclient / rdesktop - caps lock inop

    Quote Originally Posted by jimv View Post
    Try the gnome-rdp client instead. It's so much faster than the one that comes with Ubuntu...and your capslock might work too.

    sudo apt-get install gnome-rdp
    Thanks for the suggestion...

    Sadly I must report Gnome-RDP suffers the same trouble as tsclient(as does grdesktop too). Caps lock setting dose not pass thru to the terminal server session.

    Where oh where is this hidden bit found?

  4. #4
    Join Date
    Apr 2008
    Beans
    31

    Re: tsclient / rdesktop - caps lock inop

    It is a regression since it used to work in Hardy.

  5. #5
    Join Date
    Aug 2007
    Beans
    10

    Re: tsclient / rdesktop - caps lock inop

    Quote Originally Posted by apedraza View Post
    It is a regression since it used to work in Hardy.
    That being the case, with whom or where should I file the bug report?

  6. #6
    Join Date
    Jun 2008
    Beans
    4

    Re: tsclient / rdesktop - caps lock inop

    Quote Originally Posted by apedraza View Post
    It is a regression since it used to work in Hardy.
    I'm having the same problem; caps lock isn't "detected" when I remote desktop (using tsclient) into a Windows 2003 machine (haven't tried other versions of Windows). Shift seems to work fine. This was working for months in Ubuntu 8.04, and stopped working when I upgraded to 8.10.

  7. #7
    Join Date
    Sep 2008
    Beans
    3

    Lightbulb Re: tsclient / rdesktop - caps lock inop

    same ISSUE thou i did find a work around, BUT IT does screw things up a bit in ubuntu, thou it does allow the caps lock to function normal in terminal services, the num pad unfortunately does not work thou. here IS what i did>

    SYSTEM> preferances > keyboard > click on the LAYOUTS tab, select "OTHER OPTIONS..."

    find caps lock behavior and expand the options, select CAPSLOCK TOGGLES SHIFT SO ALL KEYS ARE AFFECTED."

    like i said, ALL SEEMS NORMAL in rdesktop (terminal services) but, UBUNTU, ACTS A LITTLE CRAZY SINCE IT THINKS YOUR HOLDING THE SHIFT KEY, when you attempt to move a window with capslock off in ubuntu< it moves very erratically -, but terminal services does not think the same thing, i HOPe they come out with a fix for this one, I use rdesktop religiously since everything at work is operated by microsoft products.

    PAUL

    ps (this is occurring after the upgrade from 8.04 TO 8.10) and this is the message that keeps occurring in the terminal window i start rdesktop in;

    "WARNING: No translation for (keysym 0xffe6, Shift_Lock)" & "WARNING: No translation for (keysym 0xfef9, Pointer_EnableKeys)" thou i think the last error has to do with numpad not working in rdesktop using the temporary fix i put in place. i will try to keep up today with the issues and fixes i find.
    Last edited by paulie420; November 12th, 2008 at 04:59 PM.

  8. #8
    Join Date
    Dec 2007
    Beans
    7

    Re: tsclient / rdesktop - caps lock inop

    Try hitting [Ctrl][Shift][NumLock] at the same time,
    or [Shift][Numeric 7]
    Last edited by PascalNobus; November 27th, 2008 at 04:23 PM.

  9. #9
    Join Date
    Dec 2008
    Beans
    1

    Re: tsclient / rdesktop - caps lock inop

    I've got the same problem when I upgraded to 8.10. But after I removed the rdesktop package using synaptic and downloaded the .deb package from the Hardy release (v 1.5.0 something) and installed, I now got the caps lock to work properly in krdc since it depends on rdesktop as many other clients do.

    I just hope no other issue shows up using this combination...

  10. #10
    Join Date
    Jan 2008
    Beans
    6

    Re: tsclient / rdesktop - caps lock inop

    while using rdesktop try

    rdesktop -k common ...

    instead of

    rdesktop -k en-us...

    may be it help.

    all variants of key "-k" are names of files in folder /usr/share/rdesktop/keymaps/

    at least in Fedora Core

Page 1 of 3 123 LastLast

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •