Results 1 to 9 of 9

Thread: open a terminal on tty7

  1. #1
    Join Date
    Jul 2006
    Beans
    17

    open a terminal on tty7

    I let my son use my Ubuntu computer using my sign-in when I'm at work. Sometimes I want to pop up a terminal on his tty7 so that I can use "write" to send him a message. I can ssh into the home computer, but I can't figure out how to pop up the terminal so that he gets the message.

    Does anyone else know?

    TIA

  2. #2
    Join Date
    Oct 2007
    Beans
    370
    Distro
    Ubuntu 11.04 Natty Narwhal

    Re: open a terminal on tty7

    Quote Originally Posted by tropicflite View Post
    I let my son use my Ubuntu computer using my sign-in when I'm at work. Sometimes I want to pop up a terminal on his tty7 so that I can use "write" to send him a message. I can ssh into the home computer, but I can't figure out how to pop up the terminal so that he gets the message.

    Does anyone else know?

    TIA
    well, for starters, writing to tty7 won't show up. You need to use something like pts/1. to start a terminal, just typing gnome-terminal & should start one on his end if x11 forwarding is off.

  3. #3
    Join Date
    Jul 2006
    Beans
    17

    Re: open a terminal on tty7

    Quote Originally Posted by -Zeus- View Post
    well, for starters, writing to tty7 won't show up. You need to use something like pts/1. to start a terminal, just typing gnome-terminal & should start one on his end if x11 forwarding is off.
    Thanks for the reply. I tried what you said, and I got:

    dad@ubuntu:~$ gnome-terminal &
    Cannot open display:
    [1] 12907
    dad@ubuntu:~$ Run 'gnome-terminal --help' to see a full list of available command line options.

    I looked through the options but I didn't see anything helpful. Any other ideas?

  4. #4
    Join Date
    Apr 2006
    Location
    Montana
    Beans
    Hidden!
    Distro
    Kubuntu Development Release

    Re: open a terminal on tty7

    See if either of these threads help :

    http://ubuntuforums.org/showthread.php?&t=411622

    See also http://ubuntuforums.org/showthread.php?t=504351

    If so, use xmessage or zenity instead of write.

    ex:

    Code:
    xmessage " This is a test"
    There are two mistakes one can make along the road to truth...not going all the way, and not starting.
    --Prince Gautama Siddharta

    #ubuntuforums web interface

  5. #5
    Join Date
    Jul 2006
    Beans
    17

    Re: open a terminal on tty7

    OK, following your links, I made a script named forward.sh which looks like this:

    #!/bin/bash
    XAUTHORITY=/home/dad/.Xauthority
    export XAUTHORITY
    DISPLAY=:0
    export DISPLAY
    $1

    I did a chmod +x on it, and now when I ssh into my home box, I can start pidgin like this:

    ./forward.sh pidgin

    and that does just what I want.

    Thanks for your help! That was quick!

  6. #6
    Join Date
    Jul 2006
    Beans
    17

    Re: open a terminal on tty7

    .
    Last edited by tropicflite; November 10th, 2008 at 06:05 AM.

  7. #7
    Join Date
    Jan 2010
    Location
    Romania, Bacau
    Beans
    4
    Distro
    Ubuntu 9.10 Karmic Koala

    Re: open a terminal on tty7

    #!/bin/bash
    XAUTHORITY=/home/dad/.Xauthority
    export XAUTHORITY
    DISPLAY=:0
    export DISPLAY
    $1

    Works for me too. Thank you all.

  8. #8
    Join Date
    Jun 2011
    Location
    Canada
    Beans
    1
    Distro
    Ubuntu 11.04 Natty Narwhal

    Re: open a terminal on tty7

    if anybody is still paying attention to this post

    when i do this, i have to open another terminal and ssh in again in order to run any further commands as the terminal waits for the command to finish. is there any way to get it to not do this.

    ie:
    me@my-netbook:~$ ssh me@my-desktop
    me@my-desktop:~$ ./forward.sh gnome-terminal
    (and then it waits for ^C)

  9. #9
    Join Date
    Apr 2006
    Location
    Montana
    Beans
    Hidden!
    Distro
    Kubuntu Development Release

    Re: open a terminal on tty7

    Quote Originally Posted by FracturedMind View Post
    if anybody is still paying attention to this post

    when i do this, i have to open another terminal and ssh in again in order to run any further commands as the terminal waits for the command to finish. is there any way to get it to not do this.

    ie:
    me@my-netbook:~$ ssh me@my-desktop
    me@my-desktop:~$ ./forward.sh gnome-terminal
    (and then it waits for ^C)
    This is an old thread. In the future you really should start your own new thread rather then hijacking an old one

    use a & at the end

    command 1 &
    command 2 &

    You may also want to look at applications like screen and using nohup

    (nohup command 1 &)

    See also man ssh as there are several options for ssh .
    There are two mistakes one can make along the road to truth...not going all the way, and not starting.
    --Prince Gautama Siddharta

    #ubuntuforums web interface

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •