Page 1 of 10 123 ... LastLast
Results 1 to 10 of 93

Thread: HOWTO: Installing Japanese Input & Font Setup in Ubuntu 8.10 (Intrepid) with SCIM 日本語

  1. #1
    Join Date
    Dec 2006
    Location
    All over the world!
    Beans
    Hidden!
    Distro
    Ubuntu 10.10 Maverick Meerkat

    Lightbulb HOWTO: Installing Japanese Input & Font Setup in Ubuntu 8.10 (Intrepid) with SCIM 日本語

    HOWTO: Installing Japanese Input and Font Setup in Ubuntu 8.10 (Intrepid) using SCIM: 日本語

    Installing Japanese Input and Superior Font Setup in Ubuntu

    Introduction

    This is a guide to setting up Japanese for Ubuntu 8.10 Intrepid. It is intended as a complete guide encompassing all elements required for using Japanese on any language installation of Ubuntu. It covers input (SCIM-Anthy) and configuring the Japanese fonts. There are other guides around for older versions of Ubuntu or that use the alternative UIM (see other guide). This guide is intended to cover everything. Please note that Kubuntu requires slightly different steps. Please follow the relevant page accordingly. This is an updated version based on the original 6.10 one, but with some sections changed. Please note that if you follow this guide, your fonts will be reconfigured. This might mean losing some font settings you may have made. With each version of Ubuntu, there are certain changes, this guide is not the same as the 8.04 version.

    Issues Involved

    There are two main issues here:

    1.Installing the SCIM input system that will work in a locale other than converting your whole install to Japanese, i.e. you want Japanese input in an English login.

    2.The fonts look initially terrible. Therefore a certain amount of customisation is required to make all the Kanji's render in the same style and Hiragana & Katakana to render in a matching style.

    Japanese Input with SCIM

    This section covers setting up the Japanese input system using SCIM Anthy. This involves, downloading, installing and configuring it so that you can use it in non-Japanese locales (e.g. your system is in English).

    Setting Up Repositories

    First lets make sure you have the correct repositories installed in order to automatically download the relevant packs. Make sure you have the Universe and Multiverse repositories switched on. This can be done in 'Synaptic Package Manager' under the repositories tab. Also, you need the Japanese repository too. Open the repositories list file:

    Code:
    gksudo gedit /etc/apt/sources.list
    Add the following line at the bottom:

    Code:
    deb http://archive.ubuntulinux.jp/ubuntu-ja intrepid/
    Note that you will need to change 'intrepid' if you are using a different version from 8.10. Now update your repos with:

    Code:
    sudo apt-get update
    At this stage, you will probably get an error saying that the repository is not validated. Ignore this for now. The following step will correct it. After adding the repository and running the update, you also need to add a keyring for the new location:

    Code:
    sudo apt-get install ubuntu-ja-keyring
    Adding Ubuntu Language Support

    Go to System / Administration / Language Support and select Japanese. This should install the basics. Make sure you've also turned on support for inputting complex characters.

    Making SCIM available under a non-Japanese login

    Now you want to make SCIM (Language input system) available in your English (or other language) login and not just the Japanese one. Since 8.04, ubuntu will make it available in GTK applications, but if you want to run non-GTK applications such as KDE or pure X software such as those Java based you'll need to make a few changes. If you are running a US locale, it might work with defaults, but any other locale will almost certainly need registering. First restart your computer to make sure the relevant folder have been created, then open the scim global settings file:

    Code:
    gedit ~/.scim/global
    Add the line:

    Code:
    /SupportedUnicodeLocales = en_US.UTF-8,en_GB.UTF-8
    The above line adds support for US and UK locales. If you are using a different locale, you will need to change / add the relevant locale. You can find out the name of your current locale by entering:

    Code:
    locale
    In my case (UK) it returns LANG=en_GB.UTF-8. Add the necessary to the above line.

    IMPORTANT NOTE: SCIM is very unforgiving with this line. Note that there is NO SPACE between the "," and "en_GB". If you put a space there, it will ignore everything after. Therefore make sure the following locales are separated by a comma only.

    At this stage you'll probably need to log out and back in again. Open a text editor and hit ctrl+space. SCIM should pop up ready to type in Japanese.

    Adding handwriting recognition support for looking up Kanjis

    After adding the above repository, you should be able to install the 'Tomoe' handwriting recognition addon for scim using:

    Code:
    sudo apt-get install scim-tomoe
    Unfortunately, Tomoe is set to load dictionaries that correspond to the locale, so if you're not using a Japanese locale, you'll need to create a link to the dictionary manually.

    Code:
    cd /usr/share/tomoe/recognizer
    sudo cp handwriting-ja.xml handwriting-en.xml
    Where 'en' corresponds to your locale type. In my case (en_GB.UTF- it is 'en'. For you, it might be different. You can look it up as mentioned above.

    Now that Tomoe is installed, it is accessible on the SCIM menu under the 'SCIM Command Menu' and listed as 'Handwriting recognition'.

    Setting up the system to display Japanese characters properly

    OK, now you've got Japanese input installed (hopefully). It might require rebooting xwindows (CTRL+ALT+Backspace). But for me, I really didn't like the horrible fonts that defaulted. Particularly the fact that hiragana / katakana characters are rendered differently from kanjis and the poor quality of smaller sizes annoys me. The main reason for this is that the fonts provided do not always have a full set of kanjis, with default settings the kanjis are rendered as bitmaps and the hiragana and katakana as vectors.

    At lower font sizes, it would be impossible to render all the strokes in very complicated characters without blurring and this causes a readability problem. This can be overcome with bitmap alternatives at a low end. Certain strokes are omitted and the shape is actually changed in order to improve readability. It's not simply a case of rendering the same vector in a smaller size. Some true type fonts contain bitmap alternatives that can be automatically substituted at the low end. This is a common approach and is adopted by Windows, MacOS and other electronic devices in Asia such as mobile phones. Here's the next step.

    Downloading External Fonts

    Unfortunately, I am very disappointed in the Ubuntu selection and you will almost certainly want this to be changed to MSGothic and MSMincho. They contain a superior vector and bitmap selection. These are Microsoft fonts, but they are freely available to use and are actually from a company called Ricoh. They need to be downloaded and installed manually. They can be found at the following page.

    http://www.linux.ryukent.co.uk/show.php?id=24

    So download and extract the files and you need to copy them into the fonts directory. This will need root privileges and is probably easiest done using the file explorer:

    Code:
    gksudo "nautilus --browser"
    That will give you a browser with the right privileges. So copy your downloaded ttf files and paste them into a folder under the fonts tree. I recommend:

    Code:
    /usr/share/fonts/truetype/msjapanesefonts

    Rebuilding the font cache


    Now we need to rebuild the fonts cache:

    Code:
    sudo fc-cache -f -v
    Setting up the font order

    OK, so that might well be enough, but I think you'll probably still have your Japanese fonts not running at optimum and the default might be a little ugly. Lets set up the order in which we like the fonts to be selected. Open the “.fonts.conf” file in your home directory:

    Code:
    gedit ~/.fonts.conf
    It should read as follows:

    Code:
    <?xml version="1.0"?>
    <fontconfig>
     <alias>
     <family>serif</family>
     <prefer>
     <family>DejaVu Serif</family>
     <family>Times New Roman</family>
     <family>MS 明朝</family>
     <family>IPAPMincho</family>
     <family>Sazanami Mincho</family>
     <family>Kochi Mincho</family>
     <family>Bitstream Vera Serif</family>
     <family>Thorndale AMT</family>
     <family>Luxi Serif</family>
     <family>Nimbus Roman No9 L</family>
     <family>Times</family>
     <family>Frank Ruehl</family>
     <family>MgOpen Canonica</family>
     <family>AR PL SungtiL GB</family>
     <family>AR PL Mingti2L Big5</family>
     <family>FreeSerif</family>
     <family>Baekmuk Batang</family>
     </prefer>
     </alias>
     <alias>
     <family>sans-serif</family>
     <prefer>
     <family>DejaVu Sans</family>
     <family>Verdana</family>
     <family>MS ゴシック</family>
     <family>IPAPGothic</family>
     <family>Sazanami Gothic</family>
     <family>Kochi Gothic</family>
     <family>Bitstream Vera Sans</family>
     <family>Arial</family>
     <family>Albany AMT</family>
     <family>Luxi Sans</family>
     <family>Nimbus Sans L</family>
     <family>Helvetica</family>
     <family>Nachlieli</family>
     <family>MgOpen Moderna</family>
     <family>AR PL KaitiM GB</family>
     <family>AR PL KaitiM Big5</family>
     <family>FreeSans</family>
     <family>Baekmuk Dotum</family>
     <family>SimSun</family>
     </prefer>
     </alias>
     <alias>
     <family>monospace</family>
     <prefer>
     <family>DejaVu Sans Mono</family>
     <family>Courier New</family>
     <family>MS ゴシック</family>
     <family>IPAGothic</family>
     <family>Sazanami Gothic</family>
     <family>Kochi Gothic</family>
     <family>Bitstream Vera Sans Mono</family>
     <family>Andale Mono</family>
     <family>Cumberland AMT</family>
     <family>Luxi Mono</family>
     <family>Nimbus Mono L</family>
     <family>Courier</family>
     <family>Miriam Mono</family>
     <family>FreeMono</family>
     <family>AR PL KaitiM GB</family>
     <family>Baekmuk Dotum</family>
     </prefer>
     </alias>
     <match target="font" >
     <edit mode="assign" name="embeddedbitmap" >
     <bool>true</bool>
     </edit>
     </match>
    </fontconfig>
    So, save the file and reboot xwindows (CTLR+ALT+Backspace). Now with any luck the order of fonts should have been updated so that the default Japanese type face is actually a clean one first and foremost instead of the ugly first serving. Also it enables the built in bitmap font which can really make kanjis more readable and also enables the bitmap version of hiragana and katakana so that they don't look blurry anti-aliased next to clear bitmap kanjis. For most people this setting will be fine. If you're not happy, by all means leave out the embeddedbitmap setting or change it to false.

    To finish things off, I'd suggest making sure in System / Preferences / Appearance / Fonts, you've got subpixel smoothing on and after clicking on details, hinting is set to 'full'.

    If you have any additional questions, please don't hesitate to message me in this forum. I'm always happy to help, though I make take a little while responding. 頑張ってください - RyuKent
    Last edited by ryukent; December 6th, 2008 at 01:06 AM. Reason: Added link to Kubuntu thread

  2. #2
    Join Date
    Oct 2007
    Location
    Somewhere on Earth
    Beans
    342
    Distro
    Ubuntu 9.10 Karmic Koala

    Question Re: HOWTO: Installing Japanese Input & Font Setup in Ubuntu 8.10 (Intrepid) with SCIM

    よければ、Kubuntu IntrepidのSKIMの設定と使い方を教えてもらえませんか。

    Sorry, I couldn't resist!

    No, I would use Kubuntu Intrepid, however I wasn't quite able to work out how to set up Skim, which I prefered over SCIM because it was much easier to set up under Kubuntu Hardy.

    Would you be able to write about set-up under Kubuntu Intrepid?

    お願いします

    TWO
    Ubuntu= Linux Mint =
    Karmic Koala 9.10


  3. #3
    Join Date
    Nov 2008
    Beans
    3

    Re: HOWTO: Installing Japanese Input & Font Setup in Ubuntu 8.10 (Intrepid) with SCIM

    Unfortunately I wasn't able to type in Japanese text via SCIM once I completed the steps for "Making SCIM available under a non-Japanese login."

    I opened up the text editor, pressed ctrl+space and had the SCIM box pop up in the lower right hand corner. Japanese text was not among the options listed, however "Other-English/European," "Other-RAW CODE," and "English/Keyboard" was available to use as an input method.

    I completed the rest of the outlined steps in hopes that this would correct any kind of error but I'm sure thats just wishful thinking.

    Also, I ensured that I had the most recent updates and packages installed via Update Manager. If that helps

    According to the characteristics that I just described, could you give me a hint as to how I correct the SCIM configuration?

    Thank you very much

  4. #4
    Join Date
    Nov 2008
    Beans
    58

    Re: HOWTO: Installing Japanese Input & Font Setup in Ubuntu 8.10 (Intrepid) with SCIM

    very good post. . . thank you!

  5. #5
    Join Date
    Jun 2008
    Beans
    59

    Re: HOWTO: Installing Japanese Input & Font Setup in Ubuntu 8.10 (Intrepid) with SCIM

    is there something I'm doing wrong? I didn't do the bit with adding the handwriting support, but I didn't see a need for it, and it'd add trouble for me that I don't care for..
    That being said.. none of the triggers work for my SCIM... I've tried all kinds of little configuration tweaks via the GUI setup tool, just.. when I press ctrl + space, nothing happens.
    I have SCIM, anthy, language-pack-ja, language-pack-gnome-ja, language-support-ja, and all that stuff installed.. Anthy shows up in my input method list in the SCIM GUI setup tool.. Frankly, I'm pretty stumped by why I still can't type in basic japanese characters..
    (Oh, and I've got the fonts installed, I believe.. If that sounds like something that would cause my problem to anyone else, I'll confirm later, I'm just way too tired and irritated from trying to get this to work right now..)
    "Don't forget what happened to the man who suddenly got everything he ever wanted."
    "What happened?"
    "He lived happily ever after."

  6. #6
    Join Date
    Dec 2006
    Location
    All over the world!
    Beans
    Hidden!
    Distro
    Ubuntu 10.10 Maverick Meerkat

    Re: HOWTO: Installing Japanese Input & Font Setup in Ubuntu 8.10 (Intrepid) with SCIM

    Two snakes, can you confirm that 'Anthy' is on your list within SCIM. It should be automatically installed when you select Japanese in the language support.

  7. #7
    Join Date
    Dec 2006
    Location
    All over the world!
    Beans
    Hidden!
    Distro
    Ubuntu 10.10 Maverick Meerkat

    Re: HOWTO: Installing Japanese Input & Font Setup in Ubuntu 8.10 (Intrepid) with SCIM

    Lexicon101.... you say you have Anthy installed and appears on your list in SCIM. So when you're in gedit, right click and select SCIM as the input method. When SCIM is running, can you select Anthy?

  8. #8
    Join Date
    Jun 2008
    Beans
    59

    Re: HOWTO: Installing Japanese Input & Font Setup in Ubuntu 8.10 (Intrepid) with SCIM

    Well now that solves that.. But I don't see a way of doing the same in firefox..
    "Don't forget what happened to the man who suddenly got everything he ever wanted."
    "What happened?"
    "He lived happily ever after."

  9. #9
    Join Date
    Dec 2006
    Location
    All over the world!
    Beans
    Hidden!
    Distro
    Ubuntu 10.10 Maverick Meerkat

    Re: HOWTO: Installing Japanese Input & Font Setup in Ubuntu 8.10 (Intrepid) with SCIM

    Hmm... SCIM should be available automatically. Can you give me the output of:

    im-switch -l

    Also, can you confirm that you're running a fresh install of 8.10, or did you upgrade??

  10. #10
    Join Date
    Feb 2008
    Beans
    239
    Distro
    Ubuntu 8.10 Intrepid Ibex

    Re: HOWTO: Installing Japanese Input & Font Setup in Ubuntu 8.10 (Intrepid) with SCIM

    This is a great how to.

    But does anybody know how to get this working for Chinese in Kubuntu (intrepid KDE 4.1)

    Any help greatly appreciated.

    Cheers,

    James
    I pity the fool.

Page 1 of 10 123 ... LastLast

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •