Page 1 of 9 123 ... LastLast
Results 1 to 10 of 90

Thread: Ubuntu 8.10 (Ibex) Pulse Audio removal.

  1. #1
    Join Date
    Nov 2008
    Beans
    2

    Post Ubuntu 8.10 (Ibex) Pulse Audio removal.

    I totally understand why Ubuntu is pushing for this technology, but also understand that it does hinder the community. I myself have found PulseAudio to be more trouble than its worth, and removed it.

    See I like to play my World of Warcraft and Music in the back ground without 10% of my CPU being used by Pulseaudio, when I could be enjoying smoother game play.. Not to mention there was a clear reduction in sound clarity, but this may have been something related to my Soundcard's configuration through Pulseaudio.

    First things First. Remove the packages though Bash.

    sudo apt-get remove pulseaudio
    sudo apt-get install esound

    sudo rm /etc/X11/Xsession.d/70pulseaudio
    (You may want to back this up)

    Now this is done you will want check your Gnome Preferences.

    Under System -> Preferences -> Sound
    Make sure they are all set to 'Autodetect'.
    The only one you will have to set manually to ALSA is 'Sound Capture' under 'Audio Conferencing'.
    Note at this point Pulseaudio is now nolonger an option under these drop menus.

    Under System -> Preferences -> Sessions
    Deselected or Remove the Pulseaudio Manager

    The last part is one I think a lot of people have missed. Your asoundrc's under your Home Directory are still configured for Pulse.

    cd ~
    rm .asound*
    (Again! You may want to back this up)

    One this is done your back to ALSA's default configuration.

    This worked a charm for me and found all my software picked up Dmix and Dsnoop.
    I hope it does wonders for you.. Good Luck.
    Last edited by DSCP46; November 7th, 2008 at 07:25 AM.

  2. #2
    Join Date
    Dec 2004
    Location
    Atlanta, GA USA
    Beans
    7,257
    Distro
    Ubuntu Development Release

    Re: Ubuntu 8.10 (Ibex) Pulse Audio removal.

    thanks for this, but you will need to change
    Code:
    sudo apt-get remove pulse
    to
    Code:
    sudo apt-get remove pulseaudio
    cheers.

  3. #3
    Join Date
    Nov 2008
    Beans
    2

    Re: Ubuntu 8.10 (Ibex) Pulse Audio removal.

    Quote Originally Posted by wolfen69 View Post
    thanks for this, but you will need to change
    Code:
    sudo apt-get remove pulse
    to
    Code:
    sudo apt-get remove pulseaudio
    cheers.
    Thanks for the heads up! Done now.

    Cheers

  4. #4
    Join Date
    Jul 2005
    Beans
    5

    Re: Ubuntu 8.10 (Ibex) Pulse Audio removal.

    This doesnt work without wanting to take ubuntu-desktop with it. Any suggestions?

  5. #5
    Join Date
    Sep 2007
    Beans
    35
    Distro
    Ubuntu 7.04 Feisty Fawn

    Re: Ubuntu 8.10 (Ibex) Pulse Audio removal.

    Quote Originally Posted by NeeBone View Post
    This doesnt work without wanting to take ubuntu-desktop with it. Any suggestions?
    thats just the metapackage it wont actually remove ubuntu or the desktop
    i may try this out, i hate pulse too

  6. #6
    Join Date
    Jul 2005
    Beans
    5

    Re: Ubuntu 8.10 (Ibex) Pulse Audio removal.

    Sweet! Worked fine.... AFTER I deleted /etc/asound.conf as well as the one in ~/

    Sound working flawlessly now. Thanks!

  7. #7
    Join Date
    May 2008
    Beans
    98

    Re: Ubuntu 8.10 (Ibex) Pulse Audio removal.

    thanks for this, i ran the following:
    killall pulseaudio
    sudo apt-get remove pulseaudio
    sudo apt-get install esound esound-clients libao2
    sudo mv /etc/X11/Xsession.d/70pulseaudio ~/backup/pulsebackup/

    and ive got my ubuntu back first time ive got decent sound since gutsy

  8. #8
    Join Date
    Jan 2008
    Location
    Vancouver
    Beans
    48
    Distro
    Ubuntu

    Re: Ubuntu 8.10 (Ibex) Pulse Audio removal.

    Thanks worked for me.

    My usb audio device start only partially working in Intrepid, this fixed it.
    Last edited by falkaholic; November 9th, 2008 at 02:12 AM. Reason: spelling

  9. #9
    Join Date
    Nov 2007
    Beans
    30

    Re: Ubuntu 8.10 (Ibex) Pulse Audio removal.

    After reading this string. It sounds like this will work, but will not remove the desktop right? Also, please what is the easiest, quickest way to backup the files that are mentioned here?

    Can you give me the code to backup files? Linux newb here. I was sooo use to DOS in the day but this is like learning French!

    I am so tempted to try without backing up, but Murphy's law will get me as it usually does! Thanks all!

  10. #10
    Join Date
    Sep 2005
    Location
    Vancouver, Canada
    Beans
    85
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: Ubuntu 8.10 (Ibex) Pulse Audio removal.

    Thanks very very much DSCP46 and all . worked flawlessly.. I was one step away from going baack to hardy..Pulse audio is just a pain..

    BUT...Just one problem though still persistent since I upgraded to Ibex yesterday, Front Mic on my Desktop case is not working,..Speakers are working on rear and front case panels perfectly. Mic is working in rear panel as well, only the Front panel Mic.. No way.. I made sure many times that alsamixer Captures and mics settings are all boosted and unmuted..
    was never been a problem with Hardy..
    I have an HDA Intel Realtek ALC888 Chip..

    Can you please help ??

    Thanks

Page 1 of 9 123 ... LastLast

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •