Results 1 to 10 of 10

Thread: Intrepid BCM4318 AcerHK Aspire 5020

  1. #1
    Join Date
    Apr 2008
    Beans
    34

    Lightbulb Intrepid BCM4318 AcerHK Aspire 5020

    Hi,
    New Ubuntu means new ways to set up wireless.
    These steps worked for me:

    1- Install Intrepid normally
    2- Connect using a wired connection
    3- Update (System>Administration>Update Manager>Check>Install Updates)
    4- Restart computer
    5- Connect again using a wired connection
    6- Activate B43 (System>Administration>Hardware Drivers>Broadcom B43...)
    7- Open a terminal (Applications>Accessories>Terminal)
    8- Get permissions (Type: "sudo bash" and enter your password)
    9- Add acerhk module (Type: "echo acerhk >> /etc/modules")
    10-Turn on wireless when booting (Type: "gedit /etc/rc.local")

    Add "echo 1 > /proc/driver/acerhk/wirelessled" before "exit 0" line

    My "rc.local" file, looks like:

    #!/bin/sh -e
    # # rc.local
    # # This script is executed at the end of each multiuser runlevel.
    # Make sure that the script will "exit 0" on success or any other
    # value on error.
    # # In order to enable or disable this script just change the execution
    # bits.
    # # By default this script does nothing.
    echo 1 > /proc/driver/acerhk/wirelessled
    exit 0


    11 - Restart computer

    Done ! I hope this thread helps someone
    Last edited by optimisme; November 4th, 2008 at 04:46 PM.

  2. #2
    Join Date
    Nov 2008
    Beans
    7

    Re: Intrepid BCM4318 AcerHK Aspire 5020

    Thank you, i'll try the procedure as soon as i get a wired connection.
    Do you think is it the same procedure for the Hardy here ?
    http://ubuntuforums.org/showthread.p...highlight=5020

    Would this procedure go also for Ibex, in order to have a "working" wifi key ?
    Thank you again and again

  3. #3
    Join Date
    Oct 2006
    Beans
    Hidden!

    Re: Intrepid BCM4318 AcerHK Aspire 5020

    Nice! Works for my Acer Aspire 5024WLMi. Thanks a lot!

  4. #4
    Join Date
    Nov 2008
    Beans
    7

    Re: Intrepid BCM4318 AcerHK Aspire 5020

    j4ni, is still working after the reboot or you have to give the command to switch the wifi on ?
    or had you already an available script to do that ?

  5. #5
    Join Date
    Apr 2008
    Beans
    34

    Re: Intrepid BCM4318 AcerHK Aspire 5020

    Hi

    After every new Reboot, the file "/etc/rc.local" will turn on the wireless automatically, using the command "echo 1 > /proc/driver/acerhk/wirelessled".

    If you don't want to have wireless ON by default when booting, skip step number 10, but then you will have to turn it ON typing:

    sudo echo 1 > /proc/driver/acerhk/wirelessled

    See u

    (PD: No, is not the same procedure than the one for Hardy Heron, some parts are similar but I think the old procedure doesn't work anymore)
    Last edited by optimisme; November 5th, 2008 at 08:52 PM.

  6. #6
    Join Date
    Nov 2008
    Beans
    7

    Re: Intrepid BCM4318 AcerHK Aspire 5020

    it works wonderful !!!
    thank you !!!
    and with a 3023 (yeah, ok, it's i.e. a 5024 with a sempron processor)
    a question more: are you using wicd or network manager ?

    and now to fix the next issue !!!!

  7. #7
    Join Date
    Apr 2006
    Beans
    7

    Re: Intrepid BCM4318 AcerHK Aspire 5020

    I had to echo "1" in the file here:

    /sys/devices/platform/acer-wmi/

    It wouldn't work here: /proc/driver/acerhk/

  8. #8
    Join Date
    Jan 2009
    Beans
    1

    Re: Intrepid BCM4318 AcerHK Aspire 5020

    thankyou tthorb i have to do the same to activate my wireless

  9. #9
    Join Date
    May 2007
    Location
    Surrey, UK
    Beans
    12

    Re: Intrepid BCM4318 AcerHK Aspire 5020

    Please do not use acerhk on laptops that are supported by acer_acpi (bundled with *buntu 8.04) / acer-wmi (included in the kernel as of 2.6.25, *buntu 8.10 and above).

    acerhk is:

    1) Not actively maintained
    2) Is not as fully featured as acer-wmi
    3) Doesn't work on x86-64

    All you need to do is, as tthorb pointed out, is add this to rc.local:

    echo 1 > /sys/devices/platform/acer-wmi/wireless

    (acer-wmi is actively maintained & developed on my Aspire 5020, so it does work rather well on the 5020/ 3020 series, for obvious reasons

  10. #10
    Join Date
    Jun 2007
    Location
    Planet-Untu
    Beans
    156
    Distro
    Ubuntu 8.10 Intrepid Ibex

    Re: Intrepid BCM4318 AcerHK Aspire 5020

    For those that have an older Acer that does use the AcerHK driver, you may find my little utility helpful:

    http://acerhkgui.sourceforge.net

    Contributors welcome. I am very new to programming and this is my "FIRST" release of anything and contribution to the opensource community.

    CARLOS: Is there a list of what hardware shouldn't use AcerHK?

    Warm Regards to All!
    ARM-C

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •