Results 1 to 2 of 2

Thread: Installing Packages on Server with limited Privileges

  1. #1
    Join Date
    Apr 2008

    Question Installing Packages on Server with limited Privileges

    I'm trying to install the ImageMagick package as well as a program called OOF2 on a server at my university. I have been given privileges to install in the folder /afs/

    when trying to install ImageMagick i run the commands

    make install

    during the make install it tries to install to /usr/bin/local/...... which i do not have privileges to so the install fails

    i have tried the -prefix= and the -exec-prefix= options on the configure however the make install still tries to install to /usr/bin/local

    how can i limit the install to my folder /afs/ so i will have privileges to install it?

    For the oof2 install i have to run
    python build
    python install

    is there similar options for these commands that will allow me to limit the install to the folder /afs/

  2. #2
    Join Date
    May 2007
    Ubuntu 7.04 Feisty Fawn

    Re: Installing Packages on Server with limited Privileges

    Its a double dash ('--', not '-') for the prefix option:
    ./configure --prefix=/home/james/ImageMagick
    For the python package try:
    python build
    python install --prefix=/home/james/oof2
    I was only able to try the ImageMagick bit but it worked, unprivilaged. As for oof2 it seemed to crash during build, and seems I have no intention of using it, and I assume you already have it built, I'll leave it there.

    Hope this helps!
    I have long messy hair, scruffy clothes and bang on about freedom as if I'd been in prison for the last 50 years -- I am of course a Free Software Advocate.

Tags for this Thread


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts