Results 1 to 4 of 4

Thread: I just upgraded to ubuntu 8.10 and now I can't start apache.

  1. #1
    Join Date
    Nov 2008
    Beans
    2

    I just upgraded to ubuntu 8.10 and now I can't start apache.

    I just upgraded to ubuntu 8.10 and now I can't start apache.

    The following error occurs

    Starting XAMPP for Linux 1.6.8a...
    XAMPP: Starting Apache with SSL (and PHP5)...
    XAMPP: Error 139! Couldn't start Apache!
    XAMPP: Starting diagnose...
    XAMPP: Sorry, I've no idea what's going wrong.
    XAMPP: Please contact our forum http://www.apachefriends.org/f/
    XAMPP: Starting MySQL...
    XAMPP: Starting ProFTPD...
    XAMPP for Linux started.



    Tried to start apache and I got the following error


    Segmentation fault


    any suggestions?

    I have already ask at http://www.apachefriends.org/f/viewtopic.php?t=31825

  2. #2
    Join Date
    Nov 2008
    Beans
    2

    Lightbulb Re: I just upgraded to ubuntu 8.10 and now I can't start apache.

    what about just using apache2.2-common php5-common and mysql-common
    and phpmyadmin which is nearly all you may need from xampp, maybe add proftpd or vsftpd to it for ftp support, okay needs some time for proper configuration but does the job.

    openssl for https support
    lighttpd if you like to play a bit around check out lighttpd which is a smaller, maybe faster replacement for apache

    i found some config tuning for lighttpd on the net at: https://calomel.org/lighttpd.html just in case...


    --if you like to keep your xampp you should post some of the error log messages which normaly can be found under /var/log

    else there is no real chance to track down the error


    greedies

  3. #3
    Join Date
    Aug 2008
    Location
    WA
    Beans
    2,186
    Distro
    Ubuntu

    Re: I just upgraded to ubuntu 8.10 and now I can't start apache.

    Did you install apache from source originally?

    Ether -- rebuild from source
    or
    Remove and purge apache (maybe all of lamp) with dpkg and use apt-get to reinstall.

  4. #4
    Join Date
    Nov 2008
    Beans
    2

    Re: I just upgraded to ubuntu 8.10 and now I can't start apache.

    Thank you for your response.

    I have installed xampp because in every forum I read, everybody was saying to if you want apache php and mysql in ubuntu the easyest way is xampp.

    and I have installed it since 7.10 that was the first release I used. since then I have upgraded to 8.4 and now to 8.10.

    I now changed the httpd.conf file with the default one and I have started apache but I have lost all my settings.

    I'll try to find the differences in two files and I'll add line by line restarting apache, so I'll catch the problem.

    Thank you all for your time and your consultations and I'll inform you for the problem if I could find it.

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •