Results 1 to 7 of 7

Thread: [SOLVED] Intrepid: how to force vesa driver on boot

  1. #1
    Join Date
    Apr 2007
    Location
    Arkansas
    Beans
    222
    Distro
    Ubuntu 9.04 Jaunty Jackalope

    [SOLVED] Intrepid: how to force vesa driver on boot

    I had to install Ubuntu using the alternate disc because the live disc would not work. Now it hangs right after I log in.

    I suspect it is a problem with the video driver, so I need to try to make it use the Vesa driver, but the video line in the xorg.conf only says "configured video driver". Should I replace that with the word "Vesa"?

    Thanks!

  2. #2
    Join Date
    Dec 2006
    Location
    US and A
    Beans
    919
    Distro
    Ubuntu Development Release

    Re: Intrepid: how to force vesa driver on boot

    Make sure the following lines are in your Xorg.conf:

    Section "Device"
    Identifier "Configured Video Device"
    Driver "vesa"
    EndSection
    _,-O
    O
    (_)) ubuntu -
    -`-O

  3. #3
    Join Date
    Apr 2007
    Location
    Arkansas
    Beans
    222
    Distro
    Ubuntu 9.04 Jaunty Jackalope

    Re: Intrepid: how to force vesa driver on boot

    Thanks for the quick reply!

    Another question: Recovery mode mounts the filesystem as read only. How can I change that so that I can write the changes to the xorg.conf file?

  4. #4
    Join Date
    Dec 2006
    Location
    US and A
    Beans
    919
    Distro
    Ubuntu Development Release

    Re: Intrepid: how to force vesa driver on boot

    Quote Originally Posted by jonathanmotes View Post
    Thanks for the quick reply!

    Another question: Recovery mode mounts the filesystem as read only. How can I change that so that I can write the changes to the xorg.conf file?
    Hmmm..never heard of this. At any rate, you can unmount the drive (umount command) then remount (mount command) with read/write flag -rw I think. Look at: man mount
    _,-O
    O
    (_)) ubuntu -
    -`-O

  5. #5
    Join Date
    Apr 2007
    Location
    Arkansas
    Beans
    222
    Distro
    Ubuntu 9.04 Jaunty Jackalope

    Re: Intrepid: how to force vesa driver on boot

    I'm having trouble figuring out how to mount/umount. I'll try again later tonight (I've got a class soon).

    I once got a warning that I needed to do a disk scan (fstab or something). Maybe that is the reason it is read only. Do you know how to do a disk scan from the terminal?

    Thanks!

  6. #6
    Join Date
    Dec 2006
    Location
    US and A
    Beans
    919
    Distro
    Ubuntu Development Release

    Re: Intrepid: how to force vesa driver on boot

    fsck
    _,-O
    O
    (_)) ubuntu -
    -`-O

  7. #7
    Join Date
    Apr 2007
    Location
    Arkansas
    Beans
    222
    Distro
    Ubuntu 9.04 Jaunty Jackalope

    Re: Intrepid: how to force vesa driver on boot

    Thanks Soldierboy! You were a great help. I succeeded in applying the vesa driver after doing the disk scan. I later discovered the root of my problem was conflicting video cards, not the driver, but I could not have determined that without applying other drivers!

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •