Page 1 of 7 123 ... LastLast
Results 1 to 10 of 61

Thread: [SOLVED] Atheros AR242 on ubuntu 8.10

  1. #1
    Join Date
    Oct 2008
    Location
    Next to my neighbour
    Beans
    72
    Distro
    Ubuntu 8.10 Intrepid Ibex

    [SOLVED] Atheros AR242 on ubuntu 8.10

    I have recently updated to ubuntu 8.10 everything went fine except for my atheros wireless card which ubuntu still doesn't detect(actually it does detect it but the wireless just doesn't work) I had previously tried installing madwifi on ubuntu 8.04 but with being an ubuntu newb and all I failed but by searching around I have seen that I just need to enable ath5k with ubuntu 8.10 unfortunately I have no idea what that is and even less of an idea on how to enable it also if this isn't the way to make my wireless card work could you point me to some alternative instructions to get my wireless card to finally work thanks for taking the time to read this.

    _____
    oh and by the way I have a compaq c700(c793VU) not sure if that would help but you never know.

    _____
    here are some infos:


    uname -a
    Code:
    Linux krauth-laptop 2.6.27-7-generic #1 SMP Thu Oct 30 04:18:38 UTC 2008 i686 GNU/Linux

    lspci | grep -i net
    Code:
    01:00.0 Ethernet controller: Atheros Communications Inc. AR242x 802.11abg Wireless PCI Express Adapter (rev 01)
    02:01.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL-8139/8139C/8139C+ (rev 10)

    iwconfig
    Code:
    lo        no wireless extensions.
    
    eth0      no wireless extensions.
    
    pan0      no wireless extensions.
    
    wmaster0  no wireless extensions.
    
    wlan0     IEEE 802.11bg  ESSID:""  
              Mode:Managed  Frequency:2.412 GHz  Access Point: Not-Associated   
              Tx-Power=27 dBm   
              Retry min limit:7   RTS thr:off   Fragment thr=2352 B   
              Power Management:off
              Link Quality:0  Signal level:0  Noise level:0
              Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
              Tx excessive retries:0  Invalid misc:0   Missed beacon:0
    ifconfig

    Code:
    eth0      Link encap:Ethernet  HWaddr 00:1e:ec:a3:2b:7c  
              inet addr:192.168.0.100  Bcast:192.168.0.255  Mask:255.255.255.0
              inet6 addr: fe80::21e:ecff:fea3:2b7c/64 Scope:Link
              UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
              RX packets:5330 errors:0 dropped:0 overruns:0 frame:0
              TX packets:5384 errors:0 dropped:0 overruns:3 carrier:0
              collisions:0 txqueuelen:1000 
              RX bytes:5147983 (5.1 MB)  TX bytes:898951 (898.9 KB)
              Interrupt:16 Base address:0x1000 
    
    lo        Link encap:Local Loopback  
              inet addr:127.0.0.1  Mask:255.0.0.0
              inet6 addr: ::1/128 Scope:Host
              UP LOOPBACK RUNNING  MTU:16436  Metric:1
              RX packets:262 errors:0 dropped:0 overruns:0 frame:0
              TX packets:262 errors:0 dropped:0 overruns:0 carrier:0
              collisions:0 txqueuelen:0 
              RX bytes:16604 (16.6 KB)  TX bytes:16604 (16.6 KB)
    
    wlan0     Link encap:Ethernet  HWaddr 00:23:4d:03:47:d9  
              UP BROADCAST MULTICAST  MTU:1500  Metric:1
              RX packets:0 errors:0 dropped:0 overruns:0 frame:0
              TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
              collisions:0 txqueuelen:1000 
              RX bytes:0 (0.0 B)  TX bytes:0 (0.0 B)
    
    wmaster0  Link encap:UNSPEC  HWaddr 00-23-4D-03-47-D9-00-00-00-00-00-00-00-00-00-00  
              UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
              RX packets:0 errors:0 dropped:0 overruns:0 frame:0
              TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
              collisions:0 txqueuelen:1000 
              RX bytes:0 (0.0 B)  TX bytes:0 (0.0 B)
    ________
    Edit: Wireless works after the install it's just that the led does not turn blue and there is no alert message saying the wireless has been turned off so I guess this is solved.
    Last edited by Karilex; November 3rd, 2008 at 01:01 PM.

  2. #2
    Join Date
    Apr 2006
    Location
    UK
    Beans
    6,646
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: Atheros AR242 on ubuntu 8.10

    You can try this: https://help.ubuntu.com/community/AspireOne110L#WLan

    It is for the AspireOne, but I believe you have the same wifi card.

    No promises though - perhaps do some googling to double-check.

  3. #3
    Join Date
    Dec 2007
    Location
    Buenos Aires, Argentina
    Beans
    1,231
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: Atheros AR242 on ubuntu 8.10

    Hi there Karilex,

    I have the same WiFi card, on a Compaq F700, which I think is how they called the same model over here,
    I have just tested the, let's call it, "method" of:
    Code:
    sudo aptitude install linux-backports-modules-intrepid-generic
    On my fresh -less than 24 hrs old install- of Intrepid. It worked perfectly.

    Here are the steps:

    1- Disable the "Support for Atheros 802.11 wireless LAN cards" on Hardware Drivers, and reboot your box.
    2- Once it is back on, open a Terminal, and type:
    Code:
    sudo aptitude install linux-backports-modules-intrepid-generic
    It will ask your password, this is what it prints on screen, that is, what it will do:
    Code:
    esteban@tango:~/Desktop$ sudo aptitude install linux-backports-modules-intrepid-generic
    [sudo] password for esteban: 
    Reading package lists... Done
    Building dependency tree       
    Reading state information... Done
    Reading extended state information      
    Initializing package states... Done
    The following NEW packages will be installed:
      linux-backports-modules-2.6.27-7-generic{a} 
      linux-backports-modules-intrepid-generic 
    0 packages upgraded, 2 newly installed, 0 to remove and 0 not upgraded.
    Need to get 1173kB of archives. After unpacking 3772kB will be used.
    Do you want to continue? [Y/n/?]
    When that is over (you'll get your prompt back), reboot, and enjoy the WiFi connection.
    Personally, I can't still believe it, I have spent hours on Hardy with this... The WiFi card used to work, I was able to set an IP address to ip, etc, but it was impossible to connect to any type of network.

    But that was Hardy, on Intrepid, after the backports installation, I had no problem connecting to my WPA2 DLink AP (after autenticating me of course).
    Good luck, I hope this is useful.

    This is my WiFi card, according to 'lspci':

    Code:
    esteban@tango:~/Desktop$ lspci | grep Atheros
    03:00.0 Ethernet controller: Atheros Communications Inc. AR242x 802.11abg Wireless PCI Express Adapter (rev 01)
    esteban@tango:~/Desktop$
    Other links on this:
    Instalando WiFi Atheros AR242X Ubuntu intrepid Ibex 8.10 - in Spanish
    Atheros Wireless in Ubuntu 8.10 Intrepid Ibex - Recommends installing the backports *before* disabling the Atheros 802.11 card. I haven't done that.
    Live long and prosper.
    And use lotsa Linux, BSD, and Emacs.

  4. #4
    Join Date
    Oct 2008
    Location
    Next to my neighbour
    Beans
    72
    Distro
    Ubuntu 8.10 Intrepid Ibex

    Re: Atheros AR242 on ubuntu 8.10

    Thanks a lot for your help but unfortunately i tried the installation the "Support for 5xxx series of Atheros 802.11 wireless LAN cards" does appear in my list of hardware drivers but my wireless still doesn't work it may be just the led and the button that don't work if it is is there some kind of command to turn my wireless on?

  5. #5
    Join Date
    Jul 2007
    Location
    Melbourne, Australia
    Beans
    3,475
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: Atheros AR242 on ubuntu 8.10

    I used ndiswrapper to get that card going. Look here.
    Windows is the best virus detector on the market!
    Ubuntu attracts Human Beings - Windows attracts viruses and worms

  6. #6
    Join Date
    Dec 2007
    Location
    Buenos Aires, Argentina
    Beans
    1,231
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: Atheros AR242 on ubuntu 8.10

    Quote Originally Posted by Karilex View Post
    Thanks a lot for your help but unfortunately i tried the installation the "Support for 5xxx series of Atheros 802.11 wireless LAN cards" does appear in my list of hardware drivers but my wireless still doesn't work it may be just the led and the button that don't work if it is is there some kind of command to turn my wireless on?
    Too bad it didn't work, the led is still red, it didn't change.
    Live long and prosper.
    And use lotsa Linux, BSD, and Emacs.

  7. #7
    Join Date
    Oct 2008
    Location
    Next to my neighbour
    Beans
    72
    Distro
    Ubuntu 8.10 Intrepid Ibex

    Re: Atheros AR242 on ubuntu 8.10

    With the ndiswrapper I install the net 5211 file and it says the hardware is present but the wireless still doesn't startafter i reboot what do i do next?

  8. #8
    Join Date
    Jul 2006
    Location
    Washington, DC
    Beans
    1,678
    Distro
    Kubuntu Development Release

    Re: Atheros AR242 on ubuntu 8.10

    Get rid of ndiswrapper and disable whatever drivers are currently attempting to handle it. Install linux-backports-modules-intrepid and reboot.

    LinuxChix | Linux User #432169 | Ubuntu User #8495 | IRC: maco @ irc.linuxchix.org or irc.freenode.net

  9. #9
    Join Date
    Oct 2008
    Location
    Next to my neighbour
    Beans
    72
    Distro
    Ubuntu 8.10 Intrepid Ibex

    Re: Atheros AR242 on ubuntu 8.10

    Should I enable the"support for 5xxx series atheros 802.11?"

  10. #10
    Join Date
    Jun 2006
    Location
    Syracuse, NY
    Beans
    3,264

    Re: Atheros AR242 on ubuntu 8.10

    Quote Originally Posted by Karilex View Post
    Should I enable the"support for 5xxx series atheros 802.11?"
    NO.

    Install the package suggested in the post above instead.
    Desktop: AMD Athlon64 X2 3600+, Nvidia 8600GT, 3GB RAM, 80GB hd, Windows 7 Beta
    Lappy: Sony Vaio FW-140E, Intel P8400 2.26Ghz, 3GB Ram, 250GB HD, Intel x4500MHD, Windows 7 Beta & Kubuntu 8.10 w/ KDE 4.2

Page 1 of 7 123 ... LastLast

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •