Results 1 to 5 of 5

Thread: HAL and xinput - disabling device

  1. #1
    Join Date
    Sep 2006
    Location
    Denmark
    Beans
    22
    Distro
    Ubuntu 7.10 Gutsy Gibbon

    HAL and xinput - disabling device

    Hi, I just upgraded to Ubuntu Intrepid Ibex and sadly found that my IBM USB Keyboard with Ultranav wasn't working properly anymore.

    I have previously had problems with using scrolling and with disabling the touchpad, but got that solved using xorg.conf.

    Apparantly xorg.conf isn't used to configure input devices anymore, so I searched around a bit, and found out, that I needed to configure HAL to enable my scrolling. I got that to work by creating a .fdi file and using x11 configuration options in that one.

    Now I need to disable my Touchpad - I can do that runtime using the command
    Code:
    xinput set-int-prop 4 "Device Enabled" 32 0
    I use the device id 4 in the command (i found that using xinput list) since I have 2 entries named "Synaptics Inc. Composite Touchpad / Trackpoint".

    But I want to do that automatically everytime my system boots. I could probably run a script at startup that executes the above command, but there must be a better way. Can I somehow disable the touchpad, I feel that there must be a way to set this permanently.

    Thanks for your help.

    /Kyozo

  2. #2
    Join Date
    Sep 2006
    Location
    Denmark
    Beans
    22
    Distro
    Ubuntu 7.10 Gutsy Gibbon

    Re: HAL and xinput - disabling device

    Bump - come on, there must be somebody that knows this

    /Kyozo

  3. #3
    Join Date
    Oct 2006
    Beans
    1

    Re: HAL and xinput - disabling device

    for me it works in /etc/gdm/PostLogin/Default

  4. #4
    Join Date
    Jan 2008
    Beans
    2

    Re: HAL and xinput - disabling device

    Kyozo,

    I got it working with mostly your earlier setup, plus one additional section in my xorg.conf:

    Section "ServerFlags"
    Option "AutoAddDevices" "False"
    EndSection

    I did not do anything with HAL. Scrolling and all that work just fine. If you need to see my xorg.conf, let me know.

  5. #5
    Join Date
    Jan 2008
    Beans
    2

    Re: HAL and xinput - disabling device

    May or may not be related:

    After making that change in my xorg.conf file, the mouse would randomly cut out. It looked like it was being-recreated very rapidly (input device numbers quickly approaching 100).

    I removed that xorg.conf entry that I added, and haven't seen problems so far...

    Probably have to give it a go with HAL.

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •