Page 1 of 8 123 ... LastLast
Results 1 to 10 of 71

Thread: [SOLVED] Atheros AR5007EG or AR242x in 8.10

  1. #1
    Join Date
    Jan 2006
    Location
    Loughborough, UK
    Beans
    8
    Distro
    Ubuntu 8.10 Intrepid Ibex

    Talking [SOLVED] Atheros AR5007EG or AR242x in 8.10

    Here's the solutions (although both give inconsistent connections):
    1. You can try the linux-backports-modules-intrepid method outlined here http://ubuntuforums.org/showpost.php...69&postcount=3 which people have said is a better connection, but you'll need to reload the driver every time you log in.
      OR
    2. Compile latest ath5k driver:

    If you have problems and need to uninstall you can do:
    Code:
    sudo make unload
    sudo make uninstall
    in the source directory.
    Last edited by Malet; November 5th, 2008 at 01:05 PM.

  2. #2
    Join Date
    Jan 2006
    Location
    Loughborough, UK
    Beans
    8
    Distro
    Ubuntu 8.10 Intrepid Ibex

    Re: Atheros AR5007EG or AR242x in 8.10

    See above post
    Last edited by Malet; November 5th, 2008 at 01:06 PM.

  3. #3
    Join Date
    Oct 2008
    Beans
    2

    Re: Atheros AR5007EG or AR242x in 8.10

    hey i have an acer laptop with a atheros wireless card and i can't seem to get mine to work either. did you do this in terminal?

  4. #4
    Join Date
    Jan 2006
    Location
    Loughborough, UK
    Beans
    8
    Distro
    Ubuntu 8.10 Intrepid Ibex

    Re: Atheros AR5007EG or AR242x in 8.10

    Putting that in terminal should work - Apparently ath5k was included in 8.10 but just disabled by default so there's probably a much easier way of doing this.

  5. #5
    Join Date
    Oct 2008
    Beans
    2

    Re: Atheros AR5007EG or AR242x in 8.10

    when i get to your cd compat-wireless-2.6 it says No such file or directory then when i do the sudu make install i get make: *** No rule to make target `install'. Stop.

  6. #6
    Join Date
    Jan 2006
    Location
    Loughborough, UK
    Beans
    8
    Distro
    Ubuntu 8.10 Intrepid Ibex

    Re: Atheros AR5007EG or AR242x in 8.10

    Ok I think I've fixed it now - although the folder name will probably change.
    it should have been
    Code:
    cd compat-wireless-2008-10-31

  7. #7
    Join Date
    Oct 2008
    Location
    Egypt
    Beans
    6
    Distro
    Ubuntu Jaunty Jackalope (testing)

    Re: Atheros AR5007EG or AR242x in 8.10

    I have the same card but haven't upgraded yet (still downloading ).
    Thanks for posting your solution. The problem is mentioned in the Release Notes Here.
    So, installing linux-backports-modules-intrepid-generic should solve it. If not, your solution will become handy .

  8. #8
    Join Date
    Apr 2006
    Beans
    27
    Distro
    Dapper Drake Testing/

    Re: [SOLVED] Atheros AR5007EG or AR242x in 8.10

    Thanks! It looks messy but it works. Installing the backports didn't work for me but this did.

  9. #9
    Join Date
    Sep 2005
    Beans
    94

    Re: [SOLVED] Atheros AR5007EG or AR242x in 8.10

    If you goto the wireless.kernel.org website, it says they have blocked direct downloads from things such as wget if you don't get a dated file. So use a browser and goto:

    http://wireless.kernel.org/download

    and download it via web browser.

    But for the record, I stuck in the CD, enabled it (You have to enable it in software sources or repositories or it won't work), reloaded, installed linux-backports-modules-intrepid-generic and rebooted and it automagically worked.

    So if you had trouble with the backports method, make sure you're enabling and reloading or it won't work.

    Cheers,
    KermitJr

  10. #10
    Join Date
    May 2007
    Beans
    1

    Re: Atheros AR5007EG or AR242x in 8.10

    Quote Originally Posted by Malet View Post
    I've now got it working!!! for anyone with similar problems here's what I did:

    Code:
    wget http://wireless.kernel.org/download/compat-wireless-2.6/compat-wireless-2008-10-31.tar.bz2
    tar jxvf compat-wireless-2.6.tar.bz2
    cd compat-wireless-2008-10-31
    make
    sudo make install
    sudo make unload
    sudo make load
    Then reboot and it should be working in network-manager
    I can confirm that this approach works very well for getting wireless connection to work on the Fujitsu Siemens Esprimo Mobile v5535

    Good work

Page 1 of 8 123 ... LastLast

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •