Page 1 of 2 12 LastLast
Results 1 to 10 of 11

Thread: [SOLVED] Staticy/choppy audio in wine (Ubuntu 8.10)

  1. #1
    Join Date
    Aug 2008
    Beans
    5

    Unhappy [SOLVED] Staticy/choppy audio in wine (Ubuntu 8.10)

    Okay, so I upgraded from Ubuntu 8.4 to 8.10 earlier today, and everything went smoothly.

    I'm having one problem, though

    Whenever I open up World of Warcraft under Wine, the audio is absolutely horrible! I've never had a problem like this before, so I know it's something in 8.10 that's doing it.

    The only advice I could find with google was to kill the PulseAudio process with the system monitor, but that just kills all of my sound.

    Does anyone else have this problem? What do I do?


  2. #2
    Join Date
    Jul 2006
    Location
    Kalamazoo, MI USA
    Beans
    70

    Re: Staticy/choppy audio in wine (Ubuntu 8.10)

    I experienced this as well. If you are using the latest version the audio for WoW seems broken, again. If you have the audio fix suggested from the Ubuntu help site that you include in your Config.wtf you might want to try buffer values like 50 or 100.

    Code:
    SET Sound_SoundOutputSystem "1"
    SET Sound_SoundBufferSize "150" <-- if your value looks like this try the
    above mentioned.
    I just didn't want to fight with it that much so I went back to the repo version (in hardy) but you can get 1.1.5 from winehq.org under their Ubuntu section. The issue is not present in that version.

    Also, I had a lot of issues getting wine to work with pulseaudio and mumble voice chat. I had to set all the sound preferences to ALSA and delete all my asound config files (/etc/asound* and ~/.asound*) and reboot. Then I could voice chat, WoW, stream audio, everything but flash audio. My sound card is an nforce3 Realtek based codec.

  3. #3
    Join Date
    Dec 2006
    Beans
    5
    Distro
    Ubuntu 8.10 Intrepid Ibex

    Re: Staticy/choppy audio in wine (Ubuntu 8.10)

    I'm having this problem too, only on a different game - civ4.
    Before upgrading (on hardy, 8.04) the sound was perfect, and I had no other problems with the game. Now with 8.10, the sound is choppy and contains a lot of static, and in general the game (coming to think of it, also my entire system, actually) seemed to slow down.

    I've tried to change the settings in System -> Preferences -> Sound to ALSA, and then rebooted, it didn't help.
    Using wine v1.1.7 .
    Any ideas?

  4. #4
    Join Date
    Jul 2006
    Location
    Kalamazoo, MI USA
    Beans
    70

    Re: Staticy/choppy audio in wine (Ubuntu 8.10)

    Yes, try using Wine 1.1.5 instead, there are some issues with audio that I have noticed with 1.1.7 possibly due to their attempt to offer Direct X 10 support. You can find the archive list under the Get Wine Now link, Ubuntu section of the winehq.org website.

  5. #5
    Join Date
    Dec 2006
    Beans
    5
    Distro
    Ubuntu 8.10 Intrepid Ibex

    Re: Staticy/choppy audio in wine (Ubuntu 8.10)

    Quote Originally Posted by miwarlock002 View Post
    You can find the archive list under the Get Wine Now link, Ubuntu section of the winehq.org website.
    Thanks for your help
    I tried wine 1.1.6 (no 1.1.5 for Ibex at winehq), didn't change anything.

  6. #6
    Join Date
    Oct 2008
    Beans
    2

    Re: Staticy/choppy audio in wine (Ubuntu 8.10)

    The following worked for me.

    Run

    Code:
    padsp winecfg
    On the audio tab, deselect ALSA and select OSS instead.

    Then, use padsp again when invoking wine:

    Code:
    padsp wine Wow.exe
    Good luck!


    Also - just to say that I also find 8.10 much slower. I multibox 3 accounts at the same time, and have had to dial back the effects settings considerably to get a reasonable framerate. Hopefully just temporary!
    Last edited by sacha99; October 31st, 2008 at 10:12 PM. Reason: More info

  7. #7
    Join Date
    Nov 2006
    Location
    Ontario, Canada
    Beans
    32
    Distro
    Ubuntu 9.04 Jaunty Jackalope

    Re: Staticy/choppy audio in wine (Ubuntu 8.10)

    Give this one a try:

    http://ubuntuforums.org/showthread.p...74#post6075974

    Worked for me.
    Thumper

  8. #8
    Join Date
    Dec 2006
    Beans
    5
    Distro
    Ubuntu 8.10 Intrepid Ibex

    Re: Staticy/choppy audio in wine (Ubuntu 8.10)

    Quote Originally Posted by sacha99 View Post
    Then, use padsp again when invoking wine:

    Code:
    padsp wine Wow.exe
    Good luck!
    This worked for me too, thanks

  9. #9
    Join Date
    Dec 2008
    Beans
    2

    Re: Staticy/choppy audio in wine (Ubuntu 8.10)

    Quote Originally Posted by sacha99 View Post
    The following worked for me.

    Run

    Code:
    padsp winecfg
    On the audio tab, deselect ALSA and select OSS instead.

    Then, use padsp again when invoking wine:

    Code:
    padsp wine Wow.exe

    Golden! thank you very much for this one

  10. #10
    Join Date
    Sep 2007
    Location
    Warsaw, Poland
    Beans
    629
    Distro
    Ubuntu 11.10 Oneiric Ocelot

    Re: Staticy/choppy audio in wine (Ubuntu 8.10)

    Quote Originally Posted by sacha99 View Post
    The following worked for me.

    Run

    Code:
    padsp winecfg
    On the audio tab, deselect ALSA and select OSS instead.

    Then, use padsp again when invoking wine:

    Code:
    padsp wine Wow.exe
    Good luck!


    Also - just to say that I also find 8.10 much slower. I multibox 3 accounts at the same time, and have had to dial back the effects settings considerably to get a reasonable framerate. Hopefully just temporary!
    Moving over to OSS eliminated the staticy sound in Frozen Throne.

Page 1 of 2 12 LastLast

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •