Page 2 of 4 FirstFirst 1234 LastLast
Results 11 to 20 of 36

Thread: [8.04->8.10] Xlib: extension "RANDR" missing on display ":0.0"

  1. #11
    Join Date
    Nov 2008
    Beans
    11
    Distro
    Ubuntu 9.04 Jaunty Jackalope

    Re: [8.04->8.10] Xlib: extension "RANDR" missing on display ":0.0"

    Same issue, not a major hurdle, but it was just great using Compiz - managing research on multiple topics, with a few hundred tabs, 20+ pdfs.

    Sweet times. Anyone tried using Nvidia's 180.06 beta?

  2. #12
    Join Date
    Jan 2007
    Beans
    119

    Re: [8.04->8.10] Xlib: extension "RANDR" missing on display ":0.0"

    I'm currently using the new beta drivers. They are mmm mmm good for a geforce go 7600 user (no more artifacts) and also on my 8600gts.

    I need xinerama though, because I have one screen rotated 90 degrees, while the other is unmodified.

    Twinview doesn't allow a monitor to be rotated, but xinerama doesn't allow compiz to run (no xgl in intrepid ).

    Any help?

  3. #13
    Join Date
    Dec 2006
    Beans
    14
    Distro
    Ubuntu 9.04 Jaunty Jackalope

    Re: [8.04->8.10] Xlib: extension "RANDR" missing on display ":0.0"

    I'm having the same problem on dual monitor system:
    Xlib: extension "RANDR" missing on display ":0.0"
    And I feel that some GUI is slower than it was in 8.04.
    I had to remove all the kde 4 applications because they were too slow.

  4. #14
    Join Date
    Mar 2008
    Beans
    102
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: [8.04->8.10] Xlib: extension "RANDR" missing on display ":0.0"

    I had this error on my fresh install of Ibex until I changed from using a separate X session for each monitor to using TwinView. This also got Compiz working, without me even having to add the lines I did under Hardy, i.e.
    Code:
    Section "Extensions"
    	Option		"Composite"	"Enable"
    EndSection
    and in the Section "Screen":
    Code:
    Option "AddARGBGLXVisuals" "True"
    Here is my xorg, hopefully it's of use to someone. Note: this has custom resolutions defined for my HDTV.
    Code:
    # nvidia-settings: X configuration file generated by nvidia-settings
    # nvidia-settings:  version 1.0  (buildd@palmer)  Mon Nov  3 08:46:46 UTC 2008
    
    Section "ServerLayout"
        Identifier     "Layout0"
        Screen      0  "Screen0" 0 0
        InputDevice    "Keyboard0" "CoreKeyboard"
        InputDevice    "Mouse0" "CorePointer"
    EndSection
    
    Section "Files"
    EndSection
    
    Section "Module"
        Load           "dbe"
        Load           "extmod"
        Load           "type1"
        Load           "freetype"
        Load           "glx"
    EndSection
    
    Section "ServerFlags"
        Option         "Xinerama" "0"
    EndSection
    
    Section "InputDevice"
        # generated from default
        Identifier     "Mouse0"
        Driver         "mouse"
        Option         "Protocol" "auto"
        Option         "Device" "/dev/psaux"
        Option         "Emulate3Buttons" "no"
        Option         "ZAxisMapping" "4 5"
    EndSection
    
    Section "InputDevice"
        # generated from default
        Identifier     "Keyboard0"
        Driver         "kbd"
    EndSection
    
    Section "Monitor"
        # HorizSync source: edid, VertRefresh source: edid
        Identifier     "Monitor0"
        VendorName     "Unknown"
        ModelName      "WYT MNT-DIGITAL19W"
        HorizSync       31.5 - 80.0
        VertRefresh     56.0 - 75.0
        ModeLine       "1208x679_60" 74.600 1208 1344 1416 1640 679 714 726 758 -hsync -vsync
        Option         "DPMS"
    EndSection
    
    Section "Device"
        Identifier     "Device0"
        Driver         "nvidia"
        VendorName     "NVIDIA Corporation"
        BoardName      "GeForce 8800 GTS"
        #################################################################
        # Added so that 1208x679_60 is deemed a valid resolution for my
        # HD TV. 1208x679_60 resolution corrects for overscan.
        Option         "ModeValidation"      "NoDFPNativeResolutionCheck"
        Option         "ExactModeTimingsDVI" "True"
        Option         "RenderAccel"         "True"
        #################################################################
    EndSection
    
    Section "Screen"
        Identifier     "Screen0"
        Device         "Device0"
        Monitor        "Monitor0"
        DefaultDepth    24
        Option         "TwinView" "1"
        Option         "TwinViewXineramaInfoOrder" "DFP-0"
        Option         "metamodes" "DFP-0: 1440x900_75 +1208+0, DFP-1: 1208x679_60 +0+0"
        SubSection     "Display"
            Depth       24
        EndSubSection
    EndSection

  5. #15
    Join Date
    May 2008
    Beans
    35
    Distro
    Ubuntu 9.10 Karmic Koala

    Re: [8.04->8.10] Xlib: extension "RANDR" missing on display ":0.0"

    Dunno if this thread is still on

    Just disable 'xinerama' in xorg.conf! At least it works for me. No errors now.

  6. #16
    Join Date
    Oct 2008
    Beans
    67

    Re: [8.04->8.10] Xlib: extension "RANDR" missing on display ":0.0"

    Quote Originally Posted by samrat1985 View Post
    Just disable 'xinerama' in xorg.conf! At least it works for me. No errors now.
    In order to use multiple monitors, with only one of the monitors rotated, you have to use Xinerama.

  7. #17
    Join Date
    Feb 2008
    Location
    Hamilton, Canada
    Beans
    Hidden!

    Re: [8.04->8.10] Xlib: extension "RANDR" missing on display ":0.0"

    So if I understand correctly, there's no "best of both worlds" configuration? You can either have xinerama on (with monitor rotation, separate X screens, etc), or off (and allow compositing and compiz).

    Seems like a neat little hole that could eventually be fixed...

  8. #18
    Join Date
    Oct 2008
    Beans
    105
    Distro
    Ubuntu

    Re: [8.04->8.10] Xlib: extension "RANDR" missing on display ":0.0"

    Well, in my case, it's just the error message - after I enable xinerama for extended dualhead, I keep getting it, but everything works perfectly anyway .

  9. #19
    Join Date
    Jun 2006
    Beans
    10
    Distro
    Kubuntu 6.06

    Re: [8.04->8.10] Xlib: extension "RANDR" missing on display ":0.0"

    I don't know if this will help, but I just discovered (through the documentation) that the "Rotate" option conflicts with XRandRRotation. Removing the xorg.conf "Rotate" option now allows RANDR to work. Now I just have to figure out how to rotate it on startup...

  10. #20
    Join Date
    May 2009
    Location
    nancy, France
    Beans
    7
    Distro
    Ubuntu 10.04 Lucid Lynx

    Re: [8.04->8.10] Xlib: extension "RANDR" missing on display ":0.0"

    ow I just have to figure out how to rotate it on startup...
    open the nvidia x-server settings with root permission (sudo nvidia-settings) and go to "X Server Display Configuration". In order to be able to rotate each monitor individually, you will have to set the configuration to "separate x screen". If you want to be able to drag windows between both monitors, then also enable Xinerama (unfortunately you can't use compiz with Xinerama enabled).

    After you have done this, save the new configuration; now it's time to manually edit the config file.

    Open the xorg.conf file whatever editor you prefer (sudo gedit /etc/X11/xorg.conf)

    You should see two sections labaled "Monitor"; choose whichever monitor you wish to rotate (it should heopfully give you a model name or something, otherwise you just have to guess). Then add the following lines at the end of the section:

    Option "RandRotate" "on"
    Option "Rotate" "CCW"

    You can either rotate the monitor clockwise or counterclockwise, just enter CW, or CCW in the second line.

    After you finish this, save you xorg.conf and restart the xserver, and one of the monitors should be in portrait mode.


Page 2 of 4 FirstFirst 1234 LastLast

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •