Page 3 of 9 FirstFirst 12345 ... LastLast
Results 21 to 30 of 86

Thread: [SOLVED] Banking Site is very slow

  1. #21
    Join Date
    Apr 2008
    Beans
    6

    Re: Banking Site is very slow

    Hey, guys!

    I am ...guess what ...having the same problem you all got!

    I have been trying to communicate the problem to PC Financial "Tech Support" for more than a week now.
    So just 5 minutes ago I got off the phone with them and they said that they will forward the problem description to the actual tech support guys.
    One interesting thing is - they say not one person called with the same problem before.

    SO - why don't all of you guys call them and tell about the problem so that there's more than one person. I hope then they will take the request seriously.
    So I called 1-888-723-8881, then key in your card number, then choose options 5,1,3.

    Let me(us) know what their response is.
    Some people I talked to on the phone in the course of 7-10 days were absolutely dismissive of the problem...

    cheers

  2. #22
    Join Date
    Oct 2008
    Beans
    3

    Re: Banking Site is very slow

    Quote Originally Posted by miscellanyous View Post
    Thanks for this. I am still having a little trouble. I have noticed a slow connection to pcfinancial.ca for a week or two.

    My system: KDE 3.5.10 / Kubunutu 8.04.1
    browser: Firefox 3.03

    OK, to the problem,
    Code:
    chris@csHome:~$ cd /proc/sys/net/ipv4/
    
    chris@csHome:/proc/sys/net/ipv4$ sudo tcp_window_scaling
    sudo: tcp_window_scaling: command not found

    I also observe all the files in /proc/sys/net/ipv4/ are of size 0 bytes. Is that normal?

    Lastly, I include my /etc/sysctl.conf
    Code:
    #
    # /etc/sysctl.conf - Configuration file for setting system variables
    # See sysctl.conf (5) for information.
    #
    
    #kernel.domainname = example.com
    
    # the following stops low-level messages on console
    kernel.printk = 4 4 1 7
    
    # enable /proc/$pid/maps privacy so that memory relocations are not
    # visible to other users.  (Added in kernel 2.6.22.)
    kernel.maps_protect = 1
    
    # Increase inotify availability
    fs.inotify.max_user_watches = 524288
    
    # protect bottom 64k of memory from mmap to prevent NULL-dereference
    # attacks against potential future kernel security vulnerabilities.
    # (Added in kernel 2.6.23.)
    vm.mmap_min_addr = 65536
    
    ##############################################################3
    # Functions previously found in netbase
    #
    
    # Comment the next two lines to disable Spoof protection (reverse-path filter)
    # Turn on Source Address Verification in all interfaces to
    # prevent some spoofing attacks
    net.ipv4.conf.default.rp_filter=1
    net.ipv4.conf.all.rp_filter=1
    
    # Uncomment the next line to enable TCP/IP SYN cookies
    # This disables TCP Window Scaling (http://lkml.org/lkml/2008/2/5/167)
    #net.ipv4.tcp_syncookies=1
    
    # Uncomment the next line to enable packet forwarding for IPv4
    #net.ipv4.ip_forward=1
    
    # Uncomment the next line to enable packet forwarding for IPv6
    #net.ipv6.ip_forward=1
    
    
    ###################################################################
    # Additional settings - these settings can improve the network
    # security of the host and prevent against some network attacks
    # including spoofing attacks and man in the middle attacks through
    # redirection. Some network environments, however, require that these
    # settings are disabled so review and enable them as needed.
    #
    # Ignore ICMP broadcasts
    #net/ipv4/icmp_echo_ignore_broadcasts = 1
    #
    # Ignore bogus ICMP errors
    #net/ipv4/icmp_ignore_bogus_error_responses = 1
    # 
    # Do not accept ICMP redirects (prevent MITM attacks)
    #net/ipv4/conf/all/accept_redirects = 0
    # _or_
    # Accept ICMP redirects only for gateways listed in our default
    # gateway list (enabled by default)
    # net/ipv4/conf/all/secure_redirects = 1
    #
    # Do not send ICMP redirects (we are not a router)
    #net/ipv4/conf/all/send_redirects = 0
    #
    # Do not accept IP source route packets (we are not a router)
    #net/ipv4/conf/all/accept_source_route = 0
    #
    # Log Martian Packets
    #net/ipv4/conf/all/log_martians = 1
    #
    # Always defragment packets
    #net/ipv4/ip_always_defrag = 1
    There is no property to enable/disable tcp_window_scaling. Where do I find this?

    And lastly, why does the pcfinancial.ca secure site require this to be disabled? Sorry for all the questions!
    (1) /proc/sys/net/ipv4 is a virtual directory, each file therein corresponds to a live configuration setting in the kernel. By reading (with cat) or writing (with echo >) those files you can change the kernel's behaviour on the fly.

    (2) So, su to root and then execute the command I gave above, exactly:

    echo 0 > /proc/sys/net/ipv4/tcp_window_scaling

    that will write 0 into the parameter and disable the window scaling option.

    (3) to make this permanent, you would add

    net.ipv4.tcp_window_scaling = 0

    into /etc/sysctl.conf

    (4) of course, there may be other ways of editing that file - this is the generic method.

    G.

  3. #23
    Join Date
    Oct 2008
    Beans
    3

    Re: Banking Site is very slow

    Quote Originally Posted by valyok View Post
    Hey, guys!

    I am ...guess what ...having the same problem you all got!

    I have been trying to communicate the problem to PC Financial "Tech Support" for more than a week now.
    So just 5 minutes ago I got off the phone with them and they said that they will forward the problem description to the actual tech support guys.
    One interesting thing is - they say not one person called with the same problem before.

    SO - why don't all of you guys call them and tell about the problem so that there's more than one person. I hope then they will take the request seriously.
    So I called 1-888-723-8881, then key in your card number, then choose options 5,1,3.

    Let me(us) know what their response is.
    Some people I talked to on the phone in the course of 7-10 days were absolutely dismissive of the problem...

    cheers
    Don't bother - I called them yesterday too - they told me there were aware of a similar issue with Mac OS.

    I also tried running IE under XP under VMware and got the same problem, so I concluded that this must be a conflict between the host OS TCP stack and the PCF server's TCP stack. I did some tcpdumps and noticed the window scaling option and tiny windows, so decided to try turning off window scaling, and it worked.

    Try disabling window scaling (see earlier posts) and see if that fixes your problem.

    G.

  4. #24
    Join Date
    Apr 2008
    Beans
    6

    Re: Banking Site is very slow

    I know.
    That's why when I spoke to a person like you describe - I just hang up and called again and spoke to a different person.

    Valera

    valyok,

    As mentioned in my previous post, I did call them but they don't want to hear anything but Windows!

    Liem

  5. #25
    Join Date
    Oct 2005
    Location
    Burlington, ON, Canada
    Beans
    104
    Distro
    Ubuntu 8.10 Intrepid Ibex

    Re: Banking Site is very slow

    This solved it for me:

    Code:
    sudo -s
    echo 0 > /proc/sys/net/ipv4/tcp_window_scaling
    Add this to bottom of /etc/sysctl.conf

    Code:
    # fix stupid pcfinancial site
    net.ipv4.tcp_window_scaling = 0
    Peter VK

  6. #26
    Join Date
    May 2005
    Location
    St.Catharines, Ontario
    Beans
    351
    Distro
    Ubuntu Development Release

    Re: Banking Site is very slow

    Just confirming the fix works for PC Banking!!!!!!!

    It has also sped up mybell.ca, which was very slow for a long time!!!

    Sign-up to Dropbox using the following link and get 2.25GB of storage FREE!!!
    https://www.dropbox.com/referrals/NTM2NDgxOTc5

  7. #27
    Join Date
    Apr 2008
    Beans
    6

    Re: Banking Site is very slow

    THNX a lot for the fix!
    I should have read the thread more carefully!

    V

  8. #28
    Join Date
    May 2008
    Location
    my(@HOME, -$NJ)
    Beans
    296
    Distro
    Ubuntu 14.04 Trusty Tahr

    Re: Banking Site is very slow

    Quote Originally Posted by valyok View Post
    Hey, guys!

    I am ...guess what ...having the same problem you all got!

    I have been trying to communicate the problem to PC Financial "Tech Support" for more than a week now.
    So just 5 minutes ago I got off the phone with them and they said that they will forward the problem description to the actual tech support guys.
    One interesting thing is - they say not one person called with the same problem before.

    SO - why don't all of you guys call them and tell about the problem so that there's more than one person. I hope then they will take the request seriously.
    So I called 1-888-723-8881, then key in your card number, then choose options 5,1,3.

    Let me(us) know what their response is.
    Some people I talked to on the phone in the course of 7-10 days were absolutely dismissive of the problem...

    cheers
    I am not a member but have wrote them an email regarding this and this was there reply:

    Thank you for taking the time to write President's Choice Financial.

    To access online banking, you need a browser with a minimum of 128-bit encryption. President's Choice Financial works with a 128-bit encrypted browser version of:

    Using Microsoft Windows

    - Microsoft Internet Explorer 5.5 or higher
    - Netscape Navigator 6.2 or higher

    Using Macintosh OS

    - Microsoft Internet Explorer 5.2.3
    - Apple Safari 1.0 or higher

    For tips on upgrading your browser, please visit http://www.banking.pcfinancial.ca/a/...ecure_browsers

    Thank you for visiting www.pcfinancial.ca.


    Sincerely,

    Curtis
    Internet Communications Specialist

    ---------------------------------------
    Note From President's Choice Financial services e-mail Postmaster: For reasons of security and confidentiality, some information in your original communication may have been altered. This information is marked by X's or .
    ---------------------------------------
    This information is confidential and for the exclusive use of the person to whom it is addressed. If you are not the intended recipient, please advise us by e-mail and destroy or return to us any copies. President's Choice Financial services are provided by the direct banking division of CIBC. CIBC accepts no liability for use by third parties or for errors or omissions.




    It appears that they don't support linux, or firefox. there web developer really sucks!
    TRACKING NUMBER: A00002790398-00008621257
    Last edited by alienprdkt; November 1st, 2008 at 11:44 PM.

  9. #29
    Join Date
    Jun 2007
    Beans
    31

    Re: Banking Site is very slow

    It works! I will mark it as SOLVED.

    Thanks for everyone's help!

  10. #30
    Join Date
    Nov 2008
    Beans
    1

    Re: [SOLVED] Banking Site is very slow

    ISSUE:
    When accessing https://www.txn.banking.pcfinancial....Box_banking_go

    The page comes up very slow. Once logged in response remains slow.

    ENVIRONMENT
    Ubuntu 8.04 and 8.10
    Firefox 3.0.3 (Investigation finds this to be a problem for version 2.x as well)

    CAUSE
    tcp_window_scaling is set to true (1)

    RESOLUTION
    echo 0 > /proc/sys/net/ipv4/tcp_window_scaling

    PROBLEM
    When you reboot the machine, you get the same problem.
    tcp_window_scaling goes back to 1

    WHAT I DID to fix the problem:

    Set echo 0 > /proc/sys/net/ipv4/tcp_window_scaling into rc.local

    #!/bin/sh -e
    #
    # rc.local
    #
    # This script is executed at the end of each multiuser runlevel.
    # Make sure that the script will "exit 0" on success or any other
    # value on error.
    #
    # In order to enable or disable this script just change the execution
    # bits.
    #
    # By default this script does nothing.
    echo 0 > /proc/sys/net/ipv4/tcp_window_scaling
    exit 0

    HOW to do this?
    Could use vi or pico

    EXAMPLE:
    sudo pico /etc/rc.local
    Enter password
    Make change
    Exit with save.

Page 3 of 9 FirstFirst 12345 ... LastLast

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •