Page 2 of 12 FirstFirst 1234 ... LastLast
Results 11 to 20 of 112

Thread: Gens/GS Milestone 5

  1. #11
    Join Date
    Oct 2008
    Beans
    75

    Re: Gens/GS Milestone 5

    Quote Originally Posted by Disreali View Post
    I would like to second nerdy_girlscout's request, yet understand that they may be difficult. I'm no coder either.

    Your version of Gens is AWESOME!! It does not flicker on my system and the menus are actually usable. I can also use OpenGL with this version. I thank and encourage you to continue your efforts. Thanks
    Thanks.

    Unfortunately, it doesn't seem like it's possible to use GTK+ menus in a fullscreen SDL application. However, I am planning on writing custom menus for an OSD interface later on.

  2. #12
    Join Date
    Oct 2008
    Beans
    1

    Question Re: Gens/GS Milestone 5

    Great Job.

    But how can i compile for amd64 on ubuntu intrepid.
    ./Configure quits with this errormessage:
    ***
    configure: error: 64-bit is currently not supported.
    ***
    Any Ideas what i did wrong?


    Greetings

  3. #13
    Join Date
    Jan 2008
    Beans
    346
    Distro
    Ubuntu 9.10 Karmic Koala

    Re: Gens/GS Milestone 5

    Quote Originally Posted by chris79 View Post
    Great Job.

    But how can i compile for amd64 on ubuntu intrepid.
    ./Configure quits with this errormessage:
    ***
    configure: error: 64-bit is currently not supported.
    ***
    Any Ideas what i did wrong?


    Greetings
    That's what's wrong.

  4. #14
    Join Date
    Oct 2008
    Beans
    75

    Re: Gens/GS Milestone 5

    Quote Originally Posted by chris79 View Post
    Great Job.

    But how can i compile for amd64 on ubuntu intrepid.
    ./Configure quits with this errormessage:
    ***
    configure: error: 64-bit is currently not supported.
    ***
    Any Ideas what i did wrong?


    Greetings
    Gens currently has a ton of 32-bit assumptions, such as storing pointers in integers and the use of x86 assembly code. Unfortunately, this makes it impossible to compile Gens as a 64-bit application. You should be able to use the 32-bit version if you have the appropriate 32-bit compatibility libraries installed.

  5. #15
    Join Date
    Mar 2007
    Beans
    11

    Re: Gens/GS Milestone 5

    Quote Originally Posted by GerbilSoft View Post
    Thanks.

    Unfortunately, it doesn't seem like it's possible to use GTK+ menus in a fullscreen SDL application. However, I am planning on writing custom menus for an OSD interface later on.
    I don't know if I've seen a complete interface in OSD before. I'll see how it turns out. :3

    About 64-bit, will it be supported when you've replaced enough asm code?

  6. #16
    Join Date
    Oct 2008
    Beans
    75

    Re: Gens/GS Milestone 5

    Quote Originally Posted by nerdy_girlscout View Post
    I don't know if I've seen a complete interface in OSD before. I'll see how it turns out. :3

    About 64-bit, will it be supported when you've replaced enough asm code?
    Yes, 64-bit will be supported once all the base asm code is replaced. (Starscream, the 68000 emulator, is going to be a pain - it's a C program that emits assembly.) I will retain the asm code for most of the renderers as a compile-time option though, so x86 users can take advantage of that. Other architectures will use C++ versions of said renderers. (On 64-bit, the C++ version might actually be faster than the 32-bit asm version because of larger registers.)

  7. #17
    Join Date
    Jul 2006
    Beans
    232
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: Gens/GS Milestone 5

    Sorry if I've missed something but my favourite game on the Megadrive does not work on Gens/GS - Super Street Fighter 2: The New Challengers. All I got was a red screen. I've had to revert to the rather inferior Gens 2.15.5 release in order to play it.

  8. #18
    Join Date
    Oct 2008
    Beans
    75

    Re: Gens/GS Milestone 5

    Quote Originally Posted by megamaced View Post
    Sorry if I've missed something but my favourite game on the Megadrive does not work on Gens/GS - Super Street Fighter 2: The New Challengers. All I got was a red screen. I've had to revert to the rather inferior Gens 2.15.5 release in order to play it.
    SSF2:TNC appears to have a custom checksum algorithm. I believe Gens/GS has "Auto Fix Checksum" enabled by default, which uses the standard Sega checksum algorithm; however, since SSF2:TNC doesn't use that algorithm, the game will detect an incorrect checksum and show the red screen.

    The solution is to disable "Auto Fix Checksum" in General Options.

  9. #19
    Join Date
    Oct 2008
    Beans
    75

    Re: Gens/GS Milestone 5

    Milestone 5.1 version bump, with a bunch of bugfixes!

  10. #20
    Join Date
    Sep 2006
    Beans
    548

    Re: Gens/GS Milestone 5

    I get lots of buzzing noises when trying to run 32X games with the latest version. I also get 2 bands of garbled graphics on the top and bottom of the screen when using OpenGL rendering.

    The last Linux version of Gens that has worked properly for me was 2.15.3 from the other thread on these forums. 2.15.5 must have introduced some OpenGL issues. The buzzing is another regression probably. I tried playing with my .asoundrc file and it doesn't help.

Page 2 of 12 FirstFirst 1234 ... LastLast

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •