Page 72 of 87 FirstFirst ... 2262707172737482 ... LastLast
Results 711 to 720 of 867

Thread: SiS 771/671 Mirage 3 Video Drivers

  1. #711
    Join Date
    Oct 2010
    Location
    Argentina
    Beans
    19
    Distro
    Ubuntu 11.04 Natty Narwhal

    Re: SiS 771/671 Mirage 3 Video Drivers!?!?

    Lol, thanks for the tip I forgot to do that! Much better now!

  2. #712
    Join Date
    Apr 2006
    Beans
    5

    Re: SiS 771/671 Mirage 3 Video Drivers!?!?

    I open a repository for sis671 driver here:

    https://launchpad.net/sis671n

    I would like to update and clean the code, based on Winischhofer sis671 driver, within the limits of my knowledge.

    The version stored on repository seems to work on xorg 7.6.

    Of course this is an experimental driver.

    Of course (2) I find people, mostly coders and testers.

    Finally excuse for my bad english

  3. #713
    Join Date
    Sep 2007
    Location
    /dev/null/
    Beans
    5
    Distro
    Ubuntu 10.10 Maverick Meerkat

    Re: SiS 771/671 Mirage 3 Video Drivers!?!?

    Quote Originally Posted by homer87 View Post
    I open a repository for sis671 driver here:

    https://launchpad.net/sis671n

    I would like to update and clean the code, based on Winischhofer sis671 driver, within the limits of my knowledge.

    The version stored on repository seems to work on xorg 7.6.

    Of course this is an experimental driver.

    Of course (2) I find people, mostly coders and testers.

    Finally excuse for my bad english
    will be 3d?

  4. #714
    Join Date
    Apr 2006
    Beans
    5

    Re: SiS 771/671 Mirage 3 Video Drivers!?!?

    Nope. I don't think.

    I write this simple FAQ:

    https://answers.launchpad.net/sis671n/+faq/1606

  5. #715
    Join Date
    May 2011
    Beans
    1

    Re: SiS 771/671 Mirage 3 Video Drivers!?!?

    homer87, does your driver support 2d video acceleration at the moment? Till ubuntu natty all the drivers used to support XV acceleration but the driver for natty posted on the ajoliveira's site doesn't...

  6. #716
    Join Date
    Apr 2006
    Beans
    5

    Re: SiS 771/671 Mirage 3 Video Drivers!?!?

    The codebase is the same as ajoliveira's; the Winischhofer has support for XV but is very ugly, incomplete and unstable.

    The code on repository has small changes, that make the driver a bit more stable.
    Last edited by homer87; May 19th, 2011 at 09:34 PM.

  7. #717
    Join Date
    Oct 2010
    Beans
    90
    Distro
    Kubuntu 10.10 Maverick Meerkat

    Re: SiS 771/671 Mirage 3 Video Drivers!?!?

    3D Support will never be available IMHO, Anyway it's nice you setup a Bazaar repo ^^, also you can take a look a patch from Timo for the driver.
    My Blog,

    Life is hard already, don't make it more complicated

  8. #718
    Join Date
    Apr 2006
    Beans
    5

    Re: SiS 771/671 Mirage 3 Video Drivers!?!?

    Quote Originally Posted by hellnest View Post
    3D Support will never be available IMHO, Anyway it's nice you setup a Bazaar repo ^^, also you can take a look a patch from Timo for the driver.
    I think the same thing, where is the Timo's patch?

  9. #719
    Join Date
    Oct 2010
    Beans
    90
    Distro
    Kubuntu 10.10 Maverick Meerkat

    Re: SiS 771/671 Mirage 3 Video Drivers!?!?

    Quote Originally Posted by homer87 View Post
    I think the same thing, where is the Timo's patch?
    Sorry for the late reply, you can grab the tarball from here. https://github.com/hellnest/xf86-vid...all/timo-patch
    My Blog,

    Life is hard already, don't make it more complicated

  10. #720
    Join Date
    Apr 2011
    Beans
    9

    Talking Re: SiS 771/671 Mirage 3 Video Drivers!?!?

    Well, hi again . I started with 10.10 using Gnome. And as I "found" a "3d" driver wich seemed to work better than sisimedia, I switched to Kubuntu 10.04. Used this guide (wich is in portuguese, but as I'm native spanish I can understand some words). Oh, and btw Barros Lee has a "download center" here.

    Same procedure, download driver. Then copying it to the drivers folder and modified the xorg.conf file.

    @xorg.conf:
    Driver "sis671" (I dont remember wich driver is it, but i downloaded it from Barros Lee because the links on the BR guide are dead)

    My xorg.conf complete.
    Code:
    Section "Module"
         Disable "dri"
         Load "dbe" # Double-Buffering Extension
         Load "v4l" # Video for Linux
         Load "extmod"
         Load "glx" # 3D layer
         Load "GLcore" 
     EndSection
     
    
     Section "Monitor"
         Identifier "monitor1"
         VendorName "Generic"
         ModelName "Flat Panel 1280x800"
         HorizSync 28.8-90
         VertRefresh 60
          
        # Monitor preferred modeline (60.0 Hz vsync, 49.0 kHz hsync, ratio 16/10, 106 dpi)
         ModeLine "1280x800" 68.94 1280 1301 1333 1408 800 803 808 816 -hsync -vsync
          
         # TV fullscreen mode or DVD fullscreen output.
         # 768x576 @ 79 Hz, 50 kHz hsync
         ModeLine "768x576"     50.00  768  832  846 1000   576  590  595  630
          
         # 768x576 @ 100 Hz, 61.6 kHz hsync
         ModeLine "768x576"     63.07  768  800  960 1024   576  578  590  616
          
         # modeline generated by gtf(1) [handled by XFdrake]
         ModeLine "1280x800_120"  181.21  1280 1376 1520 1760  800 801 804 858  -HSync +Vsync
          
         # modeline generated by gtf(1) [handled by XFdrake]
         ModeLine "1280x800_100"  147.89  1280 1376 1512 1744  800 801 804 848  -HSync +Vsync
          
         # modeline generated by gtf(1) [handled by XFdrake]
         ModeLine "1280x800_85"  123.38  1280 1368 1504 1728  800 801 804 840  -HSync +Vsync
          
         # modeline generated by gtf(1) [handled by XFdrake]
         ModeLine "1280x800_75"  107.21  1280 1360 1496 1712  800 801 804 835  -HSync +Vsync
          
         # modeline generated by gtf(1) [handled by XFdrake]
         ModeLine "1280x800_60"  83.46  1280 1344 1480 1680  800 801 804 828  -HSync +Vsync
          
         # modeline generated by gtf(1) [handled by XFdrake]
         ModeLine "1280x800_50"  68.56  1280 1336 1472 1664  800 801 804 824  -HSync +Vsync
     EndSection
     
    
     Section "Screen"
         Identifier "screen1"
         Device "device1"
         Monitor "monitor1"
         DefaultColorDepth 24
          
         Subsection "Display"
             Depth 8
             Modes "1280x800"
         EndSubsection
          
         Subsection "Display"
             Depth 15
             Modes "1280x800"
         EndSubsection
          
         Subsection "Display"
             Depth 16
             Modes "1280x800"
         EndSubsection
          
         Subsection "Display"
             Depth 24
             Modes "1280x800"
         EndSubsection
     EndSection
     
    
     Section "ServerLayout"
         Identifier "layout1"
         Screen "screen1"
     EndSection
     
    
     Section "Device"
         Identifier   "Configured Video Device"
         Driver "sis671"
         Option "DPMS"
         Option "XvDefaultAdaptor"      "Blitter"
         Option "EnableSiSCtrl" "yes"
     EndSection
     
    
     Section "DRI"
             Mode 0666
     EndSection
    .

    I dont really know what those lines are or work for. But my Kubuntu is running smoothly, still no 3d acceleration.
    I hope this works for other folks in the same disgrace as me .
    There's a driver programmed by Barros Lee wich seems to work for ubuntu 7.10. I've got an iso but can't install it. I'll post my results ASAP.

Page 72 of 87 FirstFirst ... 2262707172737482 ... LastLast

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •