Quote Originally Posted by ajoliveira View Post
I just put step-by-step installation sis driver instructions and an experimental install script on my page, hope it will help.
Hello i'm trying to do your way and i thinks i'm gonna make it if i make a right configuration. Can you help me? My native monitor is 1366x768

This is my xorg.log when i'm using your configuration.... Waiting forward to hear from you

Code:
X.Org X Server 1.7.6
Release Date: 2010-03-17
X Protocol Version 11, Revision 0
Build Operating System: Linux 2.6.24-25-server i686 Ubuntu
Current Operating System: Linux BlackBird 2.6.32-21-generic #32-Ubuntu SMP Fri Apr 16 08:10:02 UTC 2010 i686
Kernel command line: BOOT_IMAGE=/boot/vmlinuz-2.6.32-21-generic root=UUID=de1f54d0-5359-4f74-adcf-b18e71fd3f99 ro quiet splash
Build Date: 23 April 2010  05:11:50PM
xorg-server 2:1.7.6-2ubuntu7 (Bryce Harrington <bryce@ubuntu.com>) 
Current version of pixman: 0.16.4
	Before reporting problems, check http://wiki.x.org
	to make sure that you have the latest version.
Markers: (--) probed, (**) from config file, (==) default setting,
	(++) from command line, (!!) notice, (II) informational,
	(WW) warning, (EE) error, (NI) not implemented, (??) unknown.
(==) Log file: "/var/log/Xorg.0.log", Time: Sat Oct 16 01:36:55 2010
(==) Using config file: "/etc/X11/xorg.conf"
(==) Using config directory: "/usr/lib/X11/xorg.conf.d"
(==) No Layout section.  Using the first Screen section.
(**) |-->Screen "Default Screen" (0)
(**) |   |-->Monitor "Configured Monitor"
(**) |   |-->Device "Configured Video Device"
(==) Automatically adding devices
(==) Automatically enabling devices
(WW) The directory "/usr/share/fonts/X11/cyrillic" does not exist.
	Entry deleted from font path.
(==) FontPath set to:
	/usr/share/fonts/X11/misc,
	/usr/share/fonts/X11/100dpi/:unscaled,
	/usr/share/fonts/X11/75dpi/:unscaled,
	/usr/share/fonts/X11/Type1,
	/usr/share/fonts/X11/100dpi,
	/usr/share/fonts/X11/75dpi,
	/var/lib/defoma/x-ttcidfont-conf.d/dirs/TrueType,
	built-ins
(==) ModulePath set to "/usr/lib/xorg/extra-modules,/usr/lib/xorg/modules"
(II) The server relies on udev to provide the list of input devices.
	If no devices become available, reconfigure udev or disable AutoAddDevices.
(II) Loader magic: 0x81f0e80
(II) Module ABI versions:
	X.Org ANSI C Emulation: 0.4
	X.Org Video Driver: 6.0
	X.Org XInput driver : 7.0
	X.Org Server Extension : 2.0
(++) using VT number 7

(--) PCI:*(0:1:0:0) 1039:6351:1558:0804 Silicon Integrated Systems [SiS] 771/671 PCIE VGA Display Adapter rev 16, Mem @ 0xc0000000/268435456, 0xd8000000/131072, I/O @ 0x00009000/128
(WW) Open ACPI failed (/var/run/acpid.socket) (No such file or directory)
(II) LoadModule: "extmod"
(II) Loading /usr/lib/xorg/modules/extensions/libextmod.so
(II) Module extmod: vendor="X.Org Foundation"
	compiled for 1.7.6, module version = 1.0.0
	Module class: X.Org Server Extension
	ABI class: X.Org Server Extension, version 2.0
(II) Loading extension MIT-SCREEN-SAVER
(II) Loading extension XFree86-VidModeExtension
(II) Loading extension XFree86-DGA
(II) Loading extension DPMS
(II) Loading extension XVideo
(II) Loading extension XVideo-MotionCompensation
(II) Loading extension X-Resource
(II) LoadModule: "dbe"
(II) Loading /usr/lib/xorg/modules/extensions/libdbe.so
(II) Module dbe: vendor="X.Org Foundation"
	compiled for 1.7.6, module version = 1.0.0
	Module class: X.Org Server Extension
	ABI class: X.Org Server Extension, version 2.0
(II) Loading extension DOUBLE-BUFFER
(II) LoadModule: "glx"
(II) Loading /usr/lib/xorg/modules/extensions/libglx.so
(II) Module glx: vendor="X.Org Foundation"
	compiled for 1.7.6, module version = 1.0.0
	ABI class: X.Org Server Extension, version 2.0
(==) AIGLX enabled
(II) Loading extension GLX
(II) LoadModule: "record"
(II) Loading /usr/lib/xorg/modules/extensions/librecord.so
(II) Module record: vendor="X.Org Foundation"
	compiled for 1.7.6, module version = 1.13.0
	Module class: X.Org Server Extension
	ABI class: X.Org Server Extension, version 2.0
(II) Loading extension RECORD
(II) LoadModule: "dri"
(II) Loading /usr/lib/xorg/modules/extensions/libdri.so
(II) Module dri: vendor="X.Org Foundation"
	compiled for 1.7.6, module version = 1.0.0
	ABI class: X.Org Server Extension, version 2.0
(II) Loading extension XFree86-DRI
(II) LoadModule: "dri2"
(II) Loading /usr/lib/xorg/modules/extensions/libdri2.so
(II) Module dri2: vendor="X.Org Foundation"
	compiled for 1.7.6, module version = 1.1.0
	ABI class: X.Org Server Extension, version 2.0
(II) Loading extension DRI2
(II) LoadModule: "sis671"
(II) Loading /usr/lib/xorg/modules/drivers/sis671_drv.so
(II) Module sis671: vendor="X.Org Foundation"
	compiled for 1.7.6, module version = 0.8.0
	Module class: X.Org Video Driver
	ABI class: X.Org Video Driver, version 6.0
(II) SIS: driver for SiS chipsets: SIS5597/5598, SIS530/620,
	SIS6326/AGP/DVD, SIS300/305, SIS630/730, SIS540, SIS315, SIS315H,
	SIS315PRO/E, SIS550, SIS650/M650/651/740, SIS330(Xabre),
	SIS[M]661[F|M]X/[M]741[GX]/[M]760[GX]/[M]761[GX]/662, SIS340,
	[M]670/[M]770[GX], [M]671/[M]771[GX]
(II) SIS: driver for XGI chipsets: Volari Z7 (XG20),
	Volari V3XT/V5/V8/Duo (XG40/XG42)
(II) Primary Device is: PCI 01@00:00:0
(WW) Falling back to old probe method for sis671
(--) Assigning device section with no busID to primary device
(--) Chipset [M]671/[M]771[GX] found
(II) SIS(0): SiS driver (2006/10/17-1, compiled for X.org 1.7.6.0)
(II) SIS(0): Copyright (C) 2001-2005 Thomas Winischhofer <thomas@winischhofer.net> and others
(II) SIS(0): *** See http://www.winischhofer.at/linuxsisvga.shtml
(II) SIS(0): *** for documentation, updates and a Premium Version.
(II) SIS(0): RandR rotation support not available in this version.
(II) SIS(0): Dynamic modelist support not available in this version.
(II) SIS(0): Screen growing support not available in this version.
(II) SIS(0): Advanced Xv video blitter not available in this version.
(II) SIS(0): Advanced MergedFB support not available in this version.
(--) SIS(0): sisfb not found
(--) SIS(0): Relocated I/O registers at 0x9000
(II) Loading sub module "ramdac"
(II) LoadModule: "ramdac"
(II) Module "ramdac" already built-in
(II) SIS(0): Creating default Display subsection in Screen section
	"Default Screen" for depth/fbbpp 24/32
(**) SIS(0): Depth 24, (--) framebuffer bpp 32
(==) SIS(0): RGB weight 888
(==) SIS(0): Default visual is TrueColor
(WW) SIS(0): Could not find/read video BIOS
(==) SIS(0): Color HW cursor is enabled
(II) SIS(0): Using VRAM command queue, size 512k
(==) SIS(0): Hotkey display switching is enabled
(==) SIS(0): SiSCtrl utility interface is disabled
(II) SIS(0): For information on SiSCtrl, see
		http://www.winischhofer.at/linuxsispart1.shtml#sisctrl
(==) SIS(0): X server will not keep DPI constant for all screen sizes
(==) SIS(0): DRI enabled
(II) SIS(0): Checking OS for SSE support is not supported in this version of X.org
(II) SIS(0): If your OS supports SSE, set the option "UseSSE" to "on".
(--) SIS(0): 262144K shared video RAM (UMA)
(--) SIS(0): DRAM type: DDR SDRAM
(--) SIS(0): Memory clock: 596.582 MHz
(--) SIS(0): DRAM bus width: 64 bit
(--) SIS(0): Linear framebuffer at 0xC0000000
(--) SIS(0): MMIO registers at 0xD8000000 (size 64K)
(--) SIS(0): VideoRAM: 262144 KB
(II) SIS(0): Using 20480K of framebuffer memory at offset 0K
(II) Loading sub module "ddc"
(II) LoadModule: "ddc"
(II) Module "ddc" already built-in
(--) SIS(0): Detected SiS307LV video bridge (Charter/UMC-1, ID 7; Rev 0xe1)
(--) SIS(0): No CRT1/VGA detected
(--) SIS(0): Detected LCD/Plasma panel (max. X 0 Y 0, pref. 0x0, RGB24)
(==) SIS(0): Using gamma correction (1.0, 1.0, 1.0)
(II) SIS(0): CRT1 gamma correction is enabled
(II) SIS(0): Separate Xv gamma correction for CRT1 is disabled
(II) SIS(0): CRT2 gamma correction is enabled
(--) SIS(0): Memory bandwidth at 32 bpp is 1193.16 MHz
(--) SIS(0): Detected LCD PanelDelayCompensation 0x00 (for LCD=CRT2)
(--) SIS(0): Detected LCD PanelDelayCompensation 0x00 (for LCD=CRT1)
(--) SIS(0): 302LV/302ELV: Using EMI 0x0a0d7038 (LCD)
(--) SIS(0): CRT2 DDC probing failed
(==) SIS(0): Min pixel clock is 10 MHz
(--) SIS(0): Max pixel clock is 340 MHz
(II) SIS(0): Replaced entire mode list with built-in modes
(II) SIS(0): Correcting bogus CRT2 monitor HSync range
(II) SIS(0): Correcting bogus CRT2 monitor VRefresh range
(II) SIS(0): "Unknown reason" in the following list means that the mode
(II) SIS(0): is not supported on the chipset/bridge/current output device.
(II) SIS(0): Configured Monitor: Using hsync range of 30.00-80.00 kHz
(II) SIS(0): Configured Monitor: Using vrefresh range of 59.00-61.00 Hz
(II) SIS(0): Configured Monitor: Using vrefresh value of 71.00 Hz
(WW) SIS(0): Unable to estimate virtual size
(II) SIS(0): Clock range:  10.00 to 340.00 MHz
(II) SIS(0): Not using default mode "800x600" (unknown reason)
(II) SIS(0): Not using default mode "800x600" (unknown reason)
(II) SIS(0): Not using default mode "800x600" (unknown reason)
(II) SIS(0): Not using default mode "800x600" (unknown reason)
(II) SIS(0): Not using default mode "800x600" (unknown reason)
(II) SIS(0): Not using default mode "800x600" (unknown reason)
(II) SIS(0): Not using default mode "800x600" (unknown reason)
(II) SIS(0): Not using default mode "800x600" (unknown reason)
(II) SIS(0): Not using default mode "640x480" (unknown reason)
(II) SIS(0): Not using default mode "640x480" (unknown reason)
(II) SIS(0): Not using default mode "640x480" (unknown reason)
(II) SIS(0): Not using default mode "640x480" (unknown reason)
(II) SIS(0): Not using default mode "640x480" (unknown reason)
(II) SIS(0): Not using default mode "640x480" (unknown reason)
(II) SIS(0): Not using default mode "640x480" (unknown reason)
(II) SIS(0): Not using default mode "640x480" (unknown reason)
(II) SIS(0): Not using default mode "1024x768" (unknown reason)
(II) SIS(0): Not using default mode "1024x768" (unknown reason)
(II) SIS(0): Not using default mode "1024x768" (unknown reason)
(II) SIS(0): Not using default mode "1024x768" (unknown reason)
(II) SIS(0): Not using default mode "1024x768" (unknown reason)
(II) SIS(0): Not using default mode "1024x768" (unknown reason)
(II) SIS(0): Not using default mode "1024x768" (unknown reason)
(II) SIS(0): Not using default mode "1280x1024" (unknown reason)
(II) SIS(0): Not using default mode "1280x1024" (unknown reason)
(II) SIS(0): Not using default mode "1280x1024" (unknown reason)
(II) SIS(0): Not using default mode "1280x1024" (unknown reason)
(II) SIS(0): Not using default mode "1600x1200" (unknown reason)
(II) SIS(0): Not using default mode "1600x1200" (unknown reason)
(II) SIS(0): Not using default mode "1600x1200" (unknown reason)
(II) SIS(0): Not using default mode "1600x1200" (unknown reason)
(II) SIS(0): Not using default mode "1600x1200" (unknown reason)
(II) SIS(0): Not using default mode "1600x1200" (unknown reason)
(II) SIS(0): Not using default mode "1600x1200" (unknown reason)
(II) SIS(0): Not using default mode "1920x1440" (unknown reason)
(II) SIS(0): Not using default mode "1920x1440" (unknown reason)
(II) SIS(0): Not using default mode "1920x1440" (unknown reason)
(II) SIS(0): Not using default mode "1920x1440" (unknown reason)
(II) SIS(0): Not using default mode "1920x1440" (unknown reason)
(II) SIS(0): Not using default mode "1920x1440" (bad mode clock/interlace/doublescan)
(II) SIS(0): Not using default mode "2048x1536" (unknown reason)
(II) SIS(0): Not using default mode "2048x1536" (unknown reason)
(II) SIS(0): Not using default mode "2048x1536" (unknown reason)
(II) SIS(0): Not using default mode "2048x1536" (bad mode clock/interlace/doublescan)
(II) SIS(0): Not using default mode "2048x1536" (bad mode clock/interlace/doublescan)
(II) SIS(0): Not using default mode "1280x800" (unknown reason)
(II) SIS(0): Not using default mode "1280x800" (unknown reason)
(II) SIS(0): Not using default mode "1280x800" (unknown reason)
(WW) SIS(0): Mode pool is empty
(EE) SIS(0): **************************************************
(EE) SIS(0):                       ERROR:
(EE) SIS(0): No valid modes found - check VertRefresh/HorizSync
(EE) SIS(0):                   END OF MESSAGE
(EE) SIS(0): **************************************************
(II) UnloadModule: "sis671"
(EE) Screen(s) found, but none have a usable configuration.

Fatal server error:
no screens found

Please consult the The X.Org Foundation support 
	 at http://wiki.x.org
 for help. 
Please also check the log file at "/var/log/Xorg.0.log" for additional information.

 ddxSigGiveUp: Closing log