Results 1 to 5 of 5

Thread: keyboard,mouse not working after booting into custom kernel

  1. #1
    Join Date
    Jun 2007
    Location
    India
    Beans
    26
    Distro
    Ubuntu 7.10 Gutsy Gibbon

    keyboard,mouse not working after booting into custom kernel

    Hi All,

    I am using intrepid for last couple of weeks. I wanted to have a custom kernel with debug options enabled. So I compiled 2.6.27.1 and I successfully installed it.

    But when I reboot I am not able to use keyboard and mouse to login to gnome session via GDM. But I am able to login through command line (ALT + F2).

    Searched throught forums.Couldn't find any appropriate reply.Has anyone faced the same problem. Any suggestions?

    -Karthik.
    KARTHIK G BALAJI

  2. #2
    Join Date
    Jun 2007
    Location
    India
    Beans
    26
    Distro
    Ubuntu 7.10 Gutsy Gibbon

    Re: keyboard,mouse not working after booting into custom kernel

    Have I posted it in the right place? If I am wrong please tell me..I ll post my question the appropriate forum.

    Thanks,
    Karthik
    KARTHIK G BALAJI

  3. #3
    Join Date
    Oct 2008
    Beans
    7

    Re: keyboard,mouse not working after booting into custom kernel

    Hi Karthik,

    I might be having the same issue. I am using a custom kernel (2.6.27.2) and although I can login gdm, there are some things that just aren't working with my mouse now. I can't get the Firefox pulldown menus to work with the mouse (they do work with ALT-f though). I use Xfce4 and the Xfce4 main menu button doesn't work with the mouse either. I suggest we both try to revert back to some previous kernels to see if the issue is tied to the newer custom kernels we're running.

    Cheers,
    Perdignus.

  4. #4
    Join Date
    Oct 2008
    Beans
    7

    Re: keyboard,mouse not working after booting into custom kernel

    Hi again Karthik,

    I tried a number of my older kernels (2.6.27-rc7-git5, 2.6.26.1 and 2.6.25.17) and the issue existed in those too. I didn't try any of the Ubuntu stock kernels which might be worth checking.

    Here's the details for my PC, maybe there's a similarity here:

    Motherboard:
    GIGABYTE GA-X48-DS4 LGA 775 Intel X48 ATX Intel

    CPU:
    Intel Core 2 Quad Q9300 Yorkfield 2.5GHz 6MB L2 Cache LGA 775 95W

    Video Card:
    GIGABYTE GV-NX88T512HPV1 GeForce 8800 GT 512MB 256-bit GDDR3

    I'm using the nVidia driver 177.80 but also tried 177.78 without any luck. I have two monitors running in X.

    Maybe this is a new bug with Xorg or something else. Let me know if you get anywhere or have any new insight please.

    Thanks,
    Perdignus.

  5. #5
    Join Date
    Oct 2008
    Beans
    7

    Re: keyboard,mouse not working after booting into custom kernel

    Hello again,

    I was able to resolve the problem by editing my xorg.conf file. The mouse section was rewritten when I created a new xorg.conf file with "xorg -configure".

    The problem is detailed here:
    http://ubuntuforums.org/showthread.php?t=783467

    Hope this helps you too.

    Cheers,
    Perdignus.

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •