Page 1 of 4 123 ... LastLast
Results 1 to 10 of 36

Thread: [SOLVED] Still no wireless

  1. #1
    Join Date
    Sep 2008
    Beans
    93

    [SOLVED] Still no wireless

    I have now been trying for a month to get wireless working on my laptop with 8.04. when I type in lshw - C network i get this result

    WARNING: you should run this program as super-user.
    *-network:0
    description: Network controller
    product: BCM4306 802.11b/g Wireless LAN Controller
    vendor: Broadcom Corporation
    physical id: c
    bus info: pci@0000:00:0c.0
    version: 03
    width: 32 bits
    clock: 33MHz
    capabilities: bus_master
    configuration: driver=b43-pci-bridge latency=64 module=ssb
    *-network:1
    description: Ethernet interface
    product: VT6102 [Rhine-II]
    vendor: VIA Technologies, Inc.
    physical id: 12
    bus info: pci@0000:00:12.0
    logical name: eth0
    version: 74
    serial: 00:03:25:10:80:44
    width: 32 bits
    clock: 33MHz
    capabilities: bus_master cap_list ethernet physical
    configuration: broadcast=yes driver=via-rhine driverversion=1.4.3 ip=192.168.0.3 latency=64 maxlatency=8 mingnt=3 module=via_rhine multicast=yes
    *-network DISABLED
    description: Wireless interface
    physical id: 2
    logical name: wlan0
    serial: 00:90:4b:7c:4d:e7
    capabilities: ethernet physical wireless
    configuration: broadcast=yes multicast=yes wireless=IEEE 802.11g

    What can I do to fix this. I just can't seem to enable the wireless card?

    Please help me

  2. #2
    Join Date
    Feb 2008
    Location
    Funky Town, AUS
    Beans
    Hidden!
    Distro
    Xubuntu

    Re: Still no wireless

    If you can connect via a cable, download through Synaptics:

    ubuntu-restricted-extras

    Open a terminal and paste in:

    sudo nano /etc/modprobe.d/blacklist

    and look for this section:

    Code:
    # replaced by b43 and ssb.
    blacklist bcm43xx
    Make sure it look like that. Go to:

    System->Administration->Hardware Drivers

    ... and make sure the Broadcom B43 Driver is ticked and in use. If you have been playing around with ndiswrapper, you need to either uninstall it or blacklist it also.
    Last edited by Bucky Ball; October 19th, 2008 at 12:42 PM.

  3. #3
    Join Date
    Sep 2008
    Beans
    93

    Re: Still no wireless

    lspci gives me this result for my wireless card

    Network controller: Broadcom Corporation BCM4306 802.11b/g Wireless LAN Controller (rev 03)

  4. #4
    Join Date
    Feb 2008
    Location
    Funky Town, AUS
    Beans
    Hidden!
    Distro
    Xubuntu

  5. #5
    Join Date
    Jan 2007
    Beans
    5,549

  6. #6
    Join Date
    Feb 2008
    Location
    Funky Town, AUS
    Beans
    Hidden!
    Distro
    Xubuntu

    Re: Still no wireless

    Quote Originally Posted by superprash2003 View Post
    ndiswrapper is not longer required for this card anymore I didn't think.

  7. #7
    Join Date
    Sep 2008
    Beans
    93

    Re: Still no wireless

    the text was correct and i have uninstalled ndiswrapper. I also enabled and installed b43 cutter, which then downloaded the firmware. do i need to reboot for this to take effect?

  8. #8
    Join Date
    Sep 2008
    Beans
    93

    Re: Still no wireless

    i am trying to use wifi radar so i type sudo wifi-radar into terminal and it says

    dhclient3 --version 2>&1
    wlan0 Interface doesn't support scanning : Network is down

    the bottom line is repeated again and again and again

  9. #9
    Join Date
    Feb 2008
    Location
    Funky Town, AUS
    Beans
    Hidden!
    Distro
    Xubuntu

    Re: Still no wireless

    Is the wireless light on?

    Enter:

    ifup

    ... to bring the card up, then:

    sudo dhclient -r

    That releases your dhcp address. Then

    sudo dhclient

    That renews it again.

    sudo iwlist wlan0 scan

    Scan for networks

  10. #10
    Join Date
    Sep 2008
    Beans
    93

    Re: Still no wireless

    evan@durruti:~$ ifup
    ifup: Use --help for help
    evan@durruti:~$ sudo dhclient -r
    [sudo] password for evan:
    Internet Systems Consortium DHCP Client V3.0.6
    Copyright 2004-2007 Internet Systems Consortium.
    All rights reserved.
    For info, please visit http://www.isc.org/sw/dhcp/

    wmaster0: unknown hardware address type 801
    wmaster0: unknown hardware address type 801
    Listening on LPF/wlan0/00:90:4b:7c:4d:e7
    Sending on LPF/wlan0/00:90:4b:7c:4d:e7
    Listening on LPF/wmaster0/
    Sending on LPF/wmaster0/
    Listening on LPF/eth0/00:03:25:10:80:44
    Sending on LPF/eth0/00:03:25:10:80:44
    Sending on Socket/fallback
    DHCPRELEASE on eth0 to 192.168.0.1 port 67
    evan@durruti:~$ sudo dhclient
    There is already a pid file /var/run/dhclient.pid with pid 0
    Internet Systems Consortium DHCP Client V3.0.6
    Copyright 2004-2007 Internet Systems Consortium.
    All rights reserved.
    For info, please visit http://www.isc.org/sw/dhcp/

    wmaster0: unknown hardware address type 801
    wmaster0: unknown hardware address type 801
    Listening on LPF/wlan0/00:90:4b:7c:4d:e7
    Sending on LPF/wlan0/00:90:4b:7c:4d:e7
    Listening on LPF/wmaster0/
    Sending on LPF/wmaster0/
    Listening on LPF/eth0/00:03:25:10:80:44
    Sending on LPF/eth0/00:03:25:10:80:44
    Sending on Socket/fallback
    DHCPDISCOVER on eth0 to 255.255.255.255 port 67 interval 7
    DHCPOFFER of 192.168.0.2 from 192.168.0.1
    DHCPREQUEST of 192.168.0.2 on eth0 to 255.255.255.255 port 67
    DHCPACK of 192.168.0.2 from 192.168.0.1
    bound to 192.168.0.2 -- renewal in 42513 seconds.
    evan@durruti:~$ sudo iwlist wlan0 scan
    wlan0 No scan results

Page 1 of 4 123 ... LastLast

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •