Page 1 of 2 12 LastLast
Results 1 to 10 of 17

Thread: VMware Server 2 error - Web service not available

  1. #1
    Join Date
    Sep 2006
    Beans
    Hidden!

    Exclamation VMware Server 2 error - Web service not available

    Hi Guys,
    When I'm logging into VMware Server 2 web interface on Hardy I get "Web service not available."

    I have got IPv6 disabled:

    /etc/modprobe.d/aliases
    Code:
    alias net-pf-10 off

    /etc/hosts -
    Code:
    # The following lines are desirable for IPv6 capable hosts
    #::1     ip6-localhost ip6-loopback
    #fe00::0 ip6-localnet
    #ff00::0 ip6-mcastprefix
    #ff02::1 ip6-allnodes
    #ff02::2 ip6-allrouters
    #ff02::3 ip6-allhosts

    When I run "sudo /etc/init.d/vmware restart" I get:
    Code:
    Starting VMware services:
       Virtual machine monitor                                            done
       Virtual machine communication interface                            done
       VM communication interface socket family:                          done
       Virtual ethernet                                                   done
       Bridged networking on /dev/vmnet0                                  done
       Host-only networking on /dev/vmnet1 (background)                   done
       DHCP server on /dev/vmnet1                                         done
       Host-only networking on /dev/vmnet8 (background)                   done
       DHCP server on /dev/vmnet8                                         done
       NAT service on /dev/vmnet8                                         done
       VMware Server Authentication Daemon (background)                   done
       Shared Memory Available                                            done
    Starting VMware management services:
       VMware Server Host Agent (background)                              done
       VMware Virtual Infrastructure Web Access
    Starting VMware autostart virtual machines:
       Virtual machines                                                   done
    Can anyone give me a hand with this one?

    Cheers,
    Zeb

  2. #2
    Join Date
    Sep 2006
    Beans
    Hidden!

    Re: VMware Server 2 error - Web service not available

    Bump

  3. #3
    Join Date
    Apr 2008
    Beans
    2

    Re: VMware Server 2 error - Web service not available

    I get the same error and haven't worked out what to do about it yet.

  4. #4
    Join Date
    Sep 2006
    Beans
    Hidden!

    Re: VMware Server 2 error - Web service not available

    Anyone else come across this issue and resolved it?

  5. #5
    Join Date
    Oct 2008
    Beans
    8
    Distro
    Ubuntu 7.10 Gutsy Gibbon

    Re: VMware Server 2 error - Web service not available

    VMware Virtual Infrastructure Web Access doesn't seem to have started up, I had a similar problem and used

    /etc/rc.d/init.d/vmware-mgmt restart

    and all worked fine

  6. #6
    Join Date
    Mar 2006
    Location
    Kitakyushu Japan
    Beans
    9,361
    Distro
    Ubuntu 11.04 Natty Narwhal

    Re: VMware Server 2 error - Web service not available

    Same problem here.

    Quote Originally Posted by colinlr View Post
    VMware Virtual Infrastructure Web Access doesn't seem to have started up, I had a similar problem and used

    /etc/rc.d/init.d/vmware-mgmt restart

    and all worked fine
    For Ubuntu, the command is /etc/init.d/vmware-mgmt restart

    However, even that did not fix this issue for me. I am still unable to access the web interface either locally or remotely.

  7. #7
    Join Date
    Mar 2008
    Location
    Switzerland
    Beans
    2
    Distro
    Ubuntu 8.04 Hardy Heron

    Re: VMware Server 2 error - Web service not available

    Hi, I've the same problem.

    On my Core 2 Duo the VMWare 2.0.0 Build 116487 works correctly, on the old Pentium 4 I receive the "Web service not available" error.

    I've installed the Ubuntu Hardy (last patches) on both machines.

    I've tried disabling the IPv6 on the Pentium but I've the same error. Note that on the Core 2 Duo the IPv6 is activated!

    On the hostd.log I have this error:
    [2008-10-29 17:03:10.334 'Proxysvc' 3074156880 warning] SSL Handshake on client connection failed: SSL Exception:
    [2008-10-29 17:03:42.846 'Proxysvc Req00011' 3074156880 warning] PendingServerStrm: client write-completion error: SSL Exception: error:00000001:lib(0):func(0):reason(1)

    But I don't known if this error and the "Web access not available" are related.

  8. #8
    Join Date
    Oct 2008
    Beans
    1

    Re: VMware Server 2 error - Web service not available


  9. #9
    Join Date
    Mar 2008
    Location
    Switzerland
    Beans
    2
    Distro
    Ubuntu 8.04 Hardy Heron

    Re: VMware Server 2 error - Web service not available

    Quote Originally Posted by ask4jm View Post
    I don't know what have made the others but I've tried to connect with 127.0.0.1, localhost and the machine name and I've tried also with the LAN address but the answer was the same (on the Core 2 Duo all works).

    Now I've downgraded the version to the 1.0.7 because I need a working VMware and I can't wait more time. But I can try on a pentium 4 at home to see if I have the same problems.

  10. #10
    Join Date
    Jan 2009
    Beans
    6

    Re: VMware Server 2 error - Web service not available

    It is possible that your system has received a kernel upgrade and vmware has to be reconfigured...

    try running this..

    sudo /usr/bin/vmware-config.pl

    answer all the config questions (I leave all the default answers that are in the [square] brackets) and you should be good.

    Hope this helps.

    Q!

Page 1 of 2 12 LastLast

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •