Page 1 of 2 12 LastLast
Results 1 to 10 of 12

Thread: Trying to get Kworld ATSC 120 working

  1. #1
    Join Date
    Oct 2008
    Location
    Toronto
    Beans
    3
    Distro
    Ubuntu 8.04 Hardy Heron

    Trying to get Kworld ATSC 120 working

    The most recent useful information on this card I can find is here:
    http://www.linuxtv.org/wiki/index.php/KWorld_ATSC_120

    If I understand this right, and there's a good chance I don't, the Kworld 120 is not supported in the kernel found in Mythbuntu 8.04. But I think it might be in the kernel in 8.10. That is 2.6.27-7.

    Rather than update the kernel, I tried installing the 8.10 Beta released last week. I actually had problems installing this, and ended up installing Xubuntu 8.10, then installing MythBuntu.

    The card now gets recognized as analog /dev/video0 and as a DVB device. I can run a channel scan on analog and ATSC, but no channels are found.

    Does this mean I still need to update the firmware?

    I tried following the firmware instructions found here,
    http://www.linuxtv.org/wiki/index.ph...re_Information
    but the script gives many errors, leaving me at a dead end.

    Any suggestions?

    Thanks.

  2. #2
    Join Date
    Oct 2008
    Location
    Toronto
    Beans
    3
    Distro
    Ubuntu 8.04 Hardy Heron

    Re: Trying to get Kworld ATSC 120 working

    I made some progress, so I thought I'd update this thread.

    I got the perl script to work thanks to this forum and instructions on the Kworld 115. The part I didn't understand is that you need to cd to the documentation directory, where you'll find the perl script.

    Take my instructions with a grain of salt since things aren't working perfectly yet:
    $ cd /usr/src/linux-headers-2.6.27-7-generic/Documentation/video4linux
    (using your own kernel version number)
    Download the zip file as directed in the perl script, and unzip the file.
    Then run the local perl script. Don't download the perl script from the link given on the linuxtv.com site. (that was my mistake).
    Copy the generated .fw file to /lib/firmware
    $ sudo cp xc3028-v27.fw /lib/firmware

    I rebooted at this point.

    After removing the DVB device, since nothing is getting locked from ATSC, I rescanned the analog channels. It's picking up analog channels fine. No audio, but I figure that's a different problem.

    Now I have to figure out how to switch the board to ATSC mode.

  3. #3
    Join Date
    Oct 2008
    Location
    Toronto
    Beans
    3
    Distro
    Ubuntu 8.04 Hardy Heron

    Re: Trying to get Kworld ATSC 120 working

    The ATSC setup was pretty easy. I followed the final steps on the original page I linked to:
    http://www.linuxtv.org/wiki/index.php/KWorld_ATSC_120
    making edits to blacklist-misc and rc.local

    Note that there's a typo on that page. The modules are named cx88_dvb, with an underscore, not a dash.

    Things aren't running perfectly for me yet, but I got audio running in ATSC mode. Not sure if it'll work in analog mode. More later.

    I guess the good news is that using the beta version of xubuntu, I could get all this working without downloading kernels or source from mercurial, etc.
    Last edited by darren_j; October 12th, 2008 at 07:15 AM.

  4. #4
    Join Date
    Apr 2008
    Beans
    23

    Re: Trying to get Kworld ATSC 120 working

    I'm having this problem and was researching a fix but im a linux noob.

    I found this, I believe its a patch but I don't know how to install (or what to download).

    http://git.kernel.org/?p=linux/kerne...bd747b77040fea

    If it's useful I'd appreciate if you shoot me back the instructions on how to install it.

    Good luck.

  5. #5
    Join Date
    Sep 2008
    Beans
    7

    Re: Trying to get Kworld ATSC 120 working

    I also have a Kworld 120 that I'm attempting to get running. I've used the same wiki in the post you mention. I've updated the kernel, ran the script to generate the firmware, and added the blacklist/modprobe lines to the appropriate files. At least now I can choose the card in myth, but like you I get no signal lock on channel scan. There is a few setting/tweaks under the DVB card selection that I'm not sure about either. Oh, since I only want the ATSC tuner part(from what I understand you can only use either digital or anolog, but not both), I have that set in my rc.local file. I'm writing this post from a computer other than my backend, so I apologize for my "off the top of my head" post.

  6. #6
    Join Date
    Sep 2008
    Beans
    7

    Re: Trying to get Kworld ATSC 120 working

    After replying to your post, I decided to try again. You mentioned, in one of your post, about the hyphen-undercsore_ error. I didn't think that made a difference, but evidently it does. One of the tutorials points out that there is only support on one module, either analog or digital, at a time. I did an # lsmod to show what modules where loaded and all of them had loaded - not good. I change the blacklist and rc.local file to use underscores for the "cx_" modules and this fixed the problem for me. Your post and discoveries actually help me solve my problem. Thanks!

  7. #7
    Join Date
    Feb 2009
    Beans
    5

    Re: Trying to get Kworld ATSC 120 working

    Jeff,

    Same issue here.

    Did you have to kill and restart mythtv in your rc.local file to get this to work?

    I'm using mythbuntu 8.10, fully updated, but still can't scan any channels in ATSC mode.

  8. #8
    Join Date
    Mar 2009
    Beans
    5

    Re: Trying to get Kworld ATSC 120 working

    Hi!

    Just installed this card on a new machine today with the 9.04 release of mythbuntu. Supposedly, the custom kernal work as described on the mythtv and linuxtv wiki is not needed with the latest generic kernel (currently 2.6.28-13-generic)

    In the mythtv config I am able to select and use the tuner card, am using ETI as the video source but scanning for OVTA HD channels finds nothing.

    Anyone have any luck getting this card to pull in over the air HD?

    I'm thinking I just need to muck about in the mythtv configuration...

    Any help would be appreciated.

    Will update as to my progress, if any, as well.

    Thanks!

  9. #9
    Join Date
    Jun 2006
    Location
    Neither here nor there
    Beans
    3,290
    Distro
    Kubuntu 12.04 Precise Pangolin

    Re: Trying to get Kworld ATSC 120 working

    You don't need the custom kernel, but you probably still need the firmware file be in the right place, and possible have to still load the drivers at the right time... have you done that?
    Linux & MythTV 4 Life
    Running ubuntu on an Atom 330, Atom D525, Turion 64 X2 TL-56, X2 3800, X2 4200, X2 4600, E2180, Core i5 450M, and a Core i7-2600
    My Hardware

  10. #10
    Join Date
    Mar 2009
    Beans
    5

    Re: Trying to get Kworld ATSC 120 working

    Thanks for the reply newlinux,

    I've hopefully loaded my drivers properly, based on instructions from the linuxtv wiki (Step 3). I've got the blacklist-misc file and rc.local faile for ATSC on my system as described in the wiki.

    I did run into some confusion on their wiki in regards to loading the mythtv backed _after_ the proper modules were loaded. I have no idea what to put in the rc.local to do that.

    I have not yet attempted to use the drivers mentioned on their wiki as the instructions seemed to indicate they weren't necessary on post .26 kernels.

    But I'll give that a shot.

    Thanks again!

Page 1 of 2 12 LastLast

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •