Page 1 of 2 12 LastLast
Results 1 to 10 of 11

Thread: Playing MIDI (TuxGuitar)

  1. #1
    Join Date
    Dec 2007
    Location
    El Dorado
    Beans
    170
    Distro
    Ubuntu 8.10 Intrepid Ibex

    Playing MIDI (TuxGuitar)

    Hey,
    I installed TuxGuitar on Ubuntu 8.04.
    When I'm trying to play the composed music score, I got this error:
    MIDI System is unavailable
    Any ideas?

  2. #2
    Join Date
    Jun 2008
    Location
    Vancouver Canada
    Beans
    3,150
    Distro
    Xubuntu 14.04 Trusty Tahr

    Re: Playing MIDI (TuxGuitar)

    Hi HuBaghdadi.

    If you search for midi in synaptic package manager, a number of them are available.
    I learn something ubuntu everyday.
    dell precision T7500 1Tb hdd x 2
    2.67 Ghz intel xeon X5550 cpu
    nvidia quadro fx 4800-1.5 Gb video card

  3. #3
    Join Date
    Apr 2008
    Beans
    4,377
    Distro
    Ubuntu 9.10 Karmic Koala

    Re: Playing MIDI (TuxGuitar)

    If your sound card has no midi emulator you should get:

    timidity

    it is a software midi emulator that should work with tuxguitar.

  4. #4
    Join Date
    Jan 2008
    Beans
    588
    Distro
    Xubuntu 12.04 Precise Pangolin

    Re: Playing MIDI (TuxGuitar)

    i have tuxguitar, i have timidity (now i do anyway) and i still have no sound. thing is, it worked when i first installed timidity, then stopped working as soon as i tried to load a different guitar tab. any one got any ideas what to do?

    i like tux guitar, but v1.0 doesnt seem to work half as well as version 0.9 did!

    *edit*

    playing around with timidity a lot seems to have got it working.... for now...
    Last edited by bryncoles; November 2nd, 2008 at 06:13 PM.
    'I know lifes a bummer baby, But thats got precious little to do with me' - Monster Magnet

  5. #5
    Join Date
    Jul 2007
    Location
    New Zealand
    Beans
    75
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: Playing MIDI (TuxGuitar)

    Hi there. Saying
    Quote Originally Posted by bryncoles View Post
    playing around with timidity a lot seems to have got it working.... for now...
    doesn't help other people who are having problems. The whole purpose of these forums is to help people. What did you do to Timidity to make it work? I don't suppose you will ever look at this thread again, now that you've got your problem solved (sigh).

    Cheers,
    Kath
    Ubuntu 12.04, AMD Athlon 64 3500+, 3.4 GB RAM, 160 + 500 GB HD.

  6. #6
    Join Date
    May 2009
    Beans
    6

    Re: Playing MIDI (TuxGuitar)

    I did the apt-get timidity, or whatever the code is. Everything installed fine, but initially I got the same error message in tuxguitar. All I had to do was go to Tools>Settings>Sound within tuxguitar, and then change the MIDI port from Java to one of the Timidity ports. The very first one worked fine for me. All in all, it took about a minute and a half to do all of this.

  7. #7
    Join Date
    Nov 2009
    Beans
    1

    Re: Playing MIDI (TuxGuitar)

    I got the "midi system unavailable" error until I installed timidi and tuxguitar-oss. Hope this helps!

    -kd

    Note: I'm running Ubuntu 9.10.

  8. #8
    Join Date
    Jan 2009
    Beans
    60

    Re: Playing MIDI (TuxGuitar)

    Hey, the remedies above didn't work for me. I've tried timidity and setting Java to another port. The error disappeared but I just can't hear the sound. I've also installed tuxguitar-oss, didn't help, still no sound.

    I've also tried fluidsynth instead of timidity (fluidsynth as well as tuxguitar-fluidsynth are installed), but that didn't work either.

    Any ideas?

  9. #9
    Join Date
    Jan 2010
    Beans
    1

    Re: Playing MIDI (TuxGuitar)

    Hello everyone. I stumbled upon this thread searching for the answer to the problem and actually found it so here is what did it for me.

    1) go to synaptic manager --->search "timidity" ---> download "timidity" ( the application is called exactly that, there a few others with similar names like "timidity for emcas" or something. I did not use those).

    2) open tuxguitar ---->tools--->preferences----> set sequencer MIDI to real time sequencer.

    3) restart machine.

    4) you're done.

    PS: Sound quality sucks a bit though. So next problem I guess is "how can I get more realistic sounding instruments ?"

    EDIT: ok seems that tux guitar sometimes just randomly stops working, but goes back to normal once I restart my machine.
    this probably means that the timidity download was not what fixed it.(not sure)
    At this point I have no idea what makes it work. I am limiting myself to restart whenever the midi error starts showing up for now.
    Last edited by kar33m; January 29th, 2010 at 04:14 PM.

  10. #10
    Join Date
    Feb 2010
    Location
    Espoo, Finland
    Beans
    1
    Distro
    Xubuntu 9.10 Karmic Koala

    Re: Playing MIDI (TuxGuitar)

    I got mine working properly by following these steps:

    1. Install TiMidity
    2. Install tuxguitar-oss via terminal
    3. From TuxGuitar's settings, set the MIDI Sequencer to "Real Time Sequencer" and MIDI Port to "TiMidity port 0 #1"
    4*. Reboot

    * Might not be even necessary.

    Hope this helps =)

Page 1 of 2 12 LastLast

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •