Page 2 of 2 FirstFirst 12
Results 11 to 12 of 12

Thread: [SOLVED] GNOME PPP Check permissions

  1. #11
    Join Date
    Feb 2010

    Post Re: [SOLVED] GNOME PPP Check permissions

    Quote Originally Posted by MacDuff View Post
    Trying to set up a laptop to use a USRobotics Model 5637 USB modem so a friend can use a dial-up Internet connection.

    This person needs a graphical user interface so I thought that GNOME PPP would be good. However I have been trying to get it to work on my laptop and when it tries to connect I get the following error:

    Carrier detected. Starting PPP immediately
    Unable to run /usr/sbin/pppd
    Check permissions, or specify a "PPPD Path" option in wvdial.conf

    Below is the content of wvdial.conf
    [Dialer Defaults]
    New PPPD = yes
    Stupid Mode = yes
    Modem Thpe = Analog Modem
    ISDN = 0
    Auto DNS = 1
    Auto Reconnect = 0
    Modem = /dev/ttyACM0
    Baud = 230400
    Initl = ATZ4

    Phone = 250 388 5747
    Username = {name}
    Password = {password}

    Here is what the specs on on /usr/sbin/pppd :
    Type is: executable,
    permissions are: -rwxrwxr--
    Owner:Group is: root:30 That looks odd to me but I am still pretty green with Ubuntu.

    Can anyone suggest what I must change, and how to get this machine to connect to the Internet via dial-up using GNOME PPP or other graphical interface?
    Just in case anyone else is browsing this thread, there's another way to solve this problem. I tried granting permission using the terminal but it didn't work, so here's how I did it:

    Open terminal.
    Open nautilus by typing "sudo nautilus".
    Enter password when prompted.
    When the file browser opens, go to the folder usr, then to folder sbin,where you will find the executable program pppd.
    Right click on ppd, go to properties, then go to permissions tab under properties.
    There, you will find an option for allowing the program to be run as an executable (I've forgotten the exact words). There's a check box adjacent to it. If there is a minus (-) sign in this box, click it to change it to a tick sign. Now permissions are ok and you should be able to use gnomeppp which executes pppd without a problem.
    Last edited by hst19; February 20th, 2010 at 09:35 AM.

  2. #12
    Join Date
    Mar 2011

    Re: [SOLVED] GNOME PPP Check permissions

    I just installed Ubuntu 10.04. I got KPPP working with my modem and I can connect and stay connected. My issue is I cant get network manager to use the dialup connection bcause there is no tab for modem in the new GNOME Network Manager. Can anyone tell me what to try next?

Page 2 of 2 FirstFirst 12


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts