Results 1 to 10 of 11

Thread: Resolution not scaling with rdesktop to RDP-server of VirtualBox

Threaded View

  1. #1
    Join Date
    Mar 2006
    Location
    The Netherlands
    Beans
    82

    Resolution not scaling with rdesktop to RDP-server of VirtualBox

    I'm connecting with rdesktop through the builtin RDP-server in VirtualBox to a Windows session. Although this succeeds, the client-side resolution can *not* be controlled by the rdp-client (rdesktop) through several commandline options. The actual resolution is the resolution on the server it self (this is the same if the session is displayed locally by the vbox manager). The only way to control the client-side resolution is to change the resolution in the session it self (right click on Desktop, Properties, etc.).

    Normally RDP should work like this: the client requests for a certain screen resolution (fullscreen or defined width/height), the RDP-server responds by actually change the resoluton server-side. It seems that my problem has to do with the fact that the vbox RDP-server does not respond to the requested resolution by the client.

    The following combinations were tried:
    1. Ubuntu/rdesktop -> vbox RDP-server: no resolution scaling
    2. Ubuntu/tsclient -> vbox RDP-server: no resolution scaling
    3. Windows/mstsc -> vbox RDP-server: resolution scaling works
    4. Ubuntu/rdesktop -> Windowx XP RDP-server: resolution scaling works

    At first, I was thinking it was a RDP-client problem, because both rdesktop and tsclient (combinations 1+2) did not do the resolution scaling. This seems to be confirmed when I connected with MS Terminal Server Client (standard RDP-client in Windows) from a Windows XP installation to the vbox RDP-server (combination 3): that client did change the client resolution.

    Thinking it was clearly a client problem, I then did combination 4, rdesktop to a Windows XP RDP-server and rdesktop is actually capable of resolution scaling, because it worked (unexpected though).

    My conclusion so far: it seems like *only* the specific combination from rdesktop/tsclient to vbox RDP-server does not do resolution scaling, all other combinations work (tried also gnome-rdp client, but as this is using rdesktop on the background, it gives the same result).

    This is the error/warning when I try to connect from rdesktop to vbox RDP-server:

    Code:
    user@lin12:~$ rdesktop 192.168.0.101:3390 -g 1024x700
    WARNING: Remote desktop changed from 1024x700 to 800x600.
    It's obvious it's changing the defined resolution (1024x700) to the resolution server side (800x600). When I connect with rdesktop to a Windows RDP-server, such a warning does *not* popup.

    Does anybody have a clue why rdesktop is not able to change to resolution of the vbox RDP-server session?
    Last edited by markba; September 18th, 2008 at 10:28 PM.

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •