Page 1 of 2 12 LastLast
Results 1 to 10 of 13

Thread: [SOLVED] Gnome terminal text (fonts) spacing mess

  1. #1
    Join Date
    Jul 2007
    Location
    India
    Beans
    233
    Distro
    Ubuntu 9.04 Jaunty Jackalope

    Unhappy [SOLVED] Gnome terminal text (fonts) spacing mess

    hi...

    was trying to tweak my gnome terminal window for colours with help from this link...

    http://www.ibm.com/developerworks/li.../l-tip-prompt/

    but have messed up the text (fonts) as spacing of some letters is too close now to be readable... this is not the case with the default profile...

    please see the screenshot...

    I tried re-installing gnome-terminal but to no avail...

    please help...!!!
    Attached Images Attached Images

  2. #2
    Join Date
    Jul 2007
    Location
    India
    Beans
    233
    Distro
    Ubuntu 9.04 Jaunty Jackalope

    Re: Gnome terminal text (fonts) spacing mess

    anyone, please?

  3. #3
    Join Date
    Jul 2007
    Location
    India
    Beans
    233
    Distro
    Ubuntu 9.04 Jaunty Jackalope

    Unhappy Re: Gnome terminal text (fonts) spacing mess

    awaiting.....

  4. #4
    Join Date
    Jul 2005
    Location
    Ohio, USA
    Beans
    665
    Distro
    Ubuntu 9.04 Jaunty Jackalope

    Re: Gnome terminal text (fonts) spacing mess

    You're going to **** a lot of people off by bumping your own thread several times per hour. You're also screwing yourself out of the unanswered unreplied thread count. A thread without any answers is often picked to answer a question rather than one with multiple answers as it is assumed those threads have been answered already.

  5. #5
    Join Date
    Mar 2006
    Location
    Williams Lake
    Beans
    Hidden!
    Distro
    Ubuntu Development Release

    Re: Gnome terminal text (fonts) spacing mess

    I don't suppose you made a backup of /etc/bash.bashrc? I suppose you could remove the changes you made to restore it back to the default settings. If you created a .bashrc file in your home directory you could delete it.

    Without knowing what and how you changed the settings it is pretty hard to tell you what to do to repair your problem.

    Reinstalling a program because you sdrewed up the config file is not going to change anything as you found out. Reinstalling a program because it doesn't work the way you expected, is the windows way of doing things. Remember Linux is not Windows. What you know about windows does not transfer to Linux.

    If you could post the files you changed we might be able you to solve your problem.

    Jim

  6. #6
    Join Date
    May 2007
    Location
    Netherlands
    Beans
    639
    Distro
    Ubuntu 10.04 Lucid Lynx

    Re: Gnome terminal text (fonts) spacing mess

    If you've got a live cd you can try copy the .bashrc file back to your home folder.
    start from the live cd, look for the .bashrc (find .bashrc) and copy it to your harddisk.

    Also i believe if you put in the command export PS1=""\e[0m >" should set the foreground and background color back. Also in Gnome-terminal you can change text in edit, current profile, try with that see if it helps.

    Sorry, I looked this up and couldn't come up with anything better. Perhaps someone else might be able to help you better.

    That tutorial is from 2000 BTW, although I think it is still up to date, I would check around first before experimenting in such detail with your bash.
    Approach life & cooking with reckless abandon.

  7. #7
    Join Date
    Apr 2006
    Location
    No Comment
    Beans
    1,733
    Distro
    Kubuntu 7.10 Gutsy Gibbon

    Re: Gnome terminal text (fonts) spacing mess

    did you perhaps change fonts?? some fonts make the txt appear closer than others..
    My Stuff:
    Hostfile Blacklist
    K/Ubuntu 7.10 Tips/Tricks
    3_days_+_no_reply=Subscription_Removed

  8. #8
    Join Date
    Jul 2007
    Location
    India
    Beans
    233
    Distro
    Ubuntu 9.04 Jaunty Jackalope

    Re: Gnome terminal text (fonts) spacing mess

    Quote Originally Posted by cariboo907 View Post
    I don't suppose you made a backup of /etc/bash.bashrc? I suppose you could remove the changes you made to restore it back to the default settings. If you created a .bashrc file in your home directory you could delete it.

    Without knowing what and how you changed the settings it is pretty hard to tell you what to do to repair your problem.

    Reinstalling a program because you sdrewed up the config file is not going to change anything as you found out. Reinstalling a program because it doesn't work the way you expected, is the windows way of doing things. Remember Linux is not Windows. What you know about windows does not transfer to Linux.

    If you could post the files you changed we might be able you to solve your problem.

    Jim
    thanks, i did not create it but the .bashrc file was already there in my home directory... i had added / removed a line exactly like below (did this 2-3 times since i was testing to view different colours):
    ------------------------------------------------------------
    export PS1="\[\e[36;1m\]\u@\[\e[32;1m\]\H> \[\e[0m\]"
    ------------------------------------------------------------


    the following are the contents of .bashrc prior to editing & at present:

    ==============================================
    # .bashrc

    # User specific aliases and functions

    # Source global definitions
    if [ -f /etc/bashrc ]; then
    . /etc/bashrc
    fi
    ==============================================

    please help...

  9. #9
    Join Date
    Jul 2007
    Location
    India
    Beans
    233
    Distro
    Ubuntu 9.04 Jaunty Jackalope

    Re: Gnome terminal text (fonts) spacing mess

    If you've got a live cd you can try copy the .bashrc file back to your home folder.
    start from the live cd, look for the .bashrc (find .bashrc) and copy it to your harddisk.
    thanks, ok i am trying your suggestion of live CD... looks like this will work...!!!

    i will backup my ~/.bashrc file as ~./bashrc.old & copy a new version from the live CD...

    Also i believe if you put in the command export PS1=""\e[0m >" should set the foreground and background color back. Also in Gnome-terminal you can change text in edit, current profile, try with that see if it helps.
    did you perhaps change fonts?? some fonts make the txt appear closer than others..
    well, the current profile thing is not helpful since if i enable "use the system fixed width font" the text appears ok... its only with the other profiles that this problem appears...

  10. #10
    Join Date
    Sep 2007
    Location
    KCMO
    Beans
    210
    Distro
    Ubuntu 14.04 Trusty Tahr

    Re: Gnome terminal text (fonts) spacing mess

    Monospaced fonts tend to work best in the Terminal. Try finding a monospace or fixed-width variant of the font you want to use.
    Desktop: Custom - AMD Athlon X4 Quadcore 4.02GHz, 8GB DDR3, 750GB HDD, 500GB HDD, Win7 x64/Ubuntu 14.04 x64
    Laptop: Thinkpad T61 - Intel Core 2 Duo 2.00GHz, 4GB DDR2, 500GB HDD, Win7 x86/Ubuntu 14.04 x86

Page 1 of 2 12 LastLast

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •