Page 2 of 2 FirstFirst 12
Results 11 to 20 of 20

Thread: [SOLVED] LCD backlight brightness (8.04)

  1. #11
    Join Date
    May 2008
    Location
    Shanghai
    Beans
    110

    Re: LCD backlight brightness (8.04)

    Quote Originally Posted by chinchillart View Post
    Thanks for the information!
    I'm trying to solve a related problem with my LG Flatron (20" Desktop LCD )

    After setting up the cpufreqd to work with the Athlon X2 processor, I've lost the automatic LCD standby... The screensaver also stopped to work.

    Before the cpufreqd install and config, everything worked fine.
    Anyway, I've the same problem with the LCD brightness gnome applet. It doesn't work.

    I wish someone could suggest me some in-depht documentation about power saving related issues and configuration in Ubuntu/Debian.

    Rob
    This sounds unrelated as my brightness issue is something to do with ACPI, I assume. It didn't work before setting up frequency scaling at all and the brightness controls stop functioning in the very early stages of the boot process, before anything related to frequency scaling is executed.
    Guess you should start a new thread then.

  2. #12
    Join Date
    May 2008
    Location
    Shanghai
    Beans
    110

    Re: LCD backlight brightness (8.04)

    Is there anything else I could provide as info? Or a workaround that I haven't mentioned yet? That's the only issue left on my laptop.

  3. #13
    Join Date
    May 2008
    Location
    Shanghai
    Beans
    110

    Re: LCD backlight brightness (8.04)

    Does anyone of you know another way to single down the cause of this problem to a certain source? Or can I obtain the source of the acpi packages somewhere?

  4. #14
    Join Date
    May 2008
    Location
    Shanghai
    Beans
    110

    Re: LCD backlight brightness (8.04)

    "Good news, everyone..."

    Playing with the options explained here http://www.columbia.edu/~ariel/acpi/acpi_howto.txt I finally managed to get it done!

    I added the boot option acpi_osi= to my kernel line in /boot/grub/menu.lst and now it works! By default acpi_osi is used to hand over a string to the BIOS to pretend we are running Windows or any other OS for that matter. Providing an empty string apparently leaves it as it is - so now it works. Truth prevails!

  5. #15
    Join Date
    Aug 2006
    Location
    UK
    Beans
    105
    Distro
    Ubuntu 9.10 Karmic Koala

    Re: [SOLVED] LCD backlight brightness (8.04)

    Thanks for that - it works a charm.

    I've been arguing with my laptop (Novatech X70 - also based on a Clevo) for a couple of days now and it was starting to annoy me!

  6. #16
    Join Date
    Jul 2009
    Beans
    10
    Distro
    Ubuntu 9.10 Karmic Koala

    Re: LCD backlight brightness (8.04)

    Quote Originally Posted by rekado View Post
    "Good news, everyone..."

    Playing with the options explained here http://www.columbia.edu/~ariel/acpi/acpi_howto.txt I finally managed to get it done!

    I added the boot option acpi_osi= to my kernel line in /boot/grub/menu.lst and now it works! By default acpi_osi is used to hand over a string to the BIOS to pretend we are running Windows or any other OS for that matter. Providing an empty string apparently leaves it as it is - so now it works. Truth prevails!
    Can someone please clarify for me where in the file acpi_osi= needs to go? I'm still new at this, and slightly paranoid. Thanks!

  7. #17
    Join Date
    May 2008
    Location
    Shanghai
    Beans
    110

    Re: LCD backlight brightness (8.04)

    Open the file /boot/grub/menu.lst with your favorite editor. Somewhere in the middle of the file there should be a line that starts with "kernel /boot/"... This is the kernel line that I meant. There might be several kernel lines in your menu.lst file. In order to identify where to add it, have a look at the lines before the kernel line starting with "title". You should see the text that you usually select in GRUB upon booting. If you never select any different kernel in GRUB, then just go with the first.

    Add "acpi_osi=" (without the quotes) to the end of that line. Make sure that it is still only one line (and not suddenly two lines as it happens with older versions of "nano").

    Then reboot.

    Before you do this, though, make sure it works by adding "acpi_osi=" as a boot option during boot. You can do this when the GRUB menu appears. Select the kernel line you want to temporarily modify and press "e" (I guess) to edit the line. When you are done boot this modified line by pressing "b".

    If this solves your problem proceed as above by changing the entry in menu.lst.

  8. #18
    Join Date
    Jul 2007
    Beans
    17

    Talking Re: [SOLVED] LCD backlight brightness (8.04)

    YES!

    I have been looking for a solution to this problem for almost a year (well, not so much looking for a solution as dealing with).

    To make it easier for people with a similar problem to find this post:

    I have a Dell Inspiron 1420.
    Symptoms included that the acpi event fired twice and that it looked like multiple things were controlling brightness.

  9. #19
    Join Date
    Jun 2008
    Beans
    53
    Distro
    Kubuntu 9.10 Karmic Koala

    Re: [SOLVED] LCD backlight brightness (8.04)

    how to add this option in GRUB2 ??

  10. #20
    Join Date
    May 2009
    Beans
    10
    Distro
    Ubuntu Development Release

    Re: [SOLVED] LCD backlight brightness (8.04)

    >sudo gedit /etc/default/grub

    and add it to the "GRUB_CMDLINE_LINUX=" parameters

    then
    >sudo update-grub

Page 2 of 2 FirstFirst 12

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •