Page 1 of 12 12311 ... LastLast
Results 1 to 10 of 119

Thread: Configuring Acer 6920 Hardware

  1. #1
    Join Date
    Apr 2007
    Ubuntu 10.04 Lucid Lynx

    Lightbulb Configuring Acer 6920 Hardware

    [NOTE] As of Ubuntu 9.10 everything works out of the box except two things: fingerprint scanner, Video card. The video card works nice, it just feels like the driver itself isn't fully completed. Using Gnome Shell during the "activity" screen many little holes exist in the screen (unclickable area) because of this driver issue.

    I've fallen in love with this Acer 6920 that i configured to ALMOST work flawlessly with Ubuntu, here's what i found that works:

    Works out of the box:
    -Brightness fn key adjuster with a few other "fn" keys
    -Graphics seem to be fine and smooth
    -Wireless works Perfectly
    -Shortcut keys (such as the "e" button, wireless on/off button, internet/email/bluetooth)
    -Locking the CineDash is functional (its already configured at the hardware level) :: If kept locked at login will not let volume up/down work.
    -Play, Pause, Stop, Next song, Previous song work flawlessly, the shortcuts can be set in the keyboard shortcuts (For gnome its preset to work with rhythmbox).
    -VGA adapter (just restart xserver while connected to monitor/overhead to clone output, sometimes restart the whole computer, if that doesn't work just configure in system>pref>screen resolution make sure "clone screens" is checked.)
    -CD/DVD Reader/Burner is flawless.
    -And yes, the pretty blue lights on each side of the screen joints work just fine =] as well as the power button light and the CineDash light.

    Will work with a bit of configuration:
    -Camera (Conflicts with Ubuntu 8.10 AFTER online package updates).
    -CineDash Pad (Vol+, Vol-, Mute) (ALSA: Volume controls on CineDash work but make sure on login you DO NOT have the controls on "Hold" or else ubuntu will not detect the hardware, if you logging with it on hold just log out and log back in this time with the Hold off!)
    -Ethernet (WORKS OUT OF BOX IN INTREPID 8.10)

    (be prepared to spend some time configuring them all, or you can configure them individually by finding its section in this tutorial)

    What i have found that doesn't work:

    -The 2 buttons on CineDash (one with the little man spreading his arms and the backwards arrow)
    -Fingerprint scanner (Who uses this anyway?)


    -SD Card Reader If booting up with an SD card already inserted Ubuntu can detect the hardware that way and recognize the SD card. (May work on login)
    -Volume up/down CineDash :: Works with ALSA 1.18 when you login, MAKE SURE THE HOLD BUTTON IS NOT ON, otherwise ubuntu will not detect the hardware.

    Unknown Issues:
    WebCam seems to act weird when updating to latest software versions, I'm not sure which package ruins this but the kernel update seems to not bother the webcam, i refuse to upate until this is resolved :: After package updates Webcam only displays on lowest resolution, will not do 800x600 or others.

    Mic is not supported with the alsa driver yet

    Installing your hardware drivers!


    First check if your camera is already supported.
    install Cheese (it depends on ubuntu version, to my knowledge 8.04 supports my camera):

    sudo apt-get install cheese
    After you install it run it through Applications > Graphics > Cheese
    If you see an image feed your good!

    If not...


    Very simple. add two repositories through your:

    System > Administration > Software Sources

    "Third-Party Resources" Tab

    click "+ Add"

    copy paste these two lines individually into the text field.

    deb hardy main
      deb-src hardy main
    then open a terminal and do

    sudo apt-get update
    Now, if you se Gnome (gtk -- Regular Ubuntu) use this to install

    sudo apt-get install easycam2-gtk
    If you use KDE (qt -- Kubuntu <-- KDE version of Ubuntu) use this:

    sudo apt-get install easycam2-qt
    Run the EasyCam through Applications > Accessories the interface might
    be i a different language but its as simple and clicking next and then
    clicking the middle to scan for the camera and find suitable drivers.

    After that try using Cheese to see if you get an image feed, you
    should, if not post your problems!

    ================================================== ===================

    Sound and CineDash are a bit tricky..

    ---------------------------ALSA 1.0.18a Driver---------------------------


    This will install the newest ALSA driver which will have 80% functionality of your sound quality (surround sound not supported completely)

    To start the installation simply download this script to your home folder:


    Fire up a Terminal and enter the following (use as separate lines):
    sudo chmod +x
    sudo ./
    The script will download the ALSA 1.0.18a drivers from the ALSA-PROJECT website and install them automatically, will take approx 10-20 mins depending on connection.

    After restart come back and continue...

    After restart add the sound control app on to your panel if u have not already.

    right click on the app and go to preferences:

    For the device select HDA Intel (Alsa mixer)
    now for every entry underneith (Master, Headphone, PCM, etc...)
    left click to open sound control on the panel app. select each entry and unmute it from its position, the new driver mutes every entry as a precaution i guess.

    And that should be it!

    This installs the HDA VERB in an attempt to use the full potential of our speakers, its not too shabby.

    tar -xvmf hda-verb-0.3.tar.gz
    cd hda-verb-0.3
    sudo cp hda-verb /usr/local/bin  
    sudo gedit /etc/rc.local
    now add this string:
    /usr/local/bin/hda-verb /dev/snd/hwC0D0 0×15 SET_EAPD_BTLENABLE 2
    save and exit, now just restart and hda verb shall be installed!
    before the exit 0
    This method installs the OSS4 driver which then u can program the cinedash to use as a volume up/down but since it is not a native driver to ubuntu it may cause some trouble. One is a lower volume expected than regular.

    You can follow this guide:

    Download my easy to install script from to you home folder:

    Download the to you home folder:

    now fire up a terminal and put in:
    chmod +x
    sudo ./

    This will download and install the OSS4 driver follow instructions from the terminal, make sure u set the default driver as OSS rather than the default ALSA.

    Now to be able to manipulate sound you will need to use the ossxmix program that comes with the OSS4, u could also likewise use ossmix, but ossxmix has a gui.

    1. Go to your System > Preferences > Sessions
    2. Click "+ Add"
    3. Type in the name of the program: OSS X Mix
    4. The command will be ossxmix
    5. Then enter the description "Volume Control For OSS4

    Reboot and your sound should work!

    You will see a new item in the sys tray, it a black square with a neon blue writing on it, thats ossxmix. Clicking that will open a full screen sound manipulation... which kinda sucks... but its good for what need it for.

    ================================================== ===================

    CineDash: WORKS WITH OSS4 (with this configuration)::: WORKS FINE WITH THE ALSA DRIVER (Tho it stops working randomly...)

    Theres two procedures, a patch for GStreamer Patch

    Which turned out a bit buggy for my rhythmbox with very very fuzzy sound (but made my cinedash work fine). You'll have to switch to amarok in order to fix the fuzz, and even then your shortcut keys for play/pause won't work. (at least to my attempt)

    If you want to stay in Rhythmbox here we go:

    Configure CineDash

    First unhide the configuration editor in the Applications > System Tools menu by going to System > Preferences > Main Menu

    On that window click on the "System Tools" on the left folder tree
    Configuration Editor should be on the very top, check the box and click close.

    Now we'll need to create some scripts
    Create new folder in home folder and go into it:

       mkdir ~/.volumeControl
       cd ~/.volumeControl
    create first script to lower the volume:

    Now just copy and paste the following into the terminal text editor pico that you just started:

    VOL=$(ossmix | grep misc.mix21 | awk '{print $4}' | awk -F : '{print $1}')
     VOL=$(echo $VOL-8 | bc)
     ossmix misc.mix21 $VOL:$VOL
    now press Ctrl + x
    It will ask you if you want to save, press y then enter

    now to make a script for volume up!

    then copy the next code in the term...

     VOL=$(ossmix | grep misc.mix21 | awk '{print $4}' | awk -F : '{print $1}')
     VOL=$(echo $VOL+8 | bc)
     ossmix misc.mix21 $VOL:$VOL
    again 'Ctrl + x' then 'y' then 'enter'.

    and one more script:

    then the next code copy to term..

     VOLUME=$(cat $HOME/.volume)
     if [ -z "$VOLUME" ]; then
           VOLUME=$(ossmix | grep misc.mix21 | awk '{print $4}' | awk -F : '{print $1}')
           ossmix misc.mix21 0:0
           echo $VOLUME > $HOME/.volume
           VOLUME=$(echo $VOLUME + 1 | bc)
           ossmix misc.mix21 $VOLUME:$VOLUME
           > $HOME/.volume
    Againt with the 'ctrl+x' 'y' 'enter'

    no more scripts! just one more file.

    pico mute.txt
    then just type in "0:0" (without quotes)
    and press 'ctrl + x' 'y' 'enter'

    The mute.txt file will keep track of whether the system is muted or not so it knows to mute or unmute.

    Now we'll have to make each of these scripts executable by running

    chmod +x
    Just do this for the other two scripts and ur done with this part..

    Good! Now we have to bind these scripts to our CineDash
    The CineDash uses regular keyboard interrupt requests (signals) so we just need to find what those signals are!

    open your regular keyboard shortcut editor
    and now open your config editor Applications > System > Configuration Editor

    in the configuration editor navigate to metacity apps > metacity

    in here you set shortcuts to many things, and edit anything to do with metacity (your window manager)

    go to 'global keybindings'

    in here you'll see keystrokes that will do certain things we're looking to make our own shortcuts so go under run_command_1 next to it you'll see "disabled" click on the disabled and it'll ask for some text. this is where we need to know which signal codes our keys give so we can bind that code with a command. So go to ur Keyboard Shortcuts window and analyze mute, volume down, and volume up. Right next to each is a set of text
    something in the lines of 0x0a

    you want that text, thats the keyboard code for that key. so go to your config editor and under run_command_1 put in the text u see under "Mute" on the keyboard shortcut window. and do the same for volume up with run_command 2 and volume down with run_command_3

    So now we have them binded! But the metacity doesn't know what to do when you press those keys, it knows its there, but doesn't know what to do in particular.

    now on the config editor go to "keybindings_command"

    its in the left file tree in the same directory as "global_keybindings" in the metacity directory.

    and in this folder we'll see "command_1" and so forth. This is where we tell metacity what to do when we press mute, volume up, and volume down. We already identified what the keys were when we set the '0x0a'-etc. and other text in the 'run_command_1'

    Now we just have to bind those scripts we made to those keys
    we made run_command_1 bind with mute
    run_command_2 bind with volume up
    run_command_3 bind with volume down

    so all we have to do is go to command_1 click on the right under "value" (its probably blank) then type in the directory of our scripts including the script.

    /home/<your user id>/.volumeControl/

    and the same for volume up (command_2) and volume down (command_3)

    after your done with that.. .your done! restart the x server with ctrl + alt + del and now your volume control should work! The mute will be a little fussy because on the CineDash when you activate the mute it stops control of volume, Ubuntu doesn't have a driver for CineDash to recognize if CineDash itself is muted. So when you mute you might lock the CineDash, but Ubuntu will Un-mute, so just use the fn-f8 key to balance the mute on ubuntu with the lock on cinedash... small bug.

    ================================================== =====================

    Ethernet is actually rather simple


    download the driver into your home directory:

    go into your terminal
    and run these:

    cd ~
    mkdir l1e-linux-v1.0.1.0
    cd l1e-linux-v1.0.1.0
    cp ../l1e-linux-v1.0.1.0.tar.gz .
    tar xzf l1e-linux-v1.0.1.0.tar.gz
    cd src
    sudo KBUILD_NOPEDANTIC=1 make
    sudo KBUILD_NOPEDANTIC=1 make install
    cd /lib/modules/2.6.24-16-generic/kernel/drivers/net/atl1e/
    sudo insmod ./atl1e.ko
    and thats it! you got your network card working with ethernet

    Thats all that i could find that works with the Acer 6920. The rest i have not found yet... I know the mic support will have to do with the sound driver OSS4, and i've seen that an updated ALSA and Verbose makes the sound work fine, but will crash when trying to use multiple apps with sound, the ALSA might also support the mic...

    Kopete seems to work, but sometimes me and the recipient can only see a black box...
    [[Kopete will work fine with camera if you install the Jasper from the ubuntu repositories, use synaptic to search. If you compile from source u may be broadcasting a black box... dont know how that works.]]

    The SD card is what i really want to get working, after that i really don't need anything else (but i would like everything to work flawlessy )

    Hope this tutorial helped configure your Acer 6920 to function for you =]

    If anyone has any hints to kopete or mic (sound driver) or SD card, PLEAAASSE respond =]


    ALSA 1.0.18a:
    Also works on a Intel HDA 8280I (ICH9) sound with a Dell Inspiron 1440.
    Last edited by CJay554; March 2nd, 2010 at 02:25 PM.
    When you first dont succeed, google- google again

  2. #2
    Join Date
    Sep 2008

    Re: Configuring Acer 6920 Hardware

    I have got mine laptop for 2months and had been wondering when something like this would come up
    i gave up within days when i figured i couldnt fix it ^^
    im gonna test it now in Kubuntu KDE4 ill let you know if something doesnt work^

    Another THANK YOU
    (also could you describe how you installed the 9500m GS Vidcard)

  3. #3
    Join Date
    May 2007

    Re: Configuring Acer 6920 Hardware

    Hey! Very nice collection, thank you! The volumeContol stuff is new for me, will try that in a while

    Does your brightness function keys work (fn+left or right arrow)?

    Oh and Djustin, the 9500GS is configured the same way as any other nvidia card - From the restricted drivers manager
    Last edited by aralbald; September 16th, 2008 at 09:56 PM.

  4. #4
    Join Date
    Sep 2008

    Re: Configuring Acer 6920 Hardware

    i dont see that button on the KDE4 -.-"
    well the ethernet connection works
    but only my wireless is there, but cannot connect to my network
    the router is setup not to broadcast,n-only,WPA2-personal
    any suggestions?

  5. #5
    Join Date
    Apr 2007
    Ubuntu 10.04 Lucid Lynx

    Re: Configuring Acer 6920 Hardware

    Because your router is not broadcasting your going to have to manually set up the connection:

    either by leaving roaming mode or by clicking on ur icon for the wireless in your systray, then "Connect to other wireless networks..."

    Put in your ESSID (name of your wireless) then the encryption type/key and that should let you communicate with the router.

    I never configured my graphics card, was never in my proprietary drivers. Seemed to work fine out of the box? Keep in mind theres the 6920, 6980, and im sure other models with different functions, but the basics are the same.

    I really want the SD card to work =[

    Oh, and with Kopete, install the jasper from repositories, search in synaptic, when i installed from source on jasper host site, it gave me a black box when broadcasting camera, but when i installed from repo's it worked perfectly! although yahoo cam on kopete lags a little more than vista, small price for good functionality ;]

    Brightness buttons worked for me out of the box.
    Last edited by CJay554; September 23rd, 2008 at 09:14 PM.
    When you first dont succeed, google- google again

  6. #6
    Join Date
    Feb 2007
    Racine, Wisconsin
    Ubuntu 9.04 Jaunty Jackalope

    Re: Configuring Acer 6920 Hardware

    Thank you for this post. after having linux absent from this laptop for months, I decided to search and try again.

    I have sound, however, I cannot control the level from both the pad or a mixer. I have followed this guide to the T, and done searches around for fixes. Are there any recommendations?


    People, check to make sure whether you're running 32bit or 64bit.
    My mistake was since I installed Ubuntu via Wubi, I had no idea it was 64bit. Once I copied the right file over and restarted the volume control, it started working. The control pad works now too!
    Last edited by Freaky_Llama; September 27th, 2008 at 04:09 AM. Reason: I missed the obvious.

  7. #7
    Join Date
    Jul 2008

    Got to work with alsa

    Heya. thanks for the tutorial

    I tryed to make it to work with alsa using the alsa update to version 1.08.rc3

    first using using this

    but when I rebooted could not load the snd modules after running around in circles for a while I found this

    the problem was oss that I installed removing the dir /lib/modules/`uname -a`/kernel/sound and removing the soundcore.ko that was inside.

    so I removed the oss from /usr/lib/oss (the one from mercurial)

    reinstalled the kernel with

    sudo apt-get install --reinstall linux-image-2.6.24-21-generic

    and everything was dandy..

    alsa and all the only problem left is the headphones.. when you plug it it doesn't stop the playback on the main speakers

    and on reinstaling the

  8. #8
    Join Date
    Sep 2008
    Kubuntu 9.10 Karmic Koala

    Re: Configuring Acer 6920 Hardware

    Those looking to get the alc889 sound chip (ships on both acer aspire 8920 and 6920) working should take a look at this.

    The integrated speakers can be muted (ironically) by muting your headphone. Found this out just by trial and error. (That would be with alsa 1.0.17 on hardy 32-bit.)

    The ethernet fix above is missing a little bit, since after driver version the insmod line hasn't been enough to make the module load by default (anymore), so you should add "atl1e" without the quotes to /etc/modules. Complete instructions here.

    Working on the mic now, though I think the problem will be resolved with the next release of alsa since they've released a patch (patch_realtek.c) for alsa to add support for the three realtek chips. So far I've been unable to compile alsa (1.0.17 and 1.0.18 rc's) succesfully with the patch though, so I am very excited to see the next stable release.

    After some research about the TV chip it became clear that this is a basic device and even though the version of the chip in Aspire 6920 ships with vista drivers there is no single driver available for download, so if you want to have a working tv chip you might want to consider buying a supported pcmcia or usb device instead.
    Last edited by no0ne; October 16th, 2008 at 05:31 AM.

  9. #9
    Join Date
    Oct 2007

    Re: Configuring Acer 6920 Hardware

    wow great tutorial it actually made sense
    but i still have problems with the sound.. or lack of

    when i go to system> preferences> sound
    and click "Test"
    i get this weird error
    audiotestsrc wave=sine freq=512 ! audioconvert ! audioresample ! gconfaudiosink: Could not open audio device for playback.

    i flicked through the different options (ALSA,ESD,OSS,PulseAudio) but it changed nothing

    i thought it might be because i tried getting pulse audio to work before i found your tutorial.. but i have no idea...
    any ideas?

  10. #10
    Join Date
    Mar 2007
    Philadelphia, PA USA
    Ubuntu 8.04 Hardy Heron

    Re: Configuring Acer 6920 Hardware

    Same here.

Page 1 of 12 12311 ... LastLast

Tags for this Thread


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts