Page 3 of 59 FirstFirst 123451353 ... LastLast
Results 21 to 30 of 586

Thread: HOWTO: installation of e17 from SVN code

  1. #21
    Join Date
    Oct 2004
    Beans
    2,324

    Re: HOWTO: installation of e17 from SVN code

    Quote Originally Posted by Tux Aubrey View Post
    Great! Thanks for the info - I'll pass it on to Rui.

    Others (and me) are also reporting errors when we try to do an update - but these seem to be on svn rather than in the scripts. The errors are "fatal" to the update but don't cause problems with a good install.
    Thank you for the reports.

    Unfortunately that's a bad/buggy Makefile to build the theme, the only way would be patch it out after svn update... any changes would of course be lost on next update, so...

    And it installs only at user level (not system wide) but with root ownerships!


    I made a new e17-svn version that leave b_and_w out for the time been.
    Users that want it must either remove it from skip list and fixes things by hand, keep it on skip, get the code and compile directly with build.sh script included (for edje_cc) or use the OzOS update_e17 tool to update that ensures sane install of the theme.

    I'll keep an eye on it to see if Makefile gets fixed so i can put it back by default.
    ___________________________________
    ESTRAGON: We've lost our rights?

  2. #22
    Join Date
    Oct 2004
    Beans
    2,324

    Re: HOWTO: installation of e17 from SVN code

    Quote Originally Posted by whyette View Post
    I am running into a problem with the install. It seems to be a problem with dpkg, and now I can't install anything via comline.

    I get an error that there's a 404 error when updating sources.
    Code:
     sudo dpkg --configure -a
    Setting up e17-svn (0.9.4) ...
    
    --------------------------- Easy_e17.sh 1.2.0.4-OzOS ---------------------------
      Developers:      Brian 'morlenxus' Miculcy
                       David 'onefang' Seikel
      Contributors:    Tim 'amon' Zebulla
                       Daniel G. '_ke' Siegel
                       Stefan 'slax' Langner
                       Massimiliano 'Massi' Calamelli
                       Thomas 'thomasg' Gstaedtner
                       Roberto 'rex' Sigalotti
    
    ----------------------------- Current Configuration ----------------------------
      Install path:    /opt/e17
      Source path:     /var/cache/e17_src
      Source url:      http://svn.enlightenment.org/svn/e/trunk
      Logs path:       /tmp/easy_e17/install_logs
    
      Packages:        eet evas ecore efreet embryo edje epsilon esmart emotion etk etk_extra ewl exml enhance e_dbus e entrance edje_editor edje_viewer elicit elitaire emphasis empower emprint ephoto estickies exhibit expedite exquisite extrackt e_phys enthrall rage alarm bling calendar cpu deskshow efm_nav efm_path emu execwatch flame forecasts iiirk language mail mem moon mpdule net news notification penguins photo rain screenshot slideshow snow taskbar tclock tiling uptime weather winselector wlan b_and_w
      Skipping:        esmart enhance exml imlib2 edb scrot edje_editor edje_viewer emotion entrance eclair evfs evolve elicit elitaire emphasis empower engycad entrance_edit_gui entropy ephoto estickies expedite exquisite extrackt engage enthrall rage emu flame moon news penguins rain snow language photo efm_path efm_nav e_phys execwatch mpdule notification 
    
      Script action:   install
    --------------------------------------------------------------------------------
    
    -------------------------------- Build phase 1/3 -------------------------------
    - running some basic system checks
    - source checkout/update
    --------------------------------------------------------------------------------
    
    
    ------------------------------- Basic system checks ----------------------------
    - creating script dirs ....... ok
    - 'automake' available ....... ok
    - 'gcc' available ............ ok
    - 'make' available ........... ok
    - 'svn' available ............ ok
    - build-user ................. root
    - adding path to env ......... ok
    - checking lib-path in ldc ... ok (/etc/ld.so.conf.d/e17.conf)
    - setting compile options .... ok
    --------------------------------------------------------------------------------
    
    ----------------------------- Source checkout/update ---------------------------
    - updating sources (please wait, this won't output much) ...
    Checking eet source ... svn: REPORT request failed on '/svn/e/!svn/vcc/default'
    svn: REPORT of '/svn/e/!svn/vcc/default': 400 Bad Request (http://svn.enlightenment.org)
    Any ideas? It makes me run dpkg --configure -a whenever I want to install anything.
    Hi, sorry to know you get problems

    It sems that you can't get svn. We try to look at that later, now to fix dpkg.
    Run:
    Code:
    touch $HOME/_skip_easy_e17_install
    then
    Code:
    sudo apt-get update && sudo apt-get install e17-svn
    That should fix the dpkg issue. (Let me know)


    To check svn problem
    What happens when you run this:
    Code:
    svn co http://svn.enlightenment.org/svn/e/trunk/eet
    ?
    ___________________________________
    ESTRAGON: We've lost our rights?

  3. #23
    Join Date
    Oct 2004
    Beans
    2,324

    Re: HOWTO: installation of e17 from SVN code

    Quote Originally Posted by elli222 View Post
    hi!
    Im using the original easy_e17 script version 1.20 and i cant compile eyesight for some reason, i taught someone here might be able to help,

    error in script...
    Code:
    - eyesight ................... ERROR!      
    --------------------------------------------------------------------------------
    
    ----------------------------------- Last loglines ------------------------------
    gcc -DHAVE_CONFIG_H -I. -I../..  -I../.. -I../../src -I../../src/bin -DPACKAGE=\"eyesight\" -DPACKAGE_DATA_DIR=\"/opt/e17/share/eyesight\" -DPACKAGE_PLUGIN_DIR=\"/opt/e17/lib/eyesight/plugins\" -DLOCALEDIR=\"/opt/e17/share/locale\" -Wall -Werror -g -I/opt/e17/include -I/opt/e17/include/efreet   -I/opt/e17/include   -MT error.o -MD -MP -MF .deps/error.Tpo -c -o error.o error.c
    cc1: warnings being treated as errors
    error.c: In function ‘append_startup_error’:
    error.c:17: warning: implicit declaration of function ‘malloc’
    error.c:17: warning: incompatible implicit declaration of built-in function ‘malloc’
    error.c: In function ‘append_startup_error2’:
    error.c:28: warning: incompatible implicit declaration of built-in function ‘malloc’
    error.c: In function ‘display_startup_error_dialog’:
    error.c:54: warning: implicit declaration of function ‘calloc’
    error.c:54: warning: incompatible implicit declaration of built-in function ‘calloc’
    cc1: warnings being treated as errors
    main.c: In function ‘main’:make[3]: 
    *** [error.o] Error 1
    main.c:27: warning: implicit declaration of function ‘setlocale’
    main.c:27: error: ‘LC_ALL’ undeclared (first use in this function)
    make[3]: *** Waiting for unfinished jobs....
    main.c:27: error: (Each undeclared identifier is reported only once
    main.c:27: error: for each function it appears in.)
    make[3]: *** [main.o] Error 1
    make[3]: Leaving directory `/home/elliot/e17_src/PROTO/eyesight/src/bin'
    make[2]: *** [all-recursive] Error 1
    make[2]: Leaving directory `/home/elliot/e17_src/PROTO/eyesight/src'
    make[1]: *** [all-recursive] Error 1
    make[1]: Leaving directory `/home/elliot/e17_src/PROTO/eyesight'
    make: *** [all] Error 2
    --------------------------------------------------------------------------------
    
    -> Get more informations by checking the log file '/tmp/easy_e17/install_logs/eyesight.log'!
    gonna try clearing my system of e17 and reinstall...

    NOTE: ignoring errors isnt an option, and nor is skipping packages...

    Hi elli222.

    You must know that e17 it's pre-alpha code. Parts of the "official" tree code it's even more beyond that, either done for some api that meanwhile changed or just at prototype stage.
    Thats the case of some folders inside the source tree, specially PROTO.
    They are not suppose to be of any use unless you want to work (as a developer) on it.

    Regrettably the original morlenxus script it's for a much advanced users (internal e17 devs) than the usual desktop users and get such things...

    The app you mention it's from PROTO section and it's an exact illustration of that.
    Just a quick look at error output shows some bad C code (not even related with e17) around malloc functions, even if you managed to compile you will face bad issues like memory leaks.

    You are right, skipping packages are not an option, but a must, the only sane way
    ___________________________________
    ESTRAGON: We've lost our rights?

  4. #24
    Join Date
    May 2007
    Beans
    14

    Re: HOWTO: installation of e17 from SVN code

    All fixed! Thanks! It's installed, I'm off to attempt it now!

  5. #25
    Join Date
    May 2007
    Beans
    14

    Re: HOWTO: installation of e17 from SVN code

    One more issue (let's hope this is the last one). When I attempted to log in under enlightenment, I got an error saying "No exec line in enlightenment." It then loaded the failsafe Gnome.

    I'm just interested in experimenting with Enlightenment, I'm a rather avid fan of Gnome, otherwise.

  6. #26
    Join Date
    Oct 2004
    Beans
    2,324

    Re: HOWTO: installation of e17 from SVN code

    Quote Originally Posted by whyette View Post
    All fixed! Thanks! It's installed, I'm off to attempt it now!
    No problem, glad it's ok.
    (That's a fragility of dpkg, when an install have a problem, sometimes a simple nonexistent path or a failure command, it can stay "broken" due to the unfinished package installation... )


    Quote Originally Posted by whyette View Post
    One more issue (let's hope this is the last one). When I attempted to log in under enlightenment, I got an error saying "No exec line in enlightenment." It then loaded the failsafe Gnome.

    I'm just interested in experimenting with Enlightenment, I'm a rather avid fan of Gnome, otherwise.
    Ok. The above command make dpkg finish the installation, overpassing the issue, by skipping the e17 compilation. You shouldn't have e17 install it yet.

    You need to see if it's a svn problem, if you get some broken revision of the sources or have any network issue...

    Can you tell me whats the output of:
    Code:
    ls /var/cache/e17_src/
    ?
    If you have 26 folders, including one called "e", then try:
    Code:
    sudo easy_e17.sh -i
    otherwise post here.
    ___________________________________
    ESTRAGON: We've lost our rights?

  7. #27
    Join Date
    May 2007
    Beans
    14

    Re: HOWTO: installation of e17 from SVN code

    Only one item was listed under ls:

    eet.

  8. #28
    Join Date
    Oct 2004
    Beans
    2,324

    Re: HOWTO: installation of e17 from SVN code

    Quote Originally Posted by whyette View Post
    Only one item was listed under ls:

    eet.
    Ah. so your previous installation aborted (for some reason...) at 1st package. But seems to at least connect to svn server.

    I think the best option now would be clean any possible borked code and then install from new source:
    Code:
    sudo rm -rf /var/cache/e17_src
    sudo easy_e17.sh -i
    (check if you have cvs installed too, since there's an old dependency left on etk package that require it. It can be deleted after e17 installs)

    Hope it runs well this time!
    ___________________________________
    ESTRAGON: We've lost our rights?

  9. #29
    Join Date
    Jan 2007
    Beans
    11

    Re: HOWTO: installation of e17 from SVN code

    is there any way i can try out entropy ? i seemed to remember being able to use it when compiling from cvs awhile back, but now when i try
    but running the script with only entropy doesnt seem to install.
    Is ths because they moved the folder to OLD or something?
    Thanks
    Dave

  10. #30
    Join Date
    Mar 2007
    Location
    $HOME (Washington State)
    Beans
    4,590

    Re: HOWTO: installation of e17 from SVN code

    Quote Originally Posted by djvantri View Post
    is there any way i can try out entropy ? i seemed to remember being able to use it when compiling from cvs awhile back, but now when i try
    but running the script with only entropy doesnt seem to install.
    Is ths because they moved the folder to OLD or something?
    Thanks
    Dave
    Yes, Entropy is old so it was moved to old. The script might be broken for those apps since they are in old.
    See my themes here! | Dont preach Linux, mention it | Make GNOME Themes
    I'm no longer on here. If you want to talk to me, go to noost.org.
    My DeviantArt | Linux user #461096 | Ubuntu user #15753

Page 3 of 59 FirstFirst 123451353 ... LastLast

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •