Results 1 to 4 of 4

Thread: [SOLVED] Hostnames issues

  1. #1
    Join Date
    Oct 2007

    Exclamation [SOLVED] Hostnames issues

    Hi everyone, I'm having the following issues:

    I'm in a network, that is full of computers. I used to be able to browse around them using nautilus to access the shared folders.
    But now something is changed. I can still browse normally and view whatever is shared in each computer, but when I double click a shared folder to browse it, I am asked for a login and the Nautilus just stops (as in crashes) there. The folder shows up as mounted in my desktop, but it won't open.
    The computer name is "bolseiros" and it's IP address is This is just an example, the same happens with many others - both running XP and Ubuntu+Samba.
    If I type the path like: smb://bolseiros, I get the same result.
    If I type the path like: smb:// - It works. I get prompted for a login and I can browse the folder like normally.

    Anyone have any idea what could be causing this?
    if I type in a terminal:
    ping bolseiros - I get a timeout.

    ping - It pings fine.

    I can ping a few computers using the hostname, but it seems somewhat random...
    This only started happening a short time ago - like last week.
    I've done some browsing and I can't seem to find this problem, much less a solution.

    Thanks in advance!

  2. #2
    Join Date
    Sep 2006
    Solihull/Piraeus (UK/GR)
    Ubuntu 11.10 Oneiric Ocelot

    Re: Hostnames issues

    Make sure that you have winbind installed:

    sudo apt-get install winbind
    And also check that "wins" is listed in the hosts line of the file /etc/nsswitch.conf (post the contents if unsure):

    cat /etc/nsswitch.conf

  3. #3
    Join Date
    Oct 2007

    Re: Hostnames issues

    Hi and thanks for your reply!

    Yes, winbind is installed, and my /etc/nsswitch.conf has wins in the hosts line:
    # /etc/nsswitch.conf
    # Example configuration of GNU Name Service Switch functionality.
    # If you have the `glibc-doc-reference' and `info' packages installed, try:
    # `info libc "Name Service Switch"' for information about this file.
    passwd:         compat
    group:          compat
    shadow:         compat
    hosts:          files mdns4_minimal [NOTFOUND=return] dns wins mdns4
    networks:       files
    protocols:      db files
    services:       db files
    ethers:         db files
    rpc:            db files
    netgroup:       nis
    I had been to that route before, but maybe your more skilled eyes can find something worth changing in this file...

    Thanks again.

  4. #4
    Join Date
    Oct 2007

    Re: Hostnames issues


    Just wanted to let you know I have solved my problem. I found the solution on this thread:

    I now can ping all computers using hostname and use samba connections with nautilus just like before.

    I don't know what went wrong here, tough.

    Anyway, thanks for your help!

    Edit: It was the part about editing /etc/samba/smb.conf that made it work.
    Last edited by Stunts; September 11th, 2008 at 09:14 AM.

Tags for this Thread


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts