Page 1 of 2 12 LastLast
Results 1 to 10 of 19

Thread: [SOLVED] failed to mount NTFS drives

  1. #1
    Join Date
    Mar 2007
    Beans
    201
    Distro
    Ubuntu 10.10 Maverick Meerkat

    [SOLVED] failed to mount NTFS drives

    Hi,

    I am a ubuntu user and I do not use windows. But for some reason, i needed to install xp yesterday. So i formatted ubuntu drive and installed xp there but my xp system crashed so I reinstalled ubuntu. Now i see that i can't mount any drive. I suspect it might be a virus problem for which xp crashed( again it's only my guess, i have no idea why it crashed :-p ).

    Here is the error message i receive from ubuntu :

    http://i38.tinypic.com/8z38l0.png

  2. #2
    Join Date
    Mar 2008
    Location
    City of Pines
    Beans
    3,585

    Re: failed to mount NTFS drives

    Probably you have an unclean shutdown on your windoze OS (If you're dual booted) thus it produce this kind of error:

    On your terminal, as the message displayed:

    Code:
    sudo mount -t ntfs-3g /dev/sda8 /media/Others -o force
    Steady movement is more important than speed, much of the time. So long as there is a regular progression of Stimuli to get your mental hooks into, there is room for lateral movement. Once this begins, its rate is a matter of discretion.

  3. #3
    Join Date
    Mar 2007
    Beans
    201
    Distro
    Ubuntu 10.10 Maverick Meerkat

    Re: failed to mount NTFS drives

    I did not dual boot . I did a clean install of windows . Then after the crash i formatted windows and install ubuntu there.

    Here is the output of that command :

    $LogFile indicates unclean shutdown (0, 0)
    WARNING: Forced mount, reset $LogFile.
    fuse: failed to access mountpoint /media/Others: No such file or directory

  4. #4
    Join Date
    Mar 2008
    Location
    City of Pines
    Beans
    3,585

    Re: failed to mount NTFS drives

    Huh, I'd copied the mount point on your error message and it's not present in your system. Try posting the result of the command below:

    Code:
    cat /etc/fstab
    and

    Code:
    sudo fdisk -l
    Steady movement is more important than speed, much of the time. So long as there is a regular progression of Stimuli to get your mental hooks into, there is room for lateral movement. Once this begins, its rate is a matter of discretion.

  5. #5
    Join Date
    Mar 2007
    Beans
    201
    Distro
    Ubuntu 10.10 Maverick Meerkat

    Re: failed to mount NTFS drives

    # /etc/fstab: static file system information.
    #
    # <file system> <mount point> <type> <options> <dump> <pass>
    proc /proc proc defaults 0 0
    # /dev/sda1
    UUID=2c79bd70-e27d-4065-9a91-8b2a90ef48a0 / ext3 relatime,errors=remount-ro 0 1
    # /dev/sda3
    UUID=182f0cd7-26ec-4acd-92f5-01c7b931e27b none swap sw 0 0
    /dev/scd0 /media/cdrom0 udf,iso9660 user,noauto,exec,utf8 0 0
    /dev/scd1 /media/cdrom1 udf,iso9660 user,noauto,exec,utf8 0 0
    here they r :
    Disk /dev/sda: 160.0 GB, 160041885696 bytes
    255 heads, 63 sectors/track, 19457 cylinders
    Units = cylinders of 16065 * 512 = 8225280 bytes
    Disk identifier: 0x0cd70cd6

    Device Boot Start End Blocks Id System
    /dev/sda1 * 1 3562 28611733+ 83 Linux
    /dev/sda2 3793 19457 125829112+ f W95 Ext'd (LBA)
    /dev/sda3 3563 3792 1847475 82 Linux swap / Solaris
    /dev/sda5 3793 7757 31848831 7 HPFS/NTFS
    /dev/sda6 7758 11722 31848831 7 HPFS/NTFS
    /dev/sda7 11723 15687 31848831 7 HPFS/NTFS
    /dev/sda8 15688 19457 30281728 7 HPFS/NTFS

    Partition table entries are not in disk order

  6. #6
    Join Date
    Mar 2008
    Location
    City of Pines
    Beans
    3,585

    Re: failed to mount NTFS drives

    Ow. I forgot, do include what displays with this command:

    Code:
    ls -l /media
    Steady movement is more important than speed, much of the time. So long as there is a regular progression of Stimuli to get your mental hooks into, there is room for lateral movement. Once this begins, its rate is a matter of discretion.

  7. #7
    Join Date
    Mar 2007
    Beans
    201
    Distro
    Ubuntu 10.10 Maverick Meerkat

    Re: failed to mount NTFS drives

    Output :

    total 8
    lrwxrwxrwx 1 root root 6 2008-09-10 20:39 cdrom -> cdrom0
    drwxr-xr-x 2 root root 4096 2008-09-10 20:39 cdrom0
    drwxr-xr-x 2 root root 4096 2008-09-10 20:39 cdrom1

  8. #8
    Join Date
    Mar 2008
    Location
    City of Pines
    Beans
    3,585

    Re: failed to mount NTFS drives

    On your terminal:

    -Create a mount point:

    Code:
    sudo mkdir /media/Others
    and do the mounting:

    Code:
    sudo mount -t ntfs-3g /dev/sda8 /media/Others -o force
    Steady movement is more important than speed, much of the time. So long as there is a regular progression of Stimuli to get your mental hooks into, there is room for lateral movement. Once this begins, its rate is a matter of discretion.

  9. #9
    Join Date
    Mar 2007
    Beans
    201
    Distro
    Ubuntu 10.10 Maverick Meerkat

    Re: failed to mount NTFS drives

    Wha ! Man it worked

    Can you explain what those codes do ?

    The first one creates a directory in /media/Others i think. But what is the necessity ?

    I don't understand the second command . Never used so many options when mounting :-p

  10. #10
    Join Date
    Mar 2008
    Location
    City of Pines
    Beans
    3,585

    Re: failed to mount NTFS drives

    Quote Originally Posted by Louis de Broglie View Post
    Wha ! Man it worked

    Can you explain what those codes do ?

    The first one creates a directory in /media/Others i think. But what is the necessity ?

    I don't understand the second command . Never used so many options when mounting :-p
    The first command will create a mount point for your device ( sda8 ).

    Code:
    sudo mkdir /media/Others
    The seconds command forces the mount command even if errors are incurred.

    Code:
    sudo mount -t ntfs-3g /dev/sda8 /media/Others -o force
    For more info on mount, you could:

    Code:
    man mount
    ------------------------------------------------------------------------

    If you like you could auto mount your sda8 partition everytime you boot your computer. You have to include it in your fstab file.

    Unmount the partition:

    Code:
    sudo umount /media/Others
    Then open fstab for editing:

    Code:
    gksudo gedit /etc/fstab
    and insert the lines of text below on the bottom-most part of the file (Copy and Paste it).

    Code:
    /dev/sda8 /media/Others     ntfs    defaults,umask=007,gid=46 0       1
    Save and Close the file. And, on your terminal again:

    Code:
    sudo mount -a
    Last edited by iaculallad; September 10th, 2008 at 12:37 PM.
    Steady movement is more important than speed, much of the time. So long as there is a regular progression of Stimuli to get your mental hooks into, there is room for lateral movement. Once this begins, its rate is a matter of discretion.

Page 1 of 2 12 LastLast

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •